RB750r2 (hexLite) with mem W25Q128JV


I have been using OpenWRT in a RB750r2 model that has W25Q128FV SPI NOR Flash. Recently, I buy some new RB750s and I can see that the memory changes to W25Q128JV.
The installation procedure that I use always is boot initramfs image that I've builded some time ago, under RouterBoot, flash U-Boot and Image and then use the router.

Now, initially after boot the initramfs image, the mtd devices 0-4 aren't writeable. With the mtd-rw kernel module I've done writeable, but, when I try to erase the flash in order to write new image, I got errors with 'mtd erase', 'flash_erase', 'flash_eraseall' (Invalid arguments, MEMERASE Error 22, etc)

I've tried to use flash_unlock but it says that the flash is already unlocked,

I've recompiled the initramfs image adding 'mtdparts' to the cmdline in order to use new layout of mtd partitions that hasn't ro (readonly) option, but seems it's like the kernel ignore it because when I query the cmdline with 'cat /proc/cmdline' I see the cmdline that I write in the kernel_menuconfig option, but the mtd layout (cat /proc/mtd) not changes (is the same always).

Any idea? Thanks in advance!

PD: I was tried to remove the SPI memory and programmed with SPI Programmer and flashrom utility and is working (u-boot + openwrt) but I have to do this with several routers and I can't unmount/remount the SPI memory to all.

Take a look at the U-Boot parameters, as well as if your kernel/init have been patched to ignore them or not. It might be possible that the OEM changed them.

(My gut feeling is that the SPI NOR change is a "red herring" and not the cause of the problem.)

Dear jeff,

First of all thanks for you quickly answer. U-boot at this moment not is installed. The actual bootloader is the original RouterBoot. I need to replace it for the U-Boot but this is the problem, I can't erase mtd0-4 in order to replace it.