RB750Gr3 help please

I am trying to replace an old power-hungry computer running Shorewall(6), and a Mikrotik RB750Gr3-hEX running OpenWRT appeared to be ideal as WiFi is not required. I now have one recent and one older secondhand RB750Gr3 version, and am trying to install OpenWRT without bricking either box. The instructions seen so far advise doing a test run first to make sure it will work before a forced direct installation. What is the current position regarding OpenWRT and Mikrotik RB750Gr3 hardware? The Table of Hardware information may be a couple of years old and out of date, and I have seen hints that the OpenWRT software may not work unless the original Mikrotik RouterOS is an early version and has not been updated to the current stable 6.48.6. I have two computers connected to the ethernet E02 via an unmanaged switch, one running atftpd, the other running tftpd-hpa, trying to install RouterOS version 6.45.8, then OpenWRT, but without success so far. although I have managed to ftp that version to "flash" on the recent one, but then the log complains that it is too old while trying to run or install from there. I can insert a MicroSD and/or USB memory and ftp files to them, and do intend to use external Flash and swap file space to assist the internal memory. Any advice on how to proceed, or which external memory would be best for speed and reliability, would be very welcome. Thanks.

For (non-ancient) Mikrotik NOR device, as long as your RouterBOOT version is below 7, you should be able to boot an installed OpenWrt image. If you are using BOOTP (not DHCP) for network boot, RouterBOOT version does not matter (buggy DHCP in some versions). Examples:

[admin@MikroTik-sfp] > /system routerboard print 
  factory-firmware: 3.35
  current-firmware: 6.46.5
[admin@MikroTik-sfp] > /system routerboard settings print 
               boot-device: nand-if-fail-then-ethernet
             boot-protocol: bootp

RouterOS will not install a version lower than the factory-firmware version. If you do have a RouterBOOT v7 device, you can build an image (bootimage NPK) that will boot (but the OpenWrt buildbot images will not).
The netboot process is the same to reinstall RouterOS (netinstall), or run the OpenWrt initramfs image. Safest way to trigger this is with the hardware button (watch the LEDs to know the timing), and read the manual to know the LED patterns. That way you know how to recover if you can no longer modify soft-config settings.
I use dnsmasq (would need dnsmasq-full package on OpenWrt) for this, with --dhcp-host, --bootp-dynamic, and --dhcp-boot flags.

1 Like

Thanks, I will continue trying. I am still finding my way round the original RouterOS, and tftp, but am not in an emergency rush, so prepared to continue to RTFM..

Hi, just having a bit of an issue myself. I've had a RB750Gr3 running Open WRT for years and must say I'm pretty impressed with it. I thought I'd get myself another one as a backup and must say that it's being a complete pain getting OpenWRT on it. It did come with version 7 which was an extra step I've had to deal with, but I just can't seem to get it to take. I've downgraded RouterOS twice, so now with the oldest version I can get from the Mikrotik archive (6.45) and that runs fine. I can get the OpenWRT initramfs version to boot fine, but then when I try to install the sysupgrade version it gets itself stuck in a power up reset loop. I can go back and put RouterOS back on no issues or I can go back to the initramfs version so I'm completely foxed. Unfortunately I didn't note down what version of RouterOS v7 it was and whether that's somehow made a difference? The bootloader with v6.45 comes up as 3.35 when I run cat /sys/firmware/mikrotik/hard_config/booter_version from initramfs so presume that's not the issue. Any ideas?
Cheers, Matt.

Make sure the primary RouterBOOT (cat /sys/firmware/mikrotik/soft_config/bios_version) was downgraded to a v6.
cat /sys/firmware/mikrotik/hard_config/booter_version is the backup RouterBOOT version. Hold in the reset switch when applying power (then immediately let go once any LEDs to continue normal boot) to use the backup. If that boots installed image, primary is v7.
Otherwise, attaching to UART pads is best debug. Other option of installing sysupgrade, then rebooting into initramfs to inspect SPI NOR (mtd).

it's interesting to know other people are trying this box with the latest openwrt(22.03). Here my rb750gr3 just came in a few days ago and it came with mikrotik's routeros 6.x something, it was 6.48.x iirc -- but I could not downgrade it below 6.48.4. However said, I was able to tftpboot openwrt's initramfs for it, and used the luci interface to permanently burn the firmware. I am able to power-up with the only issue that hardware-offloading seems not to be working at gigabit speeds. I got this router thinking MT7621 is properly supported for offloading and I've read others on other threads solving speed issues with this particular box hardware, but for some reason it is not working in my case. I checked the SW/HW offloading settings in the Firewall tab, and it makes no difference.

Anyone lately using this hardware and not getting +500Mbit performance-testts with iperf? I also tested iperf with the firewall stopped, still no luck.. The maximum speeds is lurking only at 300-500Mbits...


fwiw the iperf tests I've done is between WAN-interface(direct-link to local PC interface) --> this performs at around 500Mbit.

When I test from LAN-to-Wan-interface(again the WAN-interface still connected to an external PC interface), it drops dramatically to 300Mbit.

I'm wondering if offloading is really supported or may have become broken in later openwrt releases, as others are reporting success back in 2017 with much older firmware...

I looked at the link-speed reporting and take note of linux's "ethtool interface" and it always shows full-duplex 1-Gbit for mikrotik's WAN and LAN interface. I test with short rj45 cables and iperf performs perfect 931Mbit+ with the same cables between two PC interfaces I am utiilizing for the tests, so the issue has to be inside mikrotik running openwrt 22.03.

any feedback appreciated as this is my second attempt with this after another router I have has a closed binary-firmware for its offloading - this cannot be used with openwrt so this restricts me from using it beyond half-link speeds which is as you know it obviously not acceptable.