RaspberryPi 3b - No CPU thermal support in 18.06.0


#1

Hi,

I noticed some changes at github regarding the bcm2835_thermal driver on the RaspberryPi 3. For some reason neither of the BCM2709 or BCM2710 targets seem to support the CPU's thermal sensor anymore.

I did install the following modules:
kmod-hwmon-core
kmod-hwmon-bcm2835
But this didn't help.

In LEDE 17.01.4 it worked fine (even without the modules), but in OpenWRT 18.06.0 there is no entry in /sys/class/thermal/
I also tested a RaspberryPi A+ which uses the BCM2708 target, and it did support the thermal sensor.

So my question is, Am I the only one experiencing this? Or did I miss something?

Regards,
Time


#2

No one experienced this issue? Or am I the only one interested in the SoC's temperature :slight_smile:


#3

I can confirm that problem still exist in 18.06.1. Installing kmod-hwmon-bcm2835 not resolve the problem. Propably this is caused by kernel config (cpu thermal).


#4

That's what I thought at first. But it is enabled for as far as I can see.

CONFIG_THERMAL is set to "y" in the kernel config. Maybe there is something wrong in the kernel but if so I would assume that more people would complain online.

There is however a "CONFIG_CPU_THERMAL" which is not set. This entry was not in LEDE 17.04 so maybe thats the cause. It is how ever in the bcm2708 config as well and since the raspberryA+ works fine I'm not sure if it actually matters.


#5

Hello

It seems to make sense what you are saying.
As the docs page (https://openwrt.org/docs/techref/targets/brcm2708) doesn't mention anyone specifically that looks after this target, perhaps you can try to contact one of the several people who sent commits for this targets. In this URl there a list of them: https://git.openwrt.org/?p=openwrt/openwrt.git&a=search&h=HEAD&st=commit&s=brcm2708


#6

To resolve problem this patch should be backported: https://patchwork.kernel.org/patch/9972399/

Resolved in 4.15+


#7

It would be great if fixed.

But If im not mistaken the BCM2709 are arm32 builds right? Your linked patch only applies on arm64 builds.

I tested the BCM2709 OpenWRT builds aswel and the thermal sensor was not found. Did you test this patch?


#8

Can you try Stijns 4.14 branch?
https://git.openwrt.org/?p=openwrt/staging/stintel.git;a=shortlog;h=refs/heads/brcm2708-4_14


#9

On Stijns 4.14 branch I got:
cat /sys/class/thermal/thermal_zone0/temp cat: read error: Invalid argument
But when I set CONFIG_BCM2835_THERMAL=y, it works perfect.


#10

Yes on Stijns kernel 4.14 CPU thermal works on the Raspberry Pi 3+ when is enabled , also CPU frequency works now on statistics, it was not working on 4.9

thermal


#11

So both of you enabled: CONFIG_BCM2835_THERMAL?


#12

It has to be enable on the kernel menu

Screenshot_20181115_184703


#13

But isn't that where the kmod-hwmon-bcm2835 is for?