Raspberry Pi4 USB wifi

Hello, i've been attempting to use a usb3 wifi device on my raspberry pi4, and i'm a little lost.
It seems to detect the device ok. The guide i've been following (after installing a lot of packages) says all i need to do is
ifconfig wlan1 up.

I don't have a wlan1, and i'm looking in the /etc/config/wireless and see only one wifi radio and wifi interface.
when i lsusb or dmesg,it finds the device, but i'm not sure which driver it needs.

This is the closest message i can find in dmesg...
new high-speed USB device number 5 using xhci_hcd

and lsusb
ID 0bda:b812 Realtek USB3.0 802.11ac 1200M Adapter

I've tried googling the ID, seems like others have been looking for a 8812bu or 88x2bu driver, and i've tried installing all the 8812 drivers in software packages.
Any pointers welcome :slight_smile:

If you're attempting to use it as an AP, it probably won't work - Realtek device specific code usually doesn't support it.


+1 to what @frollic said. But even if it could work as an AP, also consider that most USB wifi adapters are not optimized for this use. The performance will be poor compared to generally any proper AP or even integrated wifi router.

The Pi4 is an excellent wired router when running OpenWrt, but you will be much better served with a proper wifi AP.


I chose this wifi adapter because it said it had linux support (and in fact, the box says so also), but i think they've back pedalled, and now on the website says "does NOT support linux". So for now,the project is on hold lol.

Thanks, I remember attempting something like this a while back with the onboard wifi, but the onboard wifi, as you've mentioned, was not so good.
A year or 2 later, i thought i'd try a usb wifi device.
I do have a spare wifi access point i could use with this though, although it was going to be used for something else. :slight_smile:

Linux support doesn't automatically include AP mode.... :slight_smile:

lol If only :slight_smile: but, where would the fun be in that :slight_smile:

I never caught the last part of your message, i wasn't aware that realtek had specific code, interesting. Thanks:)

All hardware vendors do, Realtek are just extremely bad at maintaining it...


I'll know in future.

Just an FYI for anyone interested.
The person who gets this working uses a...

Wireless WiFi USB Dongle Stick Adapter RT5370 150Mbps.
Might try and revisit this with the right hardware next time. :slight_smile:

Ralink RT5572 also works in AP mode but don't expect more than 70Mbps


You could study https://github.com/morrownr/USB-WiFi

Note the link isn't openwrt specific.


70Mbps is not too bad, thanks :+1:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.