Raspberry Pi Zero W fails to boot

I've been trying (and failing) to get OpenWrt installed on a Raspberry Pi Zero W. I've tried the factory.img of both 18.06.3 and 18.06.4 and they both fail in the same way. After starting to boot, they both get to the following line and hang

[    8.085829] kmodloader: done loading kernel modules for /etc/modules.d/*

The only interesting lines I see in the boot output are

[    7.736109] brcmfmac: mmc1:0001:1: Direct firmware load for crcm/brcmfmac43430-sdio.raspberrypi,model-zero-w.txt failed with error -2
[    7.736109] brcmfmac: mmc1:0001:1: Falling back to user helper
[    7.785533] firmware brcm!brcmfmac43430-sdio.raspberrypi,model-zero-w.txt: firmware_loading_store: map pages failed

And a similar error for brcm/brcmfmac4340-sdio.clm_blob

The only real relevant post I've seen is this one, but their explanation of a fix makes no sense to me.

I haven't used it, have you tried http://downloads.openwrt.org/releases/18.06.4/targets/brcm2708/bcm2708/openwrt-18.06.4-brcm2708-bcm2708-rpi-ext4-sysupgrade.img.gz?

See also: https://medium.com/@matthewhuie/connecting-a-raspberry-pi-zero-to-a-network-via-usb-on-the-go-and-openwrt-8995a58ec151

With the .sysupgrade.img how is that applied? I'm assuming it's not just dd'd on the card like "normal" since the article states that it starts with a base instance of raspbian

OK, have you followed the last link?

Yes, and nowhere in that article does it mention the sysupgrade image or actually installing OpenWrt anywhere. The steps only include configuring the OTG usb (which I'm not using) and enabling the USB modules. It seems to be missing a step of setting up OpenWrt since it skips directly to using the uci commands.

Can you be specific as to where in the last link I'm not reading?

OK, it's my mistake, but by this link there is explanation, how to edit files. See also https://openwrt.org/toh/raspberry_pi_foundation/raspberry_pi, I don't see factory image (the cell is empty) for your device.

I'm very comfortable editing files.

Since there is no factory image, does that mean that it is unsupported? Or is there an alternate method for installing OpenWrt on this device?

There is image in the corresponding folder: http://downloads.openwrt.org/releases/18.06.4/targets/brcm2708/bcm2708/openwrt-18.06.4-brcm2708-bcm2708-rpi-ext4-factory.img.gz Have you tried it exactly?

Yes, I have. I've tried that image and the 18.06.3 image several times

Have you edited the file (in the OP you've written, that you don't understand the issue) according to https://openwrt.org/toh/raspberry_pi_foundation/raspberry_pi#using_i2c_and_spi?

In the 18.06.4 image, those values are already set in the config.txt

OK, and the last tip, have you pressed Enter on keyboard?

Yes, and nothing happens

I can't find dtparam=i2s=on in the file. It is small issue, but it is last isue.

I did try with that after you mentioned it but it made no difference

I'm honestly not sure if it was a bad download, a bad keyboard or what, but it is now working. I re-downloaded the image, re-flashed and used a different keyboard (with a USB hub) and everything worked.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.