Raspberry Pi usb AP not coming up

I'm trying to do a Raspberry Pi following this guide from Network Chuck, https://www.youtube.com/watch?v=jlHWnKVpygw&t=124s&ab_channel=NetworkChuck I get to the point where he says to run the command ifconfig wlan1 up but I get the error ifconfig:SIOCGIFFLAGS: No such device. My USB Adapter does show up using lsusb. Ive tried it using both the most current stable build for the Rpi and I even went back and found the version he used in the video still no luck, hoping someone here thats smarter than me can help

What usb adapter is it?
What does lsusb say, precisely ?

lsusb showing a device =/= there is driver for your system.

Also note that not all usb wifi adapters actually support AP mode. It entirely depends on the chipset.

1 Like

lsusb pulls it up at Bus 001 Device 003: ID 0846:9053 NETGEAR A6210

I should also note in this I am not by any means someone who understands networking (or linux for that matter), Im just a guy who thought this would be a good way to repurpose a Rpi I was no longer using for what I bought it for

Have a look at Openwrt not support Netgear A6210?

Most of that is jibberish to me but Im guessing I run install wpad-basic-wolfssl and hopefully that work

And the drivers for the MT7612U chipset...


(you can see the wireless chip it uses by looking here)

1 Like

I know Im dumb when it comes to this but I try to install the drivers with opkg install kmod-mt76-usb and it get the following response

Unknown package 'kmod-mt76-usb'.
Collected errors:

  • opkg_install_cmd: Cannot install package kmod-mt76-usb.

Did you run opkg update first?

yes I had, I got frustrated and started from scratch by doing a fresh flash of my micro sd card, set everything up again, ran update ran the kmod-mt76-core and kmod-mt76-usb, still didnt work then I tried running install kmod-mt76x2u from the forum post shared by frollic and it accepted my ifconfig wlan1 up command so I am hopeful its finally going to work for me

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.