Raspberry pi : internet from the client but can't update list of software

I set up openWRT on a Raspberry Pi 4

for now, I have my br-lan as LAN with a static IP of 192.168.1.200
I added a new interface protocol DHCP Client , devices eth0
and I enabled the wifi too.

when I'm connected to the WIFi I do have internet but when I connect to openWRT (192.168.1.200) and I try to update lists (System>Software) I have an error
also I'm not sure if I did that right but I setup the wan to eth0 while the LAN with BR-LAN

Downloading https://downloads.openwrt.org/releases/22.03.3/targets/bcm27xx/bcm2711/packages/Packages.gz
*** Failed to download the package list from https://downloads.openwrt.org/releases/22.03.3/targets/bcm27xx/bcm2711/packages/Packages.gz

Downloading https://downloads.openwrt.org/releases/22.03.3/packages/aarch64_cortex-a72/base/Packages.gz
*** Failed to download the package list from https://downloads.openwrt.org/releases/22.03.3/packages/aarch64_cortex-a72/base/Packages.gz

Downloading https://downloads.openwrt.org/releases/22.03.3/packages/aarch64_cortex-a72/luci/Packages.gz
*** Failed to download the package list from https://downloads.openwrt.org/releases/22.03.3/packages/aarch64_cortex-a72/luci/Packages.gz

Downloading https://downloads.openwrt.org/releases/22.03.3/packages/aarch64_cortex-a72/packages/Packages.gz
*** Failed to download the package list from https://downloads.openwrt.org/releases/22.03.3/packages/aarch64_cortex-a72/packages/Packages.gz

Downloading https://downloads.openwrt.org/releases/22.03.3/packages/aarch64_cortex-a72/routing/Packages.gz
*** Failed to download the package list from https://downloads.openwrt.org/releases/22.03.3/packages/aarch64_cortex-a72/routing/Packages.gz

Downloading https://downloads.openwrt.org/releases/22.03.3/packages/aarch64_cortex-a72/telephony/Packages.gz
*** Failed to download the package list from https://downloads.openwrt.org/releases/22.03.3/packages/aarch64_cortex-a72/telephony/Packages.gz
Errors

Failed to send request: Operation not permitted
Failed to send request: Operation not permitted
Failed to send request: Operation not permitted
Failed to send request: Operation not permitted
Failed to send request: Operation not permitted
Failed to send request: Operation not permitted
Collected errors:
 * opkg_download: Failed to download https://downloads.openwrt.org/releases/22.03.3/targets/bcm27xx/bcm2711/packages/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download https://downloads.openwrt.org/releases/22.03.3/packages/aarch64_cortex-a72/base/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download https://downloads.openwrt.org/releases/22.03.3/packages/aarch64_cortex-a72/luci/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download https://downloads.openwrt.org/releases/22.03.3/packages/aarch64_cortex-a72/packages/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download https://downloads.openwrt.org/releases/22.03.3/packages/aarch64_cortex-a72/routing/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download https://downloads.openwrt.org/releases/22.03.3/packages/aarch64_cortex-a72/telephony/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.
The opkg update command failed with code 6.

PS this is temporary, I have a hat with a secondary NIC (USB 3.2 Gen1 And Gigabit Ethernet HUB HAT for Raspberry Pi, 3x USB, 1x Gigabit ETH, Driver-Free) which I'm gonna use for LAN
and the primary NIC as WAN (no wifi)

Config :

config interface 'loopback'                                                     
        option device 'lo'                                                      
        option proto 'static'                                                   
        option ipaddr '127.0.0.1'                                               
        option netmask '255.0.0.0'                                              
                                                                                
config globals 'globals'                                                        
        option ula_prefix 'fd7f:511f:af01::/48'                                 
                                                                                
config device                                                                   
        option name 'br-lan'                                                    
        option type 'bridge'                                                    
        list ports 'eth0'                                                       
                                                                                
config interface 'lan'                                                          
        option device 'br-lan'                                                  
        option proto 'static'                                                   
        option netmask '255.255.255.0'                                          
        option ip6assign '60'                                                   
        option ipaddr '192.168.1.200'                                           
                                                                                
config interface 'WAN'                                                          
        option proto 'dhcp'                                                     
        option device 'eth0'                                                    
                                                                                
config device                                                                   
        option name 'eth0'

I changed the WAN settings but still can't ping google.com

config interface 'WAN'
        option proto 'dhcp'
        option dns '1.1.1.1 8.8.8.8'
        option device 'eth0'

You have both your wan and lan operating with eth0.

delete the WAN interface and the device definition:

Then, add a gateway and DNS to your lan interface (typically both addresses will be for your main router -- maybe 192.168.1.1??)

1 Like

Thank, I will try this.
For now I only have one NIC since I need to have internet access to install the package for my second NIC

I'll remove the WAN interface but will I be able to install the RTL8153B package (which is the one I think I need?)

-- yes my gateway is 192.168.1.1, but I was hoping to setup some kind of DHCP so I can have internet on whatever gateway I'm connected too

reconfigure the lan as DHCP client, instead of static AP.

1 Like

I'll try this, I'm use a second raspberry Pi for now (which work fine) and when I'll have a bit more time I'll test this one again.
closing for now.
thanks

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.