Raspberry Pi 4 Unable to access SSH over wifi

have u an arduino ? or ch340 usb ?
this config working proprely with a lan bridge and wlan0
reset upload uci commit reboot


config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'
        option ip6assign '60'



config interface 'lan'
        option proto 'static'
        option delegate '0'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option type 'bridge'


==================================

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/soc/fe300000.mmcnr/mmc_host/mmc1/mmc1:0001/mmc1:0>
        option channel 'auto'
        option noscan '1'
        option country 'FR'
        option legacy_rates '0'
        option hwmode '11g'

config wifi-iface 'wifinet0'
        option device 'radio0'
        option mode 'ap'
        option ssid 'OpenWrt'
        option network 'lan'

Unfortunately I do not. I am attempting to connect my Raspberry Pi to a portable monitor I have but it seems to get no signal. I'm converting from Mini HDMI to HDMI, then to USB C, so that might be the problem...

okay now u have this solution :frowning:

  • reformate sd
  • reinstall openwrt sysfs factory
    -launch
  • on u pc connect to u home wifi
    -pc partage connexion from wifi to ethernet
    -pc config ip : 192.168.1.2 , netm , 255.255.255.0 , dns 1.1.1.1
  • plug the rpi4 rj45
    -check ip lan 192.168.1.2 ok ?
    -connect ssh
    -first ! first !
  • uci set network.lan.gateway=192.168.1.1
    -uci set network.lan.dns=1.1.1.1
    -uci commit network
    -uci commit
    -reboot
    -connect ssh
  • ping google.fr
    if ok =
    -opkg update
    -opkg install luci-nginx
    and good for this point

them if nok ping =

1 check gateway and dns on uci config
2 check ( partage connexion from wifi ton ethernet )
3 check ip pc

Thank you for the suggestion. So I got so far as reconnecting to the Raspberry Pi after rebooting it, but it seems to have no internet.

I'm currently have 2 ethernet cables connected to my laptop, one via the ethernet port and the other via usb c. I can confirm that internet is working and that I can connect to the Raspberry Pi. But the Raspberry Pi doesn't seems to receive the internet at all.

I am using Windows 10 and have configured internet sharing through the "Sharing" tab of the network adapter properties.

I've put my config and debug info below.

root@OpenWrt:~# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master br-lan state UP qlen 1000
    link/ether dc:a6:32:01:fb:66 brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether dc:a6:32:01:fb:67 brd ff:ff:ff:ff:ff:ff
4: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether dc:a6:32:01:fb:66 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global br-lan
       valid_lft forever preferred_lft forever
    inet6 fd61:11aa:e1f1::1/60 scope global
       valid_lft forever preferred_lft forever
    inet6 fe80::dea6:32ff:fe01:fb66/64 scope link
       valid_lft forever preferred_lft forever
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd61:11aa:e1f1::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option dns '1.1.1.1'

root@OpenWrt:~# ping 1.1.1.1
PING 1.1.1.1 (1.1.1.1): 56 data bytes
ping: sendto: Network unreachable

Default configuration
Log in by Ethernet (which by default is on the LAN network)
Enable wifi AP on LAN
Disconnect Ethernet, connect laptop to Pi's wifi and log in again.
Take eth0 out of LAN and attach it to WAN (proto dhcp)
Connect Ethernet cable to modem
Determine IP of the wan (eth0) with ip addr show. Should have an IPv4 IP.
If wan IP is 192.168.1.X need to reconfigure modem (passthrough) or change LAN IP to something outside that range so there is no conflict.
Internet should now work on the laptop and anything else connected to the wifi.

If you need wired connections you will need to add another Ethernet port hardware such as a USB3 adapter. Then attach the new port to the lan. More than one wired user can be served by branching through external Ethernet switch(es).

Remember lan is local users and the OpenWrt OS where you log in. wan is the connection to the Internet.

1 Like

have u anydesk ? lol u are making some pasta with u rpi stop lol

Remember lan is local users and the OpenWrt OS where you log in. wan is the connection to the Internet.

Okay so if I configure eth0 to WAN then I wouldn't be able to connect to SSH over the ethernet cable correct? In that case I would need to attach a USB adapter and configure that to lan?

Also if I switch eth0 to WAN, I need to create the following interface to access SSH over wifi? And I would also need to change the inteface in /etc/config/wireless to wan?

option interface 'wlan'
        option proto 'static'
        option ifname 'wlan0'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '64'
        list dns '1.1.1.1'

okay now u have this solution :frowning:

  • reformate sd
  • reinstall openwrt sysfs factory
    -launch
  • on u pc connect to u home wifi
    -pc partage connexion from wifi to ethernet
    -pc config ip : 192.168.1.2 , netm , 255.255.255.0 , dns 1.1.1.1
  • plug the rpi4 rj45
    -check ip lan 192.168.1.2 ok ?
    -connect ssh
    -first ! first !
  • uci set network.lan.gateway=192.168.1.2
    -uci set network.lan.dns=1.1.1.1
    -uci commit network
    -uci commit
    -reboot
    -connect ssh
  • ping google.fr
    if ok =
    -opkg update
    -opkg install luci-nginx
    and good for this point

them if nok ping =

1 check gateway and dns on uci config
2 check ( partage connexion from wifi ton ethernet )
3 check ip pc

I'm working on that right now, but I can't seem to get the internet passed through to the Raspberry Pi. I'm using the default configs, it's a fresh install. I haven't touched anything...

Is there something special I have to do for it to accept internet from my computer?

okay now u have this solution :frowning:

  • reformate sd
  • reinstall openwrt sysfs factory
    -launch
  • on u pc connect to u home wifi
    -pc partage connexion from wifi to ethernet
    -pc config ip : 192.168.1.2 , netm , 255.255.255.0 , dns 1.1.1.1
  • plug the rpi4 rj45
    -check ip lan 192.168.1.2 ok ?
    -connect ssh
    -first ! first !
  • uci set network.lan.gateway=192.168.1.2
    -uci set network.lan.dns=1.1.1.1
    -uci commit network
    -uci commit
    -reboot
    -connect ssh
  • ping google.fr
    if ok =
    -opkg update
    -opkg install luci-nginx
    and good for this point

them if nok ping =

1 check gateway and dns on uci config
2 check ( partage connexion from wifi ton ethernet )
3 check ip pc

u have windows ?

Yes I'm running Windows 10.

hotspot_wifi_windows_8_05
propriete de wifi connexion paratge to ethernet

I did that to share internet connection to my Raspberry Pi but still no internet...

Is it suppose to work right away without any configuration on the Raspberry Pi itself?

okay now u have this solution :frowning:

  • reformate sd
  • reinstall openwrt sysfs factory
    -launch
  • on u pc connect to u home wifi
    -pc partage connexion from wifi to ethernet
    -pc config ip : 192.168.1.2 , netm , 255.255.255.0 , dns 1.1.1.1
  • plug the rpi4 rj45
    -check ip lan 192.168.1.2 ok ?
    -connect ssh
    -first ! first !
  • uci set network.lan.gateway=192.168.1.2
    -uci set network.lan.dns=1.1.1.1
    -uci commit network
    -uci commit
    -reboot
    -connect ssh
  • ping google.fr
    if ok =
    -opkg update
    -opkg install luci-nginx
    and good for this point

them if nok ping =

1 check gateway and dns on uci config
2 check ( partage connexion from wifi ton ethernet )
3 check ip pc

1 Like

make this point by point and all point

Oh wow, I missed the gateway part my bad! I've been trying to figure out the internet sharing issue for 3 days now, thank you so much!

So now I have Luci installed and I got my wifi working. I added a new interface called "wan" and attached it to "eth0" with the protocol dhcp. How can I get this connected to the wifi for internet?

Or go into the lan by wifi.
The default /etc/config/wireless is all set up for a wifi AP linked to lan, but it is disabled since there is no encryption and your neighbors could connect to it and take over the router. So you probably want to add

option encryption 'psk2'
option key 'a secret key'

to the wifi-iface block. Then remove the option disabled from the wifi-device block.

For a wifi-only lan, the lan section of /etc/config/network should have no option ifname. The wifi config will connect it to lan. Since wireless ifnames are not chosen by a preset method, you don't want to hard-code the name in the network configuration.

Connect the ethernet cable to a network linked to the Internet. If it is a typical home network, or a raw cable modem, the DHCP will obtain an IP address. Having this address set means that the connection is (somewhat) ready to work. But read my earlier post about address conflict.

The linkage between LAN and WAN is via the firewall. They aren't "linked" to each other explicitly in /etc/config/network.

1 Like

yes put the eth0 to wan wwith dhcp client . in the firewall zone check wan ( red zone )

So I created the interface but am not getting any internet. I also tried pinging over SSH but nothing.

I tried rebooting it as well. Is the problem that it hasn't received an ip address from the modem?

This my config: