Raspberry Pi 4 - slow performance

I just installed OpenWRT on my Raspberry Pi 4 (quad core, 8GB of RAM) and I'm noting that wired speeds are slower than I'd expect.

I have a gigabit cable connection and when I run this Speedtest performance script (https://openwrt.org/packages/pkgdata/speedtest-netperf) directly from the Pi I get around 850Mbps down. However, when I run an Ookla speedtest from my Macbook Pro via ethernet connected directly to the Pi, it's around 600Mbps down.

I know that's not too far off from the peak, but I would have expected it to be closer. What can I do to diagnose this?

Here's some of the specs:
Raspberry Pi 4 Model B Rev 1.4
Target Platform: bcm27xx/bcm2711
Firmware: OpenWrt 21.02.2 r16495-bf0c965af0 / LuCI openwrt-21.02 branch git-22.046.85957-59c3392
Kernel Version: 5.4.179

I'm using this TP Link UE300 for the WAN connection:

You shouldn't have problems maxing out your gigabit connection, as I'm able too.

Please, ensure that you have Packet Steering enabled, and install irqbalance package, it has to be enabled manually via it's configuration file, see below.

/etc/config/irqbalance

config irqbalance 'irqbalance'
	option enabled '1'

	# The default value is 10 seconds
	#option interval '10'

	# List of IRQ's to ignore
	#list banirq '36'
	#list banirq '69'

There has been some chatter on the forum about slow speeds (especially with sqm and packet steering) lately and 21.02.2.

You could try a 22.03 snapshot if enabling packet steering and IRQ balance doesn't solve your problem on 21.02.2.

Good point. I'm not in 20.02.2, BTW. I'm running

Firmware Version     OpenWrt SNAPSHOT r19355-80f79beb95 / LuCI Master git-22.089.43958-7110635
Kernel Version       5.10.109