Raspberry Pi 4 | Router on a stick | Netgear managed switch

I am attempting to configure my Raspberry Pi 4 to act as a router on a stick. I have a five port Netgear managed switch and I have configured the following:

GS305E – 5-Port Gigabit Ethernet Smart Managed Plus Switch

Port 1 (PPOE WAN)
PVID = 1
VLAN 1 untagged

Port 2
PVID = 1
VLAN1 tagged
VLAN 10 tagged

Ports 3-5
PVID = 10
VLAN 10 untagged

image

image

image

I assume you plug the RPi into port 2 and the ISP incoming into port 1.

Then you need to make sure you reboot the ISP equipment as it sometimes locks to a MAC address other than the one you want. Sometimes even requires leaving the device off for some time like 30 mins

1 Like

I think I've managed to get things working.

Ports 2-5 VLAN 1 with no tagging.
Port 1 VAN 10 with no tagging.
Port 2 VLAN 10 with tagging.

My RPI3B manages pppoe using dumb fast ethernet switches on the default eth0 for lan and eth0.35 for pppoe wan. I removed the smart switches when I found they were not needed. I no longer have to load in kmod-usb-net-rtl8152 for the wan interface. On the SR505n modem, I left the packets tagged: VPI=-1, VCI=-1 instead of VPI=0, VCI=35.

Thanks for the tip.

Everything is working at the moment, so I'll probably leave it alone. I'm not sure if the switch is buggy, but I'm sure I tried these setting before without any success.

I am using an Honor Router 3 as a Wi-Fi access point. It has 4 ethernet ports, so I tried using that instead of the Netgear managed switch, but it wouldn't connect the PPPoE.

1 Like

I'd like to tidy up my config a bit and have both VLAN1 and VLAN10 (WAN) tagged on the RP4 link.

I'm not sure how to configure it in OpenWRT.

These are the current interfaces.

image

I know that I need to add eth0.1, but I'm not sure what other options to choose. The VLAN1 network address is already assigned to the br-lan interface. Do I need to assign another static IP on the same interface or the same IP as the br-lan? Should it be a DHCP client?

image

Don't add an interface, just change LAN to be a bridge including eth0.1

Sorry, I've very new to OpenWRT. How do I do that? When I click on LAN, I don't see any options to include eth0.1.

** Edit **

I think I have found the settings. Is this correct?

image

Do I need to enable VLAN filtering?

It's a little tricky... You probably want to start with eth0 and eth0.1 bridged together, then change the switch to tag vlan 1 on the port and then go back in and change LAN to be a bridge with just eth0.1

That will keep you from locking yourself out when you switch to tagged packets.

Thanks. I think I've finally got that working with VLAN1 tagged on the switch. I didn't appreciate the difference between 'devices' and 'interfaces' in the config menu.

I've removed eth0 from the br-lan interface and I still have network connectivity.

image

image

What does the VLAN filtering setting do? I enabled it, but it looks as though it automatically disabled it when I removed eth0.