Raspberry Pi 4 released

Does anyone have experiences with lcd displays on pi4 with OpenWrt (required drivers, programs etc.)?


1 Like

The offical case is terrible, it has hardly no ventilation.

I'm in a warm Spanish climate and had to buy a different case, settled on one of those fanless alu heatsink types and it did wonders.

1 Like


I can vouch for the Flirc case. Passively cooled, ie no noise. And doesn't throttle even when running at 100% load for 24/7.

Will look for the heatsink type case once things ease up a bit.... and hope it can run continuously at 65-ish until then!

I have the same heatsink case. With ambient temperature 25° the cpu works in the 43°-45° range.

CPU is not stressed with daily tasks.

Yep, in its way to my home. :metal:

I'm using a PoE Hat instead of a power adapter. It comes with a fan but I can't control it. I've included these lines in config.txt but I see no effect

# PoE Hat Fan Speeds

Using OpenWrt SNAPSHOT r13520-68b94f0fb4

1 Like
Load:   dtoverlay=rpi-poe,<param>[=<val>]


1 Like

I've now tried without success:

# PoE Hat Fan Speeds

Kernel 5.4.43. Is there any pkg that I need to install on top of base OpenWRT ?

you'll need to run that in config.txt on rasbian... it should setup the relevant sysfs parameters... seems that they probably use "something" to read sysfs and do the grunt work. with any luck its "sh" ( doubt it )... probably either python... a binary... ( promising to translate ) ... or heaven forbid... a driver...

edit: looks like a custom i2c driver > CONFIG_SENSORS_RPI_POE_FAN=m

edit2: these patches seem to be in the openwrt source... not sure if would need other i2c/hwmon stuff too...

# fan activation and escalation settings

I don't have it installed, and when using opkg install it says that a more recent kernel is required (5.4.48 instead of 5.4.43). I'll have to wait some hours until I have a maintenance window to upgrade OpenWRT.


Does anyone know how increase overlay size with squashfs images?

Or shall I go for ext2 images?

Still not working. Here is my config.txt file

# OpenWrt config
include distroconfig.txt

# Place your custom settings here.


# PoE Hat Fan Speeds

And here is the log:

Wed Jun 24 00:06:21 2020 kern.err kernel: [    6.781403] rpi-poe-fan rpi-poe-fan@0: Failed to get default PWM value: -5
Wed Jun 24 00:06:21 2020 kern.warn kernel: [    6.788289] rpi-poe-fan: probe of rpi-poe-fan@0 failed with error -5
kmod-pwm-bcm2835 #? ( or this kmod-hwmon-pwmfan )

Installed both, still not controlling fan after reboot.

from afar that seems to be 97% of what you need... so best to hitup the vendor or rpi forums... and rule out a config issue ( could also be done with raspbian + dtc dump + lsmod )

1 Like

Thank you very much. Maybe some future update will fix this. I'll wait.

I don't know if this is the right place to ask or I need to start a specific thread, but as this one seems generic to the pi4 I will ask here and it can always be deleted if required.

First up is an easy one, which rpi4 do I get for openwrt use? 2GB should be enough, but should I future proof a bit with 4GB or go mad and get 8GB just because it's there?

Next up is more tricky, how do I go about updating the openwrt when needed? Can you use the sysupgrade packages still or do you need to remove and reflash the SD card each time??

What package do you use to monitor CPU useage and temperature?? Your little graphs are excellent :grin:

I am using MRTG from snmp.

1 Like

I'll have to look into trying to install that as it's a nifty little ability... I love all these monitor widgets.