Raspberry Pi 4 (no lan to wan access)

Hi all,

I hate writing these generic posts, but here it goes. Currently I have a RPi4 connected to my ISP router that I want to use, my ISP is starting to provide more bandwidth and my ER-X will not be good enough for a Gigabit.

The way this is connected is pretty simple

ISP cable modem -> USB3-eth1 -> RPi4 -> Internal-eth0 -> dumb AP

Nothing special there to my knowledge, I tried two different dongles, a RTL8152 and an AX88179.

My problem is that I cannot access Internet, even from the RPi4, and curiosly some times I get and IPv4 leased from my provider and/or an IPv6. I am running 4th June Snapshot, however, I fail to see any relevant information in latest commits.

Here goes my relevant sections from the /etc/config/network if that helps

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr ''
        option netmask ''

config globals 'globals'
        option ula_prefix 'fd57:11da:b11c::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr ''
        option netmask ''
        option ip6assign '64'

config device 'lan_eth0_dev'
        option name 'eth0'
        option macaddr 'dc:a6:32:7e:f3:04'

config interface 'wan'
        option ifname 'eth1'
        option proto 'dhcp'
        option hostname 'openwrt'

config device 'wan_eth1_dev'
        option name 'eth1'
        option macaddr '00:0e:c6:54:3d:f3'

config interface 'wan6'
        option ifname 'eth1'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix '56'

I am completely at lost right now. My ER-X works flawlessly with a very similar situation, I even tried renaming eth1 to eth1.2 in case a VLAN ID was required, but my ISP says that is not required.

Any ideas?

Thanks heaps in advance.

Did you see this topic
Update kmod-usb-net-rtl8152 Driver to avoid USB 3.0 to Gigabit LAN issues? ?

Yes, I did, that's why I've got the AX88179 even when its drivers seem not so optimised. I've got same issues with both dongles.

Have you confirmed the usb dongles are working properly? Is the ISP router running in a bridge mode?

I'd start by removing this from wan interface. Not all ISPs like it.

Other than that, power off the ISP modem in case it has saved the MAC address of your ER-X.
A look at the logs and a tcpdump of the eth1 could provide more insight.
In any case start with the basic configuration on the RPi and start adding packets and configuration to find out what could be breaking the internet.

1 Like

Also be careful with two (usb) nics if used simultaneously...

I had a pegasus on usb2, rebooted and it took the "eth1" over my usb3-rtl... due to probe / load order... makes sense, but wasn't immediately clear why eth1 was "not working"...

All good, just used one USB NIC at a time, as per my "graph".

1 Like

I'll try that, I must say that this option is in there in my ER-X configuration causing no issues. Cycled the ISP modem and kicked off my connection with my ISP, they let you do that from their web site. That did not worked at all. I guess starting from a clean and basic install is what looks like next step. sigh

did you use USB 2.0 port or USB 3.0 port?

also maybe try reverting the USB to Ethernet for LAN, dan Native Ethernet for WAN.

Always tried USB3 ports, and didn't try swapping interfaces between native and USB-Ethernet, ideally having LAN in the internal ensures that I'll not lose access to the RPi4 if something goes wrong, right?

yes, the swapping thing just to check the root problem, did you try using USB 2.0 port first, I know it's not gigabit speed but just for troubleshooting since I also encounter the same problem with RTL-8153 USB to LAN adapter, although I haven't tried ASIX based USB to LAN.

And then if it doesn't work then he has no access to the device!

I assume since it's raspberry pi, there's always last resort of connecting directly to the monitor or reflash the microsd card, happens to me few times.

Right, I have a serial connection, no worries

Update: I tried all the suggested approaches, including starting from a clean configuration and, nothing. I am not getting connectivity. From time to time I get my IPv4 from my ISP but traffic do not got pass the ISP's gateway. My modem is an Arris CM8200B, do you know if is there any kind of incompatibility?

Have you tried to connect a PC right on the modem?

Oh, FFS! It did not occurred to me! Let me try!

1 Like

Yep, not working either. I suspect it needs to be a "router" behind the Arris and the RPi4 is not acting like one?

Any device set to obtain an address via DHCP should work fine, as long as the modem is in bridge mode and is handing out addresses correctly. Have you power-cycled the modem? It's not uncommon for them to only hand out an IP address for a short period and then become locked to the MAC address of the connected device. If that is the case then it'll need powering off and back on, ideally with a few minutes of being off just to be sure.

1 Like

Yes, I power-cyled it several times, and each time before starting it off again I kicked out my NTD connection on ISP's web interface. However, I never let it rest for more than a minute or so. I was thinking about a factory reset to see if that cleans up its cache.