Raspberry Pi 4 expected Wireguard Speed

I was able to get the site to site working with your above instructions. However, it works intermittently then it stops working. I have tried deleting the "NJConnectHome" interface and adding it again with the above instructions. Done it 3x but all the 3 times the site to site will work but only intermittently. I have also tried deleting and adding the Peer "NJ OpenWrt Pi" but no change.

I also had something weird that led the Home (toronto) WG to stop working for no reason after a restart. I checked the the system clock was correct after reading about that being the possible issue. It was correct, so I had to delete the WG at the home toronto location and readded. It is back up running. The third time I did the site to site was with the new Pub/Private key of the WG home. Again it only worked temporally. I know it was working because I was able to connect to the 192.168.1.1 ISP router without being connected to the WG while I was at home. Again it only worked temporarily then it stopped working.

Any idea what could be the issue for the site to site only working intermittently?

Started working out of nowhere and has been working for a while now. Will mark thread as as solved as most of the questions has been answered and any remaining questions are likely an issue at ISP Nj router.

So, I was able to get a different client working to connect to the NJ RP4. That client was also in NJ. When I ran the bandwidth test between the NJ client and the NJ RP4 I did get the appropriate bandwidth that I expected. So I guess the issue is that when I connect a client from Toronto to the NJ RP4 the connection is too far, :man_shrugging:, leading to the bandwidth speed degradation. I expect a little drop off but to get upload speeds of 15-20 Mbps from NJ to Toronto seems like a big lost. How can anyone around the other side of the world use WG with such speeds if this is what is considered normal.
Does anyone think that doing a fresh install of OpenWRT on the NJ Pi4 and install WG again would lead to any change? Or is that just a waste of time?

Had sometime this afternoon. Changed the MTU not in the wireguard interface of the NJ Pi4, but under the wan on the "devices" tab in the network interface. Tried several MTU sizes. Went as low as 1300 but that killed the upload speed to 2 Mbps. Settled with 1492 since that gave me 36-42 Mbps most of the time when running bandwidth test from Toronto client. There were a couple times that under that 1492 MTU size, I was able to saturate the upload connection and get the advertised speed. Wondering why the that happened only twice though then it went back to mid mid 30s/low 40s.
Just in case the above comment was skipped,
I did get to saturate the connection (download/upload) when I had a client in new jersey connect (in a different house) to the NJ Pi4.
@psherman @egc does this clear up what could be leading to the poor upload speed?