Raspberry Pi 4 | Asymmetric speeds on symmetric WAN

I've got a bit of an unusual problem.

Raspberry Pi 4
Managed switch connects LAN to router using VLANs.
TP Link UE300 for WAN.
WAN = 1Gbps symmetrical connection.

Speed tests, performed on my desktop PC, are giving 930Mbps down / 720 Mbps up.

I tried connecting the TP Link UE300 to my Dell XPS laptop and connecting directly into the ISP's modem.

That gave me 600Mbps down and 930Mbps up.

It appears that the WAN connection may be providing symmetrical speeds, but that's not what I'm receiving on my endpoints.

I've tried swapping out the cables, but get exactly the same results.

Any ideas?


The problem is the NIC in my desktop PC's motherboard.

  • I connected it directly into the ISP's modem and received the same 920 Mbps / 720 Mbps speed.
  • I then took the TP Link UE300 and connected it to a USB3 slot on my desktop's motherboard and it connected at 940Mbps / 948Mbps.

I guess I need to buy another UE300 for my PC.

For future reference, my desktop PC has this motherboard:

Asus PRIME X570-P with Realtek RTL8111H LAN chip.

Glad you figured it out. As for the desktop nic issue, what OS are you using on desktop? Asus generally makes pretty high quality stuff in my opinion, been using Asus for laptops and desktops for decades and never really had a problem that was not my fault. So I am thinking maybe you need to check the date on the nic driver?
It's not an OpenWRT issue per say but I think you could be helped none the less. Or as you said grab another USB adapter.

Good catch. Windows was using an automatically installed driver from 2015.

I installed the latest version from the Realtek website and I am now getting full speed in both directions.


Glad I could help. 2015? Wow!

Anyways, have fun with the Pi!!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.