Raspberry Pi 4 and OpenWrt help

Hello I have problem with openwrt setings I flash microsd and put in pi4 with lan cable connect pc to pi4 and power on. On ping 192.168.1.1 in cmd is ok also is working ssh connection, but when try open in browser 192.168.1.1 then no working what is need change for working.

here config network is original no changed.

cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd55:f20b:bc0b::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

What specific firmware file did you download and write to the card?

If it is a snapshot…

You have installed a snapshot image. Read the link for instructions how to install Luci, which is not installed by default in snapshots.

I use latest this file openwrt-22.03.2-bcm27xx-bcm2711-rpi-4-ext4-factory.img

Ok. That is a stable release version, so it will have luci installed.

Did you disconnect your computer from all other network connections (wired directly to openwrt pi, no other wired connections, WiFi disabled on your computer)?

I use other USB adapter for connect from pc ( other lan on board pc is disabled) to pi4 - usb 3.0 lan card in pc then attach cat6 cable one side to adapter and other side to pi4 lan port

that should theoretically work, but you must verify that your other network connections are disabled. I recommend physically unplugging any other connections and specifically turning off wifi. This will guarantee that you don't have any other network connections.

You may need to clear your browser's cache, too. then navigate to:
https://192.168.1.1 (you may get an error saying that there is an invalid certificate/unsafe site... you can safely ignore this error). You might also want to try different web browsers.

I clean all history cache in browsers can't access to 192.168.1.1 in cmd ping work good. But this is mystery why no open address. :worried: also reset protocols in system. Adapter is disabled no communication open on lan port from motherboard. When enable usb adapter and configure with address for router IPS also open ip address no problems, But GUI for OpenWRT no this is situation miracle. I reflash microsd card x20 times today

What is the output of:

netstat -plnt
root@OpenWrt:~# netstat -plnt
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      339/uhttpd
tcp        0      0 127.0.0.1:53            0.0.0.0:*               LISTEN      1834/dnsmasq
tcp        0      0 192.168.1.1:53          0.0.0.0:*               LISTEN      1834/dnsmasq
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      844/dropbear
tcp        0      0 0.0.0.0:443             0.0.0.0:*               LISTEN      339/uhttpd
tcp        0      0 :::80                   :::*                    LISTEN      339/uhttpd
tcp        0      0 fd75:175a:8ff::1:53     :::*                    LISTEN      1834/dnsmasq
tcp        0      0 fe80::e65f:1ff:fe1f:9f4d:53 :::*                    LISTEN      1834/dnsmasq
tcp        0      0 ::1:53                  :::*                    LISTEN      1834/dnsmasq
tcp        0      0 :::22                   :::*                    LISTEN      844/dropbear
tcp        0      0 :::443                  :::*                    LISTEN      339/uhttpd

These show that the web server is listening. The problem is most likely on your computer/browser. Do you have another computer you can try?

Will try make on other hdd new clean install windows then test again thanks for now for help I will post info here when done with installation.

I make new installation and now is ok but I worked with wrong flashed image in microsd card. I request before custom build from server before for asix lan usb driver version integrate in image in openwrt but this driver is problem is solved work.

But now you if help me with how to add pppoe connection and where set in eth0 or eth1.

Now I have WAN, eth0 and eth1