Raspberry pi 3B and 3B+ didn't boot up

tried below image, but both raspberry pi 3B and 3B+ didn't boot up, anyone can tell me if I used wrong image?Thanks!


That seems to be the correct image for the board.

How you wrote the file to card ? You extracted the file before writing ?

Do you see anything onscreen when power up?

Check with serial console connection to the Pi
Try another sd card ?

Try the LEDE Reboot 17.01.6 image also


Thanks for your information.

1. Disk Writing: tried by both win32diskimager and etcher after extracted to img file
2. 18.06.01: both 3B+ and 3B didn't boot up, nothing showed on screen, network card light blind
3. 17.01.6: 3B+ same as 18.06.01. 3B booted up, network card ligh on, see raspberry on screen, but stuck on " br-lan: port 1 (eth0) entered fowarding state"

your device is 3B or 3B+? and can boot up with either 18.06.01 or 17.01.6?

I have both, but not sure when last i used OpenWRT on them.
I will check again and report back, when I get a moment todo so

I used more recently on Zero/Zero W

You are certainly having strange issues

What happens if you flash a snapshot image?

flashed snapshot image, almost same:

3B+: didn't boot up, Ethernet card light blink.

3B: boot up, Ethernet card light on, stuck after

" smsc95xx 1-1.1:1.0 eth0: link up, 100mpbs, full duplex,lpa 0x5DE1"

have the same result, tried some earlier versions also

3B+ not boot up
3B boot but stuck

anyone successful to install openwrt on rpi3b/3b+?

did some research, but still didn't find a solution for RPI3B. frustrated!

I had problems booting RPi 3b+ and fixed it by copying a start.elf file from the boot partition an SD that boots to the SD that doesn't

See my post:


1 Like

I've used OpenWRT 18.06.01 for a while on a Raspberry Pi 3B as a WLAN AccessPoint successfully, so far. Until two days ago. I've got new RaspPi 3B+ and looked whether OpenWRT is supporting the new hardware. OpenWRT claims that since 18.06.00 the Raspberry Pi 3B+ is supported. Downloading and flashing the Image onto an SD card is quickly done - but on all devices I have at hand, the image doesn't boot and the green LED is flashing. This happens to all the RaspPi3B+ I have at hand. 18.06.01 is de facto not capable of being used with this sort of device.

I tried several snapshots up to today's snapshot OpenWrt SNAPSHOT, r8639-99e2121. They boot, so far. But WiFi is unusable as AP. While the latest snapshot, as of yesterday, resolved the problem of WiFi adapter not being detected, now the adaptor is being detected and it seems to work anyhow as a "client", but it is non functional as an AccessPoint/HotSpot, also configured explicitely as AP.

So far ... this is embarassing.

Today's snapshot image, OpenWrt SNAPSHOT, r8662-02494fa, same problem with WiFi: the 3B+ units boot with this image, but the Wifi interface never operates in AP mode. It is also stuck at channel 1 (although I explicitely configured another channel when using 802.11n, 20MHz at 2,4 MHz).

This is a portion of the dmesg output, hopefully it helps (I'm new to OpenWRT/Raspberry Pi, sorry for the inconvenience):

[    7.845753] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
[    7.882455] brcmfmac mmc1:0001:1: Direct firmware load for brcm/brcmfmac43455-sdio.raspberrypi,3-model-b-plus.txt failed with error -2
[    7.897554] brcmfmac mmc1:0001:1: Falling back to user helper
[    7.912203] firmware brcm!brcmfmac43455-sdio.raspberrypi,3-model-b-plus.txt: firmware_loading_store: map pages failed
[    8.021791] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
[    8.043603] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM4345/6 wl0: Mar  1 2015 07:29:38 version 7.45.18 (r538002) FWID 01-6a2c8ad4
[    8.089876] usbcore: registered new interface driver brcmfmac

Any news here? I have the same issue with 3B+

after i downloaded the image, which is *.img.gz, and dd it to sdcard directly, of cause it won't boot, i needed to decompress to get the *.img first, and then dd or (etcher from windows) the *.img to sdcard. hope this helps with newbies like me who had boot issue with this kind.

1 Like

Hi @Caros,
I had same problem. My Raspberry Pi 3B (a02082) -> not booting with latest firmware.

I tried another image, earlier version, and meant for Pi 2, and had success!

openwrt-19.07.3-brcm2708-bcm2710-rpi-3-ext4-factory.img - not working :x:
openwrt-18.06.1-brcm2708-bcm2709-rpi-2-ext4-factory.img - working :white_check_mark:
openwrt-19.07.3-brcm2708-bcm2709-rpi-2-ext4-factory.img - will try next :question:

From https://openwrt.org/toh/raspberry_pi_foundation/raspberry_pi:

Supported Versions

The Raspberry Pi is supported in the brcm2708 target.
Subtargets are bcm2708 for Raspberry Pi 1, bcm2709 for the Raspberry Pi 2, bcm2710 for the Raspberry Pi 3, bcm2711 for the Raspberry Pi 4.

bcm2709 subtarget can be used for bcm2710 and bcm2711 devices.
This subtarget features a 32 bit kernel instead of a 64 bit kernel (64 bit kernels aren't “officially supported” by the Raspberry Pi foundation).

I wonder if it has anything to do with 32-bit kernel? ^^^

Next, I willI will try openwrt-19.07.3-brcm2708-bcm2709-rpi-2-ext4-factory.img