Raspberry pi 3 stuck in boot loop due to wifi region bug

Detail all in the bug here: https://bugs.openwrt.org/index.php?do=details&task_id=1133

I've tried the workaround suggested in the bug - that is, use raspbian to set the wlan region, and then retry with openwrt. But this makes no change.

Any ideas anyone?

  1. https://openwrt.org/docs/guide-user/troubleshooting/failsafe_and_factory_reset assuming its available on RPi

  2. Reimage / reflash , and reconfigure your settings.

  3. Based on the region you purchased your PI in, Select a channel other than 12 or 13.. (also avoid any of the channels marked as DFS ) Wikipedia page is very good reference. Look at the 2.4 and 5ghz tables https://en.m.wikipedia.org/wiki/List_of_WLAN_channels

Thanks Sparks.

But it's stuck in s boot loop from fresh SD card image. How would I change those settings if it's not yet booted?

Take out the SD card and modify the settings by opening the SD card in for example a laptop.

Try what @Mushoz suggested. If that still doesn’t work, maybe download raspbian image and try that - just to rule out a hardware failure ..

Already done that. Even edited config.txt to disable wlan. No joy. Getting stuck at boot and looping due to the driver.

See link https://photos.app.goo.gl/81mxo9KDzsV6NrBh9

Hmm. The photo of your device’s boot up and the bug ticket you linked above are not showing the same things.. what makes you so certain that bug is the problem your having?

have you also tried a raspbian image? What does it do?

Have you tried another sd card?

Hmm, what is it you're saying that makes them different?

See the OpenWRT page describing it: Wireless Country Code Issue: https://openwrt.org/toh/raspberry_pi_foundation/raspberry_pi

Using raspbian to set the region (GB) in firmware makes no difference though.

Are you saying this is a different defect?

To be honest I wasn’t even understanding what you’re real problem was until your last post..

Maybe have a read of this .

I don’t have any answers , only suggestions on what else you can try. But since you don’t seem interested in explaining what you see, and what you’ve tried step by step, or what exactly about using raspbian makes no difference, then this is my last response to you. Maybe someone else will help you.

Looks to me like your SD card has bit the dust, Probably from the Pi shutting down improperly.

I don's use a Pi but looking at the error "run fsck" thats my guess.

Before you buy a new SSD card or try from scratch again make sure your power supply is up to the task I think they need to be 1 or 2 amps.

Nice spot, but no cigar. I'm getting similar errors and kernel panics on 4 different SD cards, one brand new. And also if I switch to alternative pi HW.

I may buy a tp link router and flash that. I urgently want to try out the new SQM cake package for bufferbloat.

Anyone got the time to try the image on their Raspberry Pi B 3+?

@realreform latest stable release of OpenWrt 18.06.2 do not works on the raspberry pi 3+, only snapshot builds are working, I haven't tried the latest snapshos builds but the last time I made a build everything was working fine.
Here is my bulid if you wants to give a try:https://github.com/1Jeff1/Raspberry-Pi-3/raw/master/openwrt-snapshot-r9404-brcm2708-bcm2709-rpi-2-squashfs-factory/openwrt-snapshot-r9439-90c8914fa0-brcm2708-bcm2709-rpi-2-squashfs-factory.img

1 Like

Are you sure that is a good image - should it not be bcm2710?

It boots further then gets stuck at ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready

Also still errors with brcmfmac43455-sdio map pages failed as before

MAC address registers on router but no IP.

When "br-lan: link becomes ready" connect to raspberry pi from desktop/laptop directly via ethernet cable and from your browser, open OpenWrt web UI @

Thanks jeff1 that works. PPPoE comes up and firewall etc but there were a couple of config problems not working out of the box. So in the 5 minutes it took to tftp it onto an Archer C7 that came up and connected perfectly first time. So I'm sticking with that until a full on pi image comes available.

Cheers for the snapshot