Random things I've found out about improving AC58U settings on OpenWrt

I return after some time, my first thread was about asking some things that were easy to figure out (like turning off the led's, just select trigger-none on everything including the status led where you create a new entry), and me thinking I've bricked the router, when it was just a small problem and it fixed itself in the end.

Now, in no apparent order, let me show you the little quirks I found out using this router, and when I had the time to further mess around with it :slight_smile:

  • 5 GHz transmission rates slightly increase when you select a channel above 100. Also, I don't know whether it's because of the higher transmission power or less interference, but in some low signal cases the network is more stable than with a lower channel. (in the bathroom 4 walls away, it was also fast before, but it dropped once every half hour or something. Now it's the same signal power of -75, but it doesn't drop anymore!)

  • The router has 4 CPU frequencies : 48, 200, 500, 716 MHz. By default the governor can go all the way down to the very low 48 MHz when idle, this can slightly hurt some network operations & speeds until it ramps up again. So set the minimum CPU frequency to 200 MHz:

echo 200000 > /sys/devices/system/cpu/cpufreq/policy0/scaling_min_freq

To set it every startup you can use init.d or something ugly in crontab, which is what I've used, because I can do it via the Luci interface :slight_smile: (EDIT: This DID improve some TCP/UDP connections made by my PC after a while!)

  • In the Adblock app (yea slightly off topic here), setting the parralel threads to 8 or 16 makes it start and refresh quicker, and reduces CPU usage. Let's not forget making it refresh automatically with crontab, I've set myself to adblock restart every 6 hours.

Anything else you know about this router you can add here. Have a great day/evening!

A better way to do anything at startup from Luci is using the Luci->System->Startup page and scrolling down to the bottom of the page to Local Startup then read the instructions carefully.

Just as I looked out of curiosity in Startup I found Local Startup. Thank you, it's easier than it seemed :slight_smile: . Do I need to separate the command by blank likes before exit 0, or it doesn't matter?

Doesn't matter but will help readability

Yeah, it works fine. I ended up putting spaces everywhere to satisfy the perfectionism :slight_smile: Good to know that it doesn't matter.

Also I further increased the minimum frequency to 500 MHz and it's even better by a small margin. The router only gets warm when I set the governor to performance and it pins the CPU to 716 MHz. But at 500 it's still just as cool as before.

New thing found out, but again it's probably just in my case: Set the 5GHz channel to 116 and it won't get moved by the DFS whatever is the region set. 100 gets moved sometimes, 116 although curiously being more into DFS territory, stays still as a rock.