Random reboots on Plusnet Hub One

Hi,

I have OpenWrt 19.07.3 r11063-85e04e9f46 firmware installed on Plusnet Hub One and it was working without issues for last 4 months. Recently, router started rebooting them self randomly and I have no clue why. I have logging setup to log to external syslog (Log output level debug), but I can't see anything it logs related to kernel. Randomly' I'm checking if there is any issue with memory level, so it looks fine.

Does anyone expecting something similar ?
Does openwrt preserver logs after reboot ?

Any suggestion about how to fix this issues with rebooting welcome

How old is the device? Could be a power supply problem

Device have half year so I don't suspect power supply. I don't suspect power cuts in home as well, as I run few Raspberry PIs and all are up whole time.

you should try using a different power supply brick if possible

2 Likes

If the kernel is crashing, it mostly likely kills any process that might try to output your log to a network address or to Flash/NAND. Best bet is a serial connection to diagnose such things.

Based on the fact that your wifi uses a Qualcomm Atheros QCA9880 (I'm hoping I've got the correct device page), I'd try disabling WiFi and seeing if your uptime improves at all.

@maurer: I have 2 exact routers in home so, I can try to swap power supply and see if this help.

@ergamus: I'm thinking to plugin usb key and setup additional logging to it. If this is kernel crash, system should have enough time to write few lines to log.

But, I'm curious what changes, as I'm running this router with this openwrt firmware for 3 months, and I have no single reboot. It just started around 2 weeks ago.

kernel panics/crashlogs are stored by default in /sys/kernel/debug/crashlog

There is no file /sys/kernel/debug/crashlog so not sure if I have to turn some option to create crashlog or reboot is not caused by kernel crash.
I setup logging to local filesystem so maybe I will be able to catch more info like OOO or "kernel panic" in main log file.
If I will not find anything, I probably will install sar or something similar, to trace system activity.

Maybe I should try to upgrade firmware to 19.7.4 version as well

I checker my access point which I run on this same hardware and using this same version of openwrt firmware and packages.

 OpenWrt 19.07.3, r11063-85e04e9f46
 -----------------------------------------------------
root@router:~# uptime
 09:38:43 up  5:08,  load average: 0.07, 0.01, 0.0

 OpenWrt 19.07.3, r11063-85e04e9f46
 -----------------------------------------------------
root@ap1:~# uptime
 09:38:56 up 59 days, 18:34,  load average: 0.00, 0.00, 0.00

Looks like only router is getting random reboots. Access point is solid.

Of course there isn't a crash log. Your router rebooted and the location is not persistent in OpenWrt.

Are you using the hub as an dumb access point? If so by any chance is dsl_control enabled in startup. I've had this problem in past and had to disable it.

As suggested by @Gopten if the DSL port is not being used, the hub can suffer from random reboots as documented in section 7.13 of the installation guide for HH5A if dsl_control is not disabled.
https://openwrt.ebilan.co.uk/viewtopic.php?f=7&t=266

Otherwise, try different power supply as suggested by @sammo

1 Like

Access point is fine (no reboots) as I mentioned above and it don't have dls_control enabled.

Main router is getting reboots.
I'm going to install rsyslog today to do proper logging

try a different power supply

I haven't change anything but reboots stopped. I'm running this same router with this same power supply for 9 days without reboot.

Strange ....

How did you manage not to tinker for 9 days? What's your secret? LOL. Nearly as frustrating something beginning to work again when you don't know why. :thinking:

1 Like

This is the worsted thing which can happen. Something is starting to work just like that.

Looks like kernel/driver issue:

ath10k_pci 0000:02:00.0: wmi command 40859 timeout, restarting hardware

Does anyone used different firmware for QCA988X like https://www.candelatech.com/ath10k-10.4.php ?