Random Reboot on OpenWrt 21.02.1 Failed to Use Reserved Channel

Dears,
Yesterday I have update the configuration of my OpenWrt 21.02.1 installing ZNC bouncer, working the whole day with wireless I have observed some strange random disconnection.

Every hours circa the router TP-Link Archer C7 v5 reboot unexpectedly; to gathering some information about the problem I have logged the syslog with an active terminal connection in order to catch the logs before the reboot.

Here the data extracted:

Sun Nov 20 19:30:20 2022 daemon.notice wpa_supplicant[1591]: wlan1: CTRL-EVENT-STARTED-CHANNEL-SWITCH freq=2412 ht_enabled=1 ch_offset=1 ch_width=40 MHz cf1=2422 cf2=0                  
Sun Nov 20 19:30:20 2022 daemon.notice wpa_supplicant[1591]: wlan1: CTRL-EVENT-CHANNEL-SWITCH count=0 freq=2412 ht_enabled=1 ch_offset=1 ch_width=40 MHz cf1=2422 cf2=0                  
Sun Nov 20 19:30:20 2022 daemon.info hostapd: wlan1-1: IEEE 802.11 CHAN_SWITCH VHT CONFIG 0x2                                                                                            
**Sun Nov 20 19:30:20 2022 kern.info kernel: [ 5749.992377] wlan1: failed to use reserved channel context, disconnecting (err=-122)**                                                        
**Sun Nov 20 19:30:20 2022 kern.info kernel: [ 5750.006068] wlan1: failed to finalize channel switch, disconnecting**                                                                        
**Sun Nov 20 19:30:20 2022 kern.info kernel: [ 5750.012878] wlan1: cannot understand ECSA IE operating class, 11, ignoring**                                                                 
Sun Nov 20 19:30:20 2022 kern.warn kernel: [ 5750.022943] ------------[ cut here ]------------                                                                                           
Sun Nov 20 19:30:20 2022 kern.warn kernel: [ 5750.027798] WARNING: CPU: 0 PID: 1591 at backports-5.10.68-1/net/mac80211/tx.c:4776 0x877323c0 [mac80211@e5e1603e+0x7cdb0]                 
Sun Nov 20 19:30:20 2022 kern.warn kernel: [ 5750.039206] Modules linked in: ath9k ath9k_common pppoe ppp_async iptable_nat ath9k_hw ath10k_pci ath10k_core ath xt_state xt_nat xt_conntr
ack xt_REDIRECT xt_MASQUERADE xt_FLOWOFFLOAD xt_CT pppox ppp_generic nf_nat nf_flow_table_hw nf_flow_table nf_conntrack mac80211 ipt_REJECT cfg80211 xt_time xt_tcpudp xt_multiport xt_ma
rk xt_mac xt_limit xt_comment xt_TCPMSS xt_LOG slhc nf_reject_ipv4 nf_log_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 iptable_mangle iptable_filter ip_tables hwmon crc_ccitt compat ledtrig_usbpo
rt nf_log_ipv6 nf_log_common ip6table_mangle ip6table_filter ip6_tables ip6t_REJECT x_tables nf_reject_ipv6 tun fsl_mph_dr_of ehci_platform ehci_fsl ehci_hcd gpio_button_hotplug usbcore
 nls_base usb_common                                                                                                                                                                     
Sun Nov 20 19:30:20 2022 kern.warn kernel: [ 5750.103787] CPU: 0 PID: 1591 Comm: wpa_supplicant Not tainted 5.4.154 #0                                                                   
Sun Nov 20 19:30:20 2022 kern.warn kernel: [ 5750.110712] Stack : 00000000 800b98ec 80660000 805fa498 00000000 00000000 00000000 00000000                                                
Sun Nov 20 19:30:20 2022 kern.warn kernel: [ 5750.119346]         00000000 00000000 00000000 00000000 00000000 00000001 87c0bd00 de1d8c83                                                
Sun Nov 20 19:30:20 2022 kern.warn kernel: [ 5750.127983]         87c0bd98 00000000 00000000 000000f0 00000038 8057ac04 20746169 6e746564                                                
Sun Nov 20 19:30:20 2022 kern.warn kernel: [ 5750.136621]         000000f0 383c593d 00000000 0001956b 80000000 87c0bce0 00000000 877323c0                                                
Sun Nov 20 19:30:20 2022 kern.warn kernel: [ 5750.145257]         00000009 00000000 00000002 87159de0 00000003 8032041c 00000000 80790000
Sun Nov 20 19:30:20 2022 kern.warn kernel: [ 5750.153886]         ...
Sun Nov 20 19:30:20 2022 kern.warn kernel: [ 5750.156413] Call Trace:
Sun Nov 20 19:30:20 2022 kern.warn kernel: [ 5750.156422] [<800b98ec>] 0x800b98ec
Sun Nov 20 19:30:20 2022 kern.warn kernel: [ 5750.162546] [<80660000>] 0x80660000
Sun Nov 20 19:30:20 2022 kern.warn kernel: [ 5750.166160] [<8057ac04>] 0x8057ac04
Sun Nov 20 19:30:20 2022 kern.warn kernel: [ 5750.169776] [<877323c0>] 0x877323c0 [mac80211@e5e1603e+0x7cdb0]
Sun Nov 20 19:30:20 2022 kern.warn kernel: [ 5750.175902] [<8032041c>] 0x8032041c
Sun Nov 20 19:30:20 2022 kern.warn kernel: [ 5750.179514] [<80069364>] 0x80069364
Sun Nov 20 19:30:20 2022 kern.warn kernel: [ 5750.183120] [<8006936c>] 0x8006936c
Sun Nov 20 19:30:20 2022 kern.warn kernel: [ 5750.186729] [<800824f4>] 0x800824f4
Sun Nov 20 19:30:20 2022 kern.warn kernel: [ 5750.190347] [<877323c0>] 0x877323c0 [mac80211@e5e1603e+0x7cdb0]
Sun Nov 20 19:30:20 2022 kern.warn kernel: [ 5750.196462] [<8008259c>] 0x8008259c
Sun Nov 20 19:30:20 2022 kern.warn kernel: [ 5750.200076] [<803dfda0>] 0x803dfda0
Sun Nov 20 19:30:20 2022 kern.warn kernel: [ 5750.203681] [<877323c0>] 0x877323c0 [mac80211@e5e1603e+0x7cdb0]
Sun Nov 20 19:30:20 2022 kern.warn kernel: [ 5750.209815] [<87160424>] 0x87160424 [ath9k@382ca032+0x19450]
Sun Nov 20 19:30:20 2022 kern.warn kernel: [ 5750.215663] [<80064f78>] 0x80064f78
Sun Nov 20 19:30:20 2022 kern.warn kernel: [ 5750.219276] [<87166dcc>] 0x87166dcc [ath9k@382ca032+0x19450]
Sun Nov 20 19:30:20 2022 kern.warn kernel: [ 5750.225135] [<8773d3d0>] 0x8773d3d0 [mac80211@e5e1603e+0x7cdb0]
Sun Nov 20 19:30:20 2022 kern.warn kernel: [ 5750.231264] [<8716044c>] 0x8716044c [ath9k@382ca032+0x19450]
Sun Nov 20 19:30:20 2022 kern.warn kernel: [ 5750.237128] [<8773d4cc>] 0x8773d4cc [mac80211@e5e1603e+0x7cdb0]
Sun Nov 20 19:30:20 2022 kern.warn kernel: [ 5750.243262] [<8716d59c>] 0x8716d59c [ath9k@382ca032+0x19450]
Sun Nov 20 19:30:20 2022 kern.warn kernel: [ 5750.249126] [<80660000>] 0x80660000

Just an observation: yesterday for mistake I have filled all the free space in /overlay/upper/ installing too much packages. I have solved removing some files and then using opgk remove some useless packages.

Here my network configuration:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd5e:a91f:c413::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'eth0.2'
	option macaddr 'b0:95:75:48:fb:0c'

config interface 'wan'
	option device 'eth0.2'
	option proto 'dhcp'
	option type 'bridge'

config interface 'wan6'
	option device 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '2 3 4 5 0t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '1 0t'

config interface 'wwan'
	option proto 'dhcp'

config interface 'vpn'
	option proto 'none'
	option device 'tun0'

Here my wireless configuration:

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'pci0000:00/0000:00:00.0'
	option htmode 'VHT80'
	option cell_density '0'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/ahb/18100000.wmac'
	option htmode 'HT20'
	option cell_density '0'
	option channel '6'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option hidden '1'
	option encryption 'psk2'
	option key '*******'
	option ssid 'OpenVolumio'

config wifi-iface 'wifinet2'
	option device 'radio0'
	option mode 'ap'
	option ssid 'OpenWifi'
	option network 'lan'
	option encryption 'psk2'
	option key '*******'

config wifi-iface 'wifinet3'
	option device 'radio1'
	option mode 'sta'
	option network 'wwan'
	option ssid 'WifiOnAir'
	option encryption 'psk2'
	option key '*******'

config wifi-iface 'wifinet4'
	option device 'radio1'
	option mode 'ap'
	option ssid 'OpenWrtBridge'
	option hidden '1'
	option encryption 'psk2'
	option key '*******'
	option network 'lan wan'

Can anyone help me to solve the problem?
Any reply is really much appreciated!!

Thanks in advance.
k

What is the output of df -h ?

Dear here the result:

Filesystem                Size      Used Available Use% Mounted on
/dev/root                 3.5M      3.5M         0 100% /rom
tmpfs                    60.3M    304.0K     60.0M   0% /tmp
/dev/mtdblock9            9.6M      8.0M      1.6M  84% /overlay
overlayfs:/overlay        9.6M      8.0M      1.6M  84% /
tmpfs                   512.0K         0    512.0K   0% /dev

Today I have seen also that the router doesn't reboot so often (I have disabled ZNC) but the wireless interface that I use for the connection to the main router is restarting automatically every 3 hours circa.

Thanks
k.

You can take a backup of the configuration, reset to defaults, and restore the essential parts only just to be certain that no leftovers are not causing this issues. Then you might want to look at the power supply and try a beefier.

Ok, thanks! I will try to reset to defaults and configure again!

1 Like