Random packet drop after turning on router for some time

I have a Linksys wrt1900acs rev.2 router and I recently installed the latest version of OpenWRT (19.07.4)

I then set it up, leaving everything to their defaults save for configuring my IPv4 WAN interface with my PPPoE credentials.
It works as expected for a few hours and then I start seeing a lot of packet loss when doing anything, even transporting things through my LAN that having nothing to do with the WAN interface.
The packet loss I experience is usually something along the lines of this:
say I ping another PC on my network. I'd get 8 consecutive packets that deliver and 3 consecutive packets that fail.

I power cycle it but the issue persists. (issue resumes immediately, no few hours wait here)

I tried resetting to defaults but the issue still persists also. (again, issue resumes immediately)

The only time I can get it to work properly again for a few hours before breaking again is when I reset it to defaults and then quickly power cycle it.

I really don't see why this is happening.

Any help is appreciated.

Wired or wireless?

the connection is wired to both devices that I tried to ping to and from.

This is weird... LAN to LAN communication happens in the embedded switch, it's almost hardware-only, and should not be affected by the firmware installed.

  1. Try different cables
  2. Try different ports on the embedded switch.
  3. Try another power supply.
  4. Use different lan hosts to make sure the problem is not on them.
2 Likes

I just realized I forgot to mention this doesn't happen with stock firmware.

And I tried it with another pair of devices and its still there.

Can you try downgrading to 19.07.3?

So after a lot of hours of troubleshooting, it turns out I was an idiot. It turns out I made the same mistake in network configuring all the arch Linux PCs that I was using to test this. I think had 2 DHCP clients running at the same time somehow and apparently, the stock router firmware was covering for me. Thanks to OpenWRT now I can have things configured properly. Finally pushed to getting around to manually configuring static IPs for my network.

So I think it's sorted out now.
Thanks, @trendy, @eduperez for your quick answers and sorry for taking your time.

cheers. :slight_smile:

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.