Random cut of client connection

Hello, I'm using OpenWRT on my router as a form of extending my 5G wifi to ethernet in my room as I do not have another option nor the money to buy a good performing adapter.

Recently I've been having issues with the router having a good connection, then randomly cutting out for seconds, minutes and even until I manually reboot it.

It usually leaves these logs in the kernel:

[49685.257842] wlan1: deauthenticating from 38:70:0c:4e:cc:d2 by local choice (Reason: 3=DEAUTH_LEAVING)
[49689.431241] br-lan: port 2(wlan1-1) entered blocking state
[49689.442192] br-lan: port 2(wlan1-1) entered disabled state
[49689.453546] device wlan1-1 entered promiscuous mode
[49689.463429] br-lan: port 2(wlan1-1) entered blocking state
[49689.474353] br-lan: port 2(wlan1-1) entered forwarding state
[49689.927857] br-lan: port 2(wlan1-1) entered disabled state
[49694.010918] wlan1: authenticate with 38:70:0c:4e:cc:d2
[49694.724383] wlan1: send auth to 38:70:0c:4e:cc:d2 (try 1/3)
[49695.150712] wlan1: authenticated
[49695.163824] wlan1: associate with 38:70:0c:4e:cc:d2 (try 1/3)
[49695.370822] wlan1: RX AssocResp from 38:70:0c:4e:cc:d2 (capab=0x411 status=0 aid=1)
[49695.386301] wlan1: associated
[49695.413663] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
[49695.486063] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1-1: link becomes ready
[49695.499203] br-lan: port 2(wlan1-1) entered blocking state
[49695.510104] br-lan: port 2(wlan1-1) entered forwarding state
[49695.539897] wlan1: Limiting TX power to 27 (30 - 3) dBm as advertised by 38:70:0c:4e:cc:d2

Here's a dump of the logs:

Please help me, thanks!