Random crashes on APU2E0

Hi! Im totally new to this diy networking, I am having some problems that I feel seem pretty strange.

I got my router today in the mail a APU2E0 board and a Qualcomm wireless adapter and all that.

I did mess around with it a bit. Mostly dns stuff and I also tried installing a SQM package whiteout any luck. However hours later while I was sitting in my sofa watching some YouTube I noticed that my IPhone 11 pro max was not connected to the network.

The phone can see my SSID and looks to be connected to it but underneath it says that there is no internet connection. Which is strange sense my laptop is fine and streaming 4k YouTube.

I immediately assume that something is wrong whit the phone. I updated it and tried resetting my network settings. But the problem persisted.
At this point I started to suspect that Openwrt wasn’t playing nicely whit my phone. I found some tips about this in a forum, recommending me to make the SSID just one word and also changing my wifi from 80 to 40 MHz in channel with.

This is where I encountered the next problem. After making these changes and clicking the save and apply button the system would simply stop. But after refreshing the page it would come back, but without the changes actually being applied. I tried a couple more times rebooting in between without any luck. I started to roll back some of the things I had tweaked, but without any luck. After that I went in to software and looked if there was any updates. There was and I updated all packages that it showed. But still the status of the router deteriorated. Now instead of just being able to refresh the page when the GUI froze it would shut of and then after about a minute later reconnect. At this point I tried to reset the hole box. But it would not accept the command lines that I found online for a soft reset.

Even more strange the system would then shut off completely and I could no longer connect to it ether by GUI or by the shell. I then tried hooking the router up to my laptop whit a ethernet cable, witch also failed. So at this point I no longer have access to the router and don’t really know what to do.

It feels so strange how it progressively got worse and worse. That to me is not a usual thing that happens to computers. Either it works or not. sorry for the long explanation but this problem is so strange to me that I had to try and be precise in my description.

Any help is appreciated.