Ran nand erase.chip....help?

Unfortunately I do not. If I have to hex edit my way through this I may as well. Not sure how it's gonna be done exactly.

I was hoping that flashing the original wrt1900ac bootloader that i downloaded would help but it does not look like it's going to.

I also noticed that I cannot do


I have to type


Which concerns me.

Ok so I found this

And it does not look so bad. All I would need to do is put in the mac address and wifi info and that would be it, right?

If so, how exactly? (I'm still trying to figure out a way here. May update you all if I am successful or if i come across something else)

bit of info

1 Like

I do not understand? those instructions helped only a little. When I typed "tftp" it was looking for a file literally named "". So i do not know what i did wrong here. Also, the command "get" it gave me "unknown command".

i was able to use kwboot-patched to restore the boot loader and then get back to factory stock firmware from linksys but its stuck at "please wait".

Currently trying to figure out how to fill out the dev info partition in mtd3. I have no idea how and i am hoping to find the answer how. Like do i type those commands at the "Marvell>>" prompt or in linksys stock firmware itself?

I started over from scratch. i issued the command "nand erase.chip" again and followed the instructions in the link you posted and also used the same files as well.

so i saved the logfile in google docs and created a link to it.

The only useful thing i learned about really was the devinfo mtd whatever and thats it. I already created my own but i do not know how to flash it to mtd3 specifically.

It feels like i am getting little help here.

The general process to flash only mtd3 would be to install and load kmod-mtd-rw so that the mtd partitions are not write protected, then prepare a file that is an image of what you want in mtd3, then use nandwrite to write it to the chip.

Did you do step 7?

The get command is part of tftp application, which is not happening; at least from the errors that appear to be occurring.

So after doing a little bit of googling, this is an OpenWRT package.

Which would mean that i would have to flash openwrt back to the router, use this tool, and then flash back to linksys firmware. Right?

That part, i did not know about.

Instead what i had done originally was use linux to run kwboot and then used tftpd on a seperate windows computer to send the boot loader to the router and then later the linksys stock firmware that i wanted to test in the first place.

That's assuming you're running OpenWrt. Stock firmware likely does not allow writing to the devinfo partition since it's only supposed to be written at the factory.

You could likely run OpenWrt from RAM using an initramfs image that you tftp in to the bootloader. This will let you modify the flash without flashing the whole image.

I could, but i just installed openwrt back on the router.

Doing this will still allow me to flash the mtd3 partition yeh?

Also, i had made a text file "sysinfo.cgi" and copied the info from the chadter777 link into the text file. i filled out the necessary blanks and placed it in the tftp folder.

figuring out the kmod-mtd-rw package atm...unless anyone wants to enlighten me here while i figure it out

EDIT: Also, i noticed that the mac address on the label of the router does not match up with the one in the interface...or any of them. I know that there are at least 3 different mac addresses, but what i care about is the one on the label not matching any of them in the interface.

Could it be that i have wiped out all mac addresses? or is it just for the one on the label?

EDIT2: forgot to post the link.

The devinfo appears to be text key-value pairs. Realize that echo "key=value" >> file
is a shell command to add the literal text in the quotes to the end of the file. You could do the same thing with a text editor. I believe the real devinfo has something other than a regular line break between entries, but likely it will still parse if it does have line breaks.

hw_mac_addr should be the first one on the label of your unit. I believe the other two are made at run time by adding one and two to that base address. If OpenWrt is unable to locate a "factory" MAC address during bootup it will create one at random.

I just realized that as i was taking this router apart to find a mac address, I had remembered that my younger self had made nvram back ups of this router when i was originally testing it for WDS things.

I still have it :smiley: . And its for dd-wrt. So i used notepad+ to check it and it indeed does have at least one of the mac addresses that match the one on the router. i am trying to check for the wireless macs as well.

Would this be all i need then?

also, putting the router back together atm. will be making an attempt it this thing later once its put together.

EDIT: it appears that the wireless macs i found in the nvram backup are indeed different from the wireless macs as well. So im going to assume that once i put the info back in, it will all go back to normal.

so far i changed the name of "sysinfo.cgi" to "devinfo" and copied it to the tmp folder using winscp.

i tried to run the flash_erase commands but it did not work

i also tried nand flash commands as well but still nothing...so i must be missing another thing.

I looked in the software list and found nand utils and openocd (for giggles)

now i am getting permission denied...hmmm

exactly how do i unlock mtd3?

when i run mtd unlock /dev/mtd3

it gives me "could not open mtd device"

i did run dmesg and i see the devinfo partition in there.

changed over to mcwrt. i was able to execute the commands, but i still dont see a change in mac address.

any idea on how exactly im supposed to save the file? what name it should be? still making some attempts on my part here

ok i got it. i just had to do

nand erase.part ubifs
nand erase.part syscfg

then i made sure that the linksys firmware was loaded on the tftp server and ran

run update_both_images

and it worked.


If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.