Radio/Wireless not working anymore (ZyXEL NBG6817 / Atheros QCA9984)

Dear Forum,

In advance: Thanks to all that are providing support for this fantastic project and all of it's additional software packages. You ladys/gents are absolutely fantastic !

I'm currently expiring an issue that I've never seen before in this extent with my device, which was working perfectly fine until today.

My HW/config:

Device: ZyXEL NBG6817
OpenWRT version: OpenWrt 19.07.3 r11063-85e04e9f46 / LuCI openwrt-19.07 branch git-20.186.82389-282dbf8 (Everything up to date)
Kernel version: 4.14.180

Fault picture:

1. The 2,4 GHz WIFI (RADIO1) stopped working today.
I tired to reboot the whole device, changed the channel/width to some other settings, disabled and re-activated the radio but: No chance to get it up and running again.

The strange thing is that it seemed to work just fine, but the SSID was not visible and no client was able to connect.

I then tried to regenerate the configuration and then rebooted the device.

rm -f /etc/config/wireless
wifi config

... and fter that:

2. Then the second radio stopped working too :frowning:

No matter what I'm doing, both radios are keeping in the state: "Device is not available" and therefore the networks underneath have got the täte "Device is not active".

Edit: I restored a working Backup and now RADIO0 (5G) is working again.

What can I do to bring the 2,4 GHz back to life again ?
I'm afraid that regenerating the configuration will lead to the problem #2 again.

Current WIFI configuration:

root@XXXXXXXX:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'VHT80'
        option channel 'auto'
        option country 'AT'
        option txpower '20'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'BlackHole 5G Link'
        option encryption 'psk2'
        option wpa_disable_eapol_key_retries '1'
        option key '16 char secure password :)'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
        option htmode 'HT20'
        option country 'AT'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'BlackHole 2.4G Link'
        option encryption 'psk2'
        option wpa_disable_eapol_key_retries '1'
        option key '16 char secure password :)'

Latest syslog (Please ignore DNS errors, I had a faulty rule running in the Firewall):

root@RXXXXXXXX:~# **logread | grep err**
Tue Jan 12 18:21:45 2021 kern.err kernel: [    0.037883] msm_bus_fabric_init_driver
Tue Jan 12 18:21:45 2021 kern.err kernel: [    2.033288] ar8327: qca,phy-rgmii-en is not specified
Tue Jan 12 18:21:45 2021 kern.err kernel: [    2.217466] Calibration not found.
Tue Jan 12 18:21:45 2021 kern.info kernel: [    2.311942] sdhci: Copyright(c) Pierre Ossman
Tue Jan 12 18:21:45 2021 user.err kernel: [    9.692685] block: unable to load configuration (fstab: Entry not found)
Tue Jan 12 18:21:45 2021 user.err kernel: [    9.693695] block: no usable configuration
Tue Jan 12 18:21:45 2021 kern.warn kernel: [   11.403076] ath10k_pci 0000:01:00.0: Direct firmware load for ath10k/fwcfg-pci-0000:01:00.0.txt failed with error -2
Tue Jan 12 18:21:45 2021 kern.err kernel: [   19.380672] firmware ath10k!fwcfg-pci-0000:01:00.0.txt: firmware_loading_store: map pages failed
Tue Jan 12 18:21:45 2021 kern.warn kernel: [   19.382492] ath10k_pci 0000:01:00.0: Direct firmware load for ath10k/QCA9984/hw1.0/ct-firmware-5.bin failed with error -2
Tue Jan 12 18:21:45 2021 kern.err kernel: [   19.413964] firmware ath10k!QCA9984!hw1.0!ct-firmware-5.bin: firmware_loading_store: map pages failed
Tue Jan 12 18:21:45 2021 kern.warn kernel: [   19.414109] ath10k_pci 0000:01:00.0: Direct firmware load for ath10k/QCA9984/hw1.0/ct-firmware-2.bin failed with error -2
Tue Jan 12 18:21:45 2021 kern.err kernel: [   19.478496] firmware ath10k!QCA9984!hw1.0!ct-firmware-2.bin: firmware_loading_store: map pages failed
Tue Jan 12 18:21:45 2021 kern.warn kernel: [   19.478708] ath10k_pci 0000:01:00.0: Direct firmware load for ath10k/QCA9984/hw1.0/firmware-6.bin failed with error -2
Tue Jan 12 18:21:45 2021 kern.err kernel: [   19.510542] firmware ath10k!QCA9984!hw1.0!firmware-6.bin: firmware_loading_store: map pages failed
Tue Jan 12 18:21:45 2021 kern.warn kernel: [   28.412847] ath10k_pci 0001:01:00.0: Direct firmware load for ath10k/fwcfg-pci-0001:01:00.0.txt failed with error -2
Tue Jan 12 18:21:45 2021 kern.err kernel: [   28.486035] firmware ath10k!fwcfg-pci-0001:01:00.0.txt: firmware_loading_store: map pages failed
Tue Jan 12 18:21:45 2021 kern.warn kernel: [   28.486642] ath10k_pci 0001:01:00.0: Direct firmware load for ath10k/QCA9984/hw1.0/ct-firmware-5.bin failed with error -2
Tue Jan 12 18:21:45 2021 kern.err kernel: [   28.525269] firmware ath10k!QCA9984!hw1.0!ct-firmware-5.bin: firmware_loading_store: map pages failed
Tue Jan 12 18:21:45 2021 kern.warn kernel: [   28.525420] ath10k_pci 0001:01:00.0: Direct firmware load for ath10k/QCA9984/hw1.0/ct-firmware-2.bin failed with error -2
Tue Jan 12 18:21:45 2021 kern.err kernel: [   28.571083] firmware ath10k!QCA9984!hw1.0!ct-firmware-2.bin: firmware_loading_store: map pages failed
Tue Jan 12 18:21:45 2021 kern.warn kernel: [   28.571305] ath10k_pci 0001:01:00.0: Direct firmware load for ath10k/QCA9984/hw1.0/firmware-6.bin failed with error -2
Tue Jan 12 18:21:45 2021 kern.err kernel: [   28.603778] firmware ath10k!QCA9984!hw1.0!firmware-6.bin: firmware_loading_store: map pages failed
Tue Jan 12 18:21:49 2021 daemon.err odhcp6c[1611]: Failed to send RS (Address not available)
Tue Jan 12 18:21:50 2021 daemon.err odhcp6c[1611]: Failed to send DHCPV6 message to ff02::1:2 (Address not available)
Tue Jan 12 18:21:50 2021 daemon.err hostapd: Configuration file: /var/run/hostapd-phy1.conf
Tue Jan 12 18:21:50 2021 daemon.err hostapd: Configuration file: /var/run/hostapd-phy0.conf
Tue Jan 12 18:21:51 2021 daemon.err odhcp6c[1611]: Failed to send DHCPV6 message to ff02::1:2 (Address not available)
Tue Jan 12 18:21:53 2021 daemon.err block: mounting /dev/mmcblk0p5 (squashfs) as /mnt/mmcblk0p5 failed (5) - Not a tty
Tue Jan 12 18:22:01 2021 daemon.err openvpn(vserv)[2773]: RESOLVE: Cannot resolve host address: XXXXXXXXXXXXX:1194 (Try again)
Tue Jan 12 18:22:03 2021 daemon.err hostapd: Using interface wlan1 with hwaddr 54:83:3a:70:bf:cc and ssid "BlackHole 2.4G Link"
Tue Jan 12 18:22:06 2021 daemon.err openvpn(vserv)[2773]: RESOLVE: Cannot resolve host address: XXXXXXXXXXXXXX:1194 (Try again)
Tue Jan 12 18:22:08 2021 daemon.err stubby[3032]: [17:22:08.046343] STUBBY: Stubby version: Stubby 0.3.0
Tue Jan 12 18:22:08 2021 daemon.err stubby[3032]: [17:22:08.063221] STUBBY: Read config from file /var/etc/stubby/stubby.yml
Tue Jan 12 18:22:08 2021 daemon.err stubby[3032]: [17:22:08.064385] STUBBY: DNSSEC Validation is ON
Tue Jan 12 18:22:08 2021 daemon.err stubby[3032]: [17:22:08.064574] STUBBY: Transport list is:
Tue Jan 12 18:22:08 2021 daemon.err stubby[3032]: [17:22:08.064748] STUBBY:   - TLS
Tue Jan 12 18:22:08 2021 daemon.err stubby[3032]: [17:22:08.064920] STUBBY: Privacy Usage Profile is Strict (Authentication required)
Tue Jan 12 18:22:08 2021 daemon.err stubby[3032]: [17:22:08.065095] STUBBY: (NOTE a Strict Profile only applies when TLS is the ONLY transport!!)
Tue Jan 12 18:22:08 2021 daemon.err stubby[3032]: [17:22:08.065271] STUBBY: Starting DAEMON....
Tue Jan 12 18:23:29 2021 daemon.err hostapd: Using interface wlan0 with hwaddr 54:83:3a:70:bf:cd and ssid "BlackHole 5G Link"
Tue Jan 12 18:24:13 2021 daemon.err uhttpd[2640]: luci: accepted login on / for root from 192.168.1.10

Disk usage:

root@XXXXXX:~# df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/root                 3.8M      3.8M         0 100% /rom
tmpfs                   234.6M    352.0K    234.3M   0% /tmp
/dev/loop0               54.5M     41.6M      8.6M  83% /overlay
overlayfs:/overlay       54.5M     41.6M      8.6M  83% /
tmpfs                   512.0K         0    512.0K   0% /dev
/dev/mmcblk0p10           3.0G      5.5M      2.8G   0% /mnt/mmcblk0p10
/dev/mmcblk0p1            2.9M    135.0K      2.5M   5% /mnt/mmcblk0p1
/dev/sda1                56.6G     81.1M     53.6G   0% /mnt/sda1  **(This is the drive containing my Adblock lists)**

And some pictures:

Edit: Can just post 1 image (new user).

Please let me know if further infos are needed.

Thanks very much for your help!!
Regards,
M.

Does iw dev show a 2.4 GHz AP including lines for SSID and channel?

that looks strange, you should try last stable openwrt and see.

Thanks for the quick responses guys!

@mk24 yess it does:

@bricco1981: Yeah I could try that since I've got NO idea what's wrong.

The strange thing is, that the router worked fine over months.

Additionally, after restoring the last known good config, the device is unable to resolve openwrt.org (DNS).

Don't ask me why, the installation of dnsmasq+stubby (including DNSSEC) worked fine too for a few days and it seem's that only resolving openwrt.org doesn't work.

Maybe I'll start over again tomorrow, it seems that something out there hates me today ;(

The software all looks like the AP should be on the air. Possibly there's hardware failure.

The gold standard to check for hardware failure is to flash back and run stock firmware.

After walking down the long and sh*tty road in order to replace OpenWRT with the Zyxel OEM Firmware, the issues continue yaaaaaaaay -_- (writing it down real quick because it can't be on the WWW often enough):

  1. Set up a TFTP Server on a Node on your network
  2. Set the IP of the TFTP Host to 192.168.1.99
  3. Place the Zyxel OEM Firmware into the TFTP Server's Download directory
  4. Rename the OEM Firmware BIN file to "ras.bin"
  5. Switch on the Router, while holding the WPS Button on the Routers backside.
  6. The Router now is getting the BIN File from the TFTP Host and flashes the Device with it.

--> The Power LED and the 2.4 GHz LED are blinking while the Router is flashing. In my case, they didn't stop when it was finished. I waited for about an hour until I (after a beer) was brave enoiugh to reset it.

--> Router came up with default IP setting and the web interface is responding.

Now that SOAB won't let me in.
It's documented well that the defualt password should be '1....2....3....4' Spaceballs voices in my head.

It is not. Definitly not. Really not...
Here is a tiny list of what I tried so far:

1234
admin
blank
ZyXel
password
Password
Zyxel
zyxel
default

Maybe it's just my frustration or the buzz in my brain after 12 hours of work or the upcoming frustration, originating from the hours and hours I spent with this little f*cker, but I think that thing just hates me, or is satans reincarnation...

Maybe someone here has got a hint regarding the default password?
For sure I tried to open a thread in the ZyXel support forums, but guess what:

The funny thing on top is, that one can click on "View Server status" on that page, which needless to say prints: "Everything is cool" in big green letters ...

What are they usually doing at ZyXel ? Something with Software I heared...

Ahh and BTW: No WIFI visible with the standard Firmware and fresh standard settings. That doesn't give me trust I have to say.

I'll continue tomorrow pushing my luck to the limits by contacting the ZyXel Support somehow and I will update this thread.

So long - I'm going to bed now....

Boot the stock firmware then set it to defaults with the reset button.

The default password for ZyXEL is indeed 1234, however your original OEM firmware configuration is remembered (as OpenWrt doesn't use tiny 4 MB overlay chosen the by OEM firmware and leaves it untouched (so whatever has been there originally remains). As @mk24 mentioned, a factory reset should sort this out.

Good morning everyone!

Yesterday when I went to bed I noticed that the WIFI Networks, powered by the OEM Firmware, were functional.

You were right, mk24, the factoy reset did reset the PW to 1234.

I installed OpenWrt 19.07.5, reconfigured everything and the device seems to be functional by now, including both WIFI networks.

So everythings fine, I hope it stays that way.
Thanks for helping - I will mark this issue as solved.

All the best & kind regards
M.