R8000 5GHz Wifi issue

Does the R8000, still have the stability problem? I am running myself about a year old image at the moment and seeing the same once in a month wifi problem which requires reboot to solve the problem.

LEDE Reboot 17.01.2 r3435-65eec8bd5f / LuCI lede-17.01 branch (git-17.152.82987-7f6fc16)

wlan0 & wlan1 works, but wlan2 still can't work. And wlan0 can only work on 40MHZ.

Could you tell me some details about wlan0 & wlan2 ? Such as, channel & bandwidth.
I guess the setting about wlan may lead to this.

config wifi-device 'radio0'
    option type 'mac80211'
    option hwmode '11a'
    option path '18000000.axi/bcma0:7/pci0000:00/0000:00:00.0/0000:01:00.0'
    option htmode 'VHT80'
    option txpower '20'
    option channel '153'
    option country 'US'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option encryption 'psk2'
        option key 'yourpassword'
        option ssid 'yourssid'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path '18000000.axi/bcma0:8/pci0001:00/0001:00:00.0/0001:01:00.0/0001:02:01.0/0001:03:00.0'
        option country 'US'
        option htmode 'HT40'
        option channel '6'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option encryption 'psk2'
        option key 'yourpassword'
        option ssid 'yourssid'

config wifi-device 'radio2'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path '18000000.axi/bcma0:8/pci0001:00/0001:00:00.0/0001:01:00.0/0001:02:02.0/0001:04:00.0'
        option htmode 'VHT80'
        option country 'US'

config wifi-iface 'default_radio2'
        option device 'radio2'
        option network 'lan'
        option mode 'ap'
        option ssid 'yourssid.5g'
        option encryption 'psk2'
        option key 'yourpassword'

With kernel 4.4 all wifi work.
See my report: https://bugs.lede-project.org/index.php?do=details&task_id=1079

Hi to all, I'm trying to hide SSIDs (radio0 and radio1) without success....why? I don't understand! (I have the latest version)

config wifi-device 'radio0'
    option type 'mac80211'
    option hwmode '11a'
    option path '18000000.axi/bcma0:7/pci0000:00/0000:00:00.0/0000:01:00.0'
    option disable '0'
    option htmode 'VHT20'
    option country 'US'
    option channel 'auto'

config wifi-device 'radio1'
    option type 'mac80211'
    option hwmode '11g'
    option path '18000000.axi/bcma0:8/pci0001:00/0001:00:00.0/0001:01:00.0/0001:02:01.0/0001:03:00.0'
    option htmode 'HT40'
    option channel '11'
    option country 'IT'

config wifi-device 'radio2'
    option type 'mac80211'
    option hwmode '11a'
    option path '18000000.axi/bcma0:8/pci0001:00/0001:00:00.0/0001:01:00.0/0001:02:02.0/0001:04:00.0'
    option htmode 'VHT80'
    option disabled '0'
    option country '00'
    option channel '36'

config wifi-iface
    option device 'radio0'
    option mode 'ap'
    option network 'lan'
    option encryption 'psk2'
    option key 'SAMEPASSWORD'
    option ssid 'SAMENAME'
    option macaddr 'xx:xx:xx:xx:xx:xx'
    option hidden '1'

config wifi-iface
    option device 'radio1'
    option mode 'ap'
    option ssid 'SAMENAME'
    option network 'lan'
    option encryption 'psk2'
    option key 'SAMEPASSWORD'
    option macaddr 'xx:xx:xx:xx:xx:xx'
    option hidden '1'

config wifi-iface
    option network 'wwan'
    option ssid 'xxxxxxxxxxxxxxxx'
    option encryption 'psk2'
    option device 'radio2'
    option mode 'sta'
    option bssid 'xx:xx:xx:xx:xx:xx'
    option key 'xxxxxxxxxxxxxxxxxxxxx'
    option macaddr 'xx:xx:xx:xx:xx:xx'

Is this the final solution for R8000 routers? (Install a kernel 4.4 build?)

If so, do I need to set up a build environment to compile for the earlier kernel, while keeping other fixes?

As of now, I have the latest build working on my R8000: I solved the problem with wifi using US as regdomain and channels 153, 40 and 1

Tested and can attest to @pmera's response. I still faced the issue with the most recent build. Just edit the wireless setting and set the channels to something like 153, 40 and 1 and all 3 radios start working.

I was previously at US/149, US/11, and US/40 for radios 0, 1, 2, respectively. I will change radios 0 and 1 to 153 and 1, while leaving radio 2 as it was.

When I did my post a few days ago, I only had radio 1 enabled on channel 11, as the other radios would not work consistently. I ended up having to reboot the router when I noticed the wifi was not working. I had plenty of messages in the log about the broadcomm drivers but didn't save it before rebooting.

The only other non-default settings I use would vlans. I use vlans to keep my home appliances (blue-ray players, tv's, surround sound, ipads, etc...) away from my work computers.

I'm currently running the following, from a few months back...

  • LEDE Reboot SNAPSHOT r5285-dea3bad / LuCI Master (git-17.309.31241-676ce11)
  • Kernel Version 4.9.58

old...
mine is

  • OpenWrt SNAPSHOT r5493-b822088 / LuCI Master (git-17.343.27587-8e6b1a6)
  • Kernel 4.9.67

Seems that the main problem is related to the lack of part of regdomains. For example, If I set as regdomain my country (IT), I experience issues setting up 5 GHz interfaces. How can I help to fix this problem?

how can I include other regdomains?

I'm having similar issues in France. I've tried using the latest official release for the R8000 (which ships with 4.4) and I've tried multiple configurations, such as having all radios on US or all on FR.

Having all radios on US, I've managed to have only the 1st 5Ghz radio (The one with the higher bands) up, and the 2.4Ghz up. The last 5Ghz (lower channels) does not come up.

I'm rolling back to stock firmware for now as I've tried all possible configurations for about 2 hours and could not see any improvement

the problem is certain, it exists and many have found it!

Yes... That's why I'm on SNAPSHOT build, like I wrote before...

For sure... Is there someone who can help me including Italian regdomain?

Try with my "illegal" configuration for your and my country

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11a'
	option path '18000000.axi/bcma0:7/pci0000:00/0000:00:00.0/0000:01:00.0'
	option channel '153'
	option country 'US'
	option txpower '20'
	option htmode 'VHT40'
	option noscan '1'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option key 'PASSWORD'
	option wpa_disable_eapol_key_retries '1'
	option wps_pushbutton '0'
	option encryption 'psk2+ccmp'
	option ssid 'LEDE'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option path '18000000.axi/bcma0:8/pci0001:00/0001:00:00.0/0001:01:00.0/0001:02:01.0/0001:03:00.0'
	option htmode 'HT40'
	option country 'US'
	option noscan '1'
	option channel '1'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option key 'PASSWORD'
	option wpa_disable_eapol_key_retries '1'
	option wps_pushbutton '0'
	option encryption 'psk2+ccmp'
	option ssid 'LEDE'

config wifi-device 'radio2'
	option type 'mac80211'
	option hwmode '11a'
	option path '18000000.axi/bcma0:8/pci0001:00/0001:00:00.0/0001:01:00.0/0001:02:02.0/0001:04:00.0'
	option country 'US'
	option htmode 'VHT40'
	option noscan '1'
	option channel '48'

config wifi-iface 'default_radio2'
	option device 'radio2'
	option network 'lan'
	option mode 'ap'
	option encryption 'psk2'
	option key 'PASSWORD'
	option wpa_disable_eapol_key_retries '1'
	option wps_pushbutton '0'
	option ssid 'LEDE'

and use the SNAPSHOT instead of latest stable release

Guys,

is there a way to add to the regdomain of the r8000 the IT country with all the right frequencies?

This is still an issue with the newest build (18.06 r7808) and the R8000 when the regulatory region is set to something other than US.

If i set it to UK, and set the channel to 13 for the BGN radio 1, i get:
Tue Sep 17 17:24:38 2019 kern.err kernel: [ 3054.999393] ieee80211 phy1: brcmf_cfg80211_start_ap: Set Channel failed: chspec=6411, -52

but can set it to channel 8 fine.

radio0 is kinda useless because none of the high frequencies at 80Mhz width are legal in the UK - which explains why that doesn't work properly, so i've disabled that.

But radio2 works fine when set to channel 48, but doesn't for any other channels (giving the same error as above for radio1)