R7800 wifi power level settings don't appear to change anything

Does the current firmware actually do anything with changing power level settings? I've tried 1mw and 1w transmissions on both bands, and I observe no difference standing a good distance from the router and taking signal strength measurements on wifi app on phone.

Or is my test wrong?

OpenWrt 18.06.4, r7808-ef686b7292

@sjcauser,welcome to the community!

  • For clarity, you're saying that you tested one watt power on a R7800?
  • How (can you show pics of this setting, or the config)?
  • Did you verify there was a change on the command line?

thanks for the welcome!

I'm setting the tx power level in luci, with this url:
..... cgi-bin/luci/admin/network/wireless/radio1.network1

At top section I found "transmit power" pull down. I set it to either
0 or 23/30 dbm (depend on band). Then I check on command line with 'iw dev' and verify that at least 'iw' thinks it changed:

root@router-sjc:~# iw dev
phy#1
Interface wlan1
ifindex 11
wdev 0x100000002
ssid xxxx
type AP
channel 7 (2442 MHz), width: 40 MHz, center1: 2432 MHz
txpower 0.00 dBm
phy#0
Interface wlan0
ifindex 10
wdev 0x2
ssid xxxx
type AP
channel 52 (5260 MHz), width: 80 MHz, center1: 5290 MHz
txpower 0.00 dBm

then:
root@router-sjc:~# iw dev
phy#1
Interface wlan1
ifindex 10
wdev 0x100000002
ssid xxxx
type AP
channel 7 (2442 MHz), width: 40 MHz, center1: 2432 MHz
txpower 30.00 dBm
phy#0
Interface wlan0
ifindex 11
wdev 0x2
ssid xxxx
type AP
channel 52 (5260 MHz), width: 80 MHz, center1: 5290 MHz
txpower 23.00 dBm

results standing in far corner of house:
at 0 dbm:
channel 7: 64 dbm
channel 52: -80dbm

at 23/30 dbm:

channel 7: -65 dbm
channel 52: -81 dbm

I checked signal strength reception on laptop and also didn't notice any difference.

Interestingly 5ghz band tends to just stop working when changing the power level, at least
on channel 52, so I reboot between config changes.

Try something in between: I think I read here that 0 == max.

Thanks fantom-x, that did the trick. Is this a bug?

I have no idea and it is quite likely most users do not us 0 for power, but that is just a guess.

My usage scenario is that my two devices on one band are extremely close to router, and I wanted to be neighbor friendly and use the lowest power setting if that works, or increase the power in increments to suit my needs.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.