R7800 WiFi issues

Hi all,

Since putting OpenWRT on my new R7800 I haven’t been able to get WiFi stability, I lose both bands at various points. 5ghz seems to have the most issues though.

Yesterday I installed the following version of the hnyman build OpenWrt 18.06-SNAPSHOT r7653-939fa07b04. I did a TFTP flash to the factory OpenWRT then to the hnyman build above. Looking this morning I see that the log file looks like this;

Sat Jan 19 00:18:02 2019 kern.warn kernel: [44380.360839] ath10k_pci 0001:01:00.0: received unexpected tx_fetch_ind event: in push mode
Sat Jan 19 00:18:02 2019 kern.warn kernel: [44380.369247] ath10k_pci 0001:01:00.0: received unexpected tx_fetch_ind event: in push mode
Sat Jan 19 00:18:02 2019 kern.warn kernel: [44380.377330] ath10k_pci 0001:01:00.0: received unexpected tx_fetch_ind event: in push mode
Sat Jan 19 00:18:02 2019 kern.warn kernel: [44380.385490] ath10k_pci 0001:01:00.0: received unexpected tx_fetch_ind event: in push mode
Sat Jan 19 00:18:02 2019 kern.warn kernel: [44380.393648] ath10k_pci 0001:01:00.0: received unexpected tx_fetch_ind event: in push mode
Sat Jan 19 00:18:02 2019 kern.warn kernel: [44380.401810] ath10k_pci 0001:01:00.0: received unexpected tx_fetch_ind event: in push mode
Sat Jan 19 00:18:02 2019 kern.warn kernel: [44380.409988] ath10k_pci 0001:01:00.0: received unexpected tx_fetch_ind event: in push mode
Sat Jan 19 00:18:02 2019 kern.warn kernel: [44380.418129] ath10k_pci 0001:01:00.0: received unexpected tx_fetch_ind event: in push mode
Sat Jan 19 00:18:02 2019 kern.warn kernel: [44380.426290] ath10k_pci 0001:01:00.0: received unexpected tx_fetch_ind event: in push mode

I noticed that the country code in the 5ghz is set to US so I set it to GB and now it won’t come back up, the only way to get it back is via a restart. I’m not sure why I’m having these issues;

Sat Jan 19 08:50:34 2019 daemon.err hostapd: hostapd_free_hapd_data: Interface wlan0 wasn't started
Sat Jan 19 08:50:34 2019 daemon.notice netifd: radio0 (12257): WARNING (wireless_add_process): executable path /usr/sbin/wpad does not match process 7783 path ()
Sat Jan 19 08:50:34 2019 daemon.notice netifd: radio0 (12257): Device setup failed: HOSTAPD_START_FAILED
Sat Jan 19 08:52:24 2019 user.notice mac80211: Failed command: iw phy phy0 set antenna all all
Sat Jan 19 08:52:24 2019 daemon.notice netifd: radio0 (12536): command failed: Not supported (-95)
Sat Jan 19 08:52:24 2019 user.notice mac80211: Failed command: iw phy phy0 set distance 0
Sat Jan 19 08:52:24 2019 daemon.err hostapd: Configuration file: /var/run/hostapd-phy0.conf
Sat Jan 19 08:52:30 2019 kern.info kernel: [75248.540276] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Sat Jan 19 08:52:30 2019 kern.warn kernel: [75248.541959] ath10k_pci 0000:01:00.0: peer-unmap-event: unknown peer id 1
Sat Jan 19 08:52:31 2019 daemon.err hostapd: nl80211: Could not configure driver mode
Sat Jan 19 08:52:31 2019 daemon.err hostapd: nl80211 driver initialization failed.
Sat Jan 19 08:52:31 2019 daemon.err hostapd: hostapd_free_hapd_data: Interface wlan0 wasn't started

Does anyone have any ideas what is wrong, I’m going to have to go back to stock at this rate as the other users whilst loving the QOS via Cake, aren’t loving the stability issues.

First guess is that you are using a invalid radio channel for your new country setting or something similar, which makes hostapd unable to initialise radios.

Start with as vanilla wifi config as possible: narrow HT band, first channel (1 or 36) etc.

Hnyman, firstly thanks for the build, what does the kernel warning mean? Is that a WiFi crash? The 5ghz was still up this morning when I noticed the kernel warnings. I have set the channel to 36 now, I went higher as I have a neighbor on 44.

I think these are the uk channels for 5ghz;

image

WiFi came straight back on 36. I have 2.4ghz set to channel 1 20mhz, yesterday my Galaxy S8 was connected but stating that it had no internet.

No idea about the specifics, but not a full wifi crash. Some how invalid/unexpected traffic.

1 Like

Still getting these on channel 36;

Sat Jan 19 10:27:23 2019 kern.warn kernel: [ 3679.934240] ath10k_pci 0001:01:00.0: received unexpected tx_fetch_ind event: in push mode
Sat Jan 19 10:27:23 2019 kern.warn kernel: [ 3679.934291] ath10k_pci 0001:01:00.0: received unexpected tx_fetch_ind event: in push mode
Sat Jan 19 10:27:23 2019 kern.warn kernel: [ 3679.941566] ath10k_pci 0001:01:00.0: received unexpected tx_fetch_ind event: in push mode
Sat Jan 19 10:27:23 2019 kern.warn kernel: [ 3679.949661] ath10k_pci 0001:01:00.0: received unexpected tx_fetch_ind event: in push mode
Sat Jan 19 10:35:03 2019 daemon.warn odhcpd[1310]: DHCPV6 RENEW IA_NA from 00020000ab11845df546a84fcdf5 on br-lan: no binding

If the WiFi doesn't crash are these safe to ignore?

Does anyone know the reason why, when I have used TFTP to go back to stock firmware that the router still has a different password from the default option of password. Not sure why it’s not wiping entirely?

Stock firmware possibly stores its settings into some Netgear-only partition that OpenWrt does not touch at all, so your old OEM settings are probably still there (eventhough you have used OpenWrt in meanwhile).

Do you think a factory reset through the gui would get rid of that after the TFTP, not that it really matters but I’m just a little concerned that there maybe some settings getting messed up. Is there a command that can be run to totally wipe and reset?

No idea about clearing the OEM firmware settings. Probably clear via GUI works (if there is that kind of option), or reset may also work. Look for their docs, knowledgebase & forum for help.