R7800 Wifi download speed is half of upload speed?!

Hi there.
Today I've installed OpenWrt 19.07.7 r11306-c4a6851c72 on my R7800. (as Access Point, not sure if the switch config is correct, would appreciate if somebody checked (Vlan) :wink: ) That worked flawlessly. So far so good. However, when I tested my Wifi, the upload speed was twice as fast as my download speed. I've tested it with multiple devices, same result. I have no clue what the problem is.....

These are my speedtests and config files:

Upload:

iperf3 -c 10.168.1.1
Connecting to host 10.168.1.1, port 5201
[  5] local 10.168.1.175 port 56210 connected to 10.168.1.1 port 5201
[ ID] Interval           Transfer     Bitrate         Retr  Cwnd
[  5]   0.00-1.00   sec  68.1 MBytes   571 Mbits/sec    0   3.05 MBytes       
[  5]   1.00-2.00   sec  77.5 MBytes   650 Mbits/sec   69   2.27 MBytes       
[  5]   2.00-3.00   sec  77.5 MBytes   649 Mbits/sec    0   2.46 MBytes       
[  5]   3.00-4.00   sec  76.2 MBytes   640 Mbits/sec    0   2.62 MBytes       
[  5]   4.00-5.00   sec  76.2 MBytes   640 Mbits/sec   10   1.94 MBytes       
[  5]   5.00-6.00   sec  77.5 MBytes   650 Mbits/sec    0   2.04 MBytes       
[  5]   6.00-7.00   sec  76.2 MBytes   640 Mbits/sec    0   2.12 MBytes       
[  5]   7.00-8.00   sec  78.8 MBytes   661 Mbits/sec   53   1.55 MBytes       
[  5]   8.00-9.00   sec  76.2 MBytes   640 Mbits/sec    0   1.65 MBytes       
[  5]   9.00-10.00  sec  77.5 MBytes   650 Mbits/sec    0   1.72 MBytes       
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-10.00  sec   762 MBytes   639 Mbits/sec  132             sender
[  5]   0.00-10.00  sec   760 MBytes   637 Mbits/sec                  receiver

And download:

iperf3 -c 10.168.1.1 -R
Connecting to host 10.168.1.1, port 5201
Reverse mode, remote host 10.168.1.1 is sending
[  5] local 10.168.1.175 port 56218 connected to 10.168.1.1 port 5201
[ ID] Interval           Transfer     Bitrate
[  5]   0.00-1.00   sec  39.4 MBytes   330 Mbits/sec                  
[  5]   1.00-2.00   sec  45.8 MBytes   384 Mbits/sec                  
[  5]   2.00-3.00   sec  45.5 MBytes   382 Mbits/sec                  
[  5]   3.00-4.00   sec  45.2 MBytes   379 Mbits/sec                  
[  5]   4.00-5.00   sec  42.9 MBytes   360 Mbits/sec                  
[  5]   5.00-6.00   sec  44.1 MBytes   370 Mbits/sec                  
[  5]   6.00-7.00   sec  43.9 MBytes   369 Mbits/sec                  
[  5]   7.00-8.00   sec  45.3 MBytes   380 Mbits/sec                  
[  5]   8.00-9.00   sec  44.7 MBytes   375 Mbits/sec                  
[  5]   9.00-10.00  sec  46.0 MBytes   386 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-10.01  sec   446 MBytes   374 Mbits/sec    1             sender
[  5]   0.00-10.00  sec   443 MBytes   371 Mbits/sec                  receiver

/etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd1a:e15b:9e67::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1 eth1.2'
        option proto 'dhcp'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 1t 2 3 4 5 6'

/etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'VHT80'
        option channel '36'
        option legacy_rates '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'wifi 5.0GHZ'
        option encryption 'psk2'
        option key 'xxxxxxxxxxxxxxx'
        option ft_over_ds '1'
        option ft_psk_generate_local '1'
        option ieee80211r '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
        option htmode 'HT20'
        option channel '5'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option key 'xxxxxxxxxxxxxx'
        option ssid 'wifi'
        option encryption 'psk2'

Only thing I noticed is that TX and RX Rates are not matching. :

Thank you for your time and have a nice day!

Maybe try ath10k non ct drivers?

Thank you for your suggestion!

Download:

iperf3 -c 10.168.1.1 -R
Connecting to host 10.168.1.1, port 5201
Reverse mode, remote host 10.168.1.1 is sending
[  5] local 10.168.1.175 port 56378 connected to 10.168.1.1 port 5201
[ ID] Interval           Transfer     Bitrate
[  5]   0.00-1.00   sec  27.3 MBytes   229 Mbits/sec                  
[  5]   1.00-2.00   sec  43.8 MBytes   367 Mbits/sec                  
[  5]   2.00-3.00   sec  42.6 MBytes   357 Mbits/sec                  
[  5]   3.00-4.00   sec  44.3 MBytes   371 Mbits/sec                  
[  5]   4.00-5.00   sec  44.2 MBytes   371 Mbits/sec                  
[  5]   5.00-6.00   sec  44.8 MBytes   376 Mbits/sec                  
[  5]   6.00-7.00   sec  44.7 MBytes   375 Mbits/sec                  
[  5]   7.00-8.00   sec  44.9 MBytes   377 Mbits/sec                  
[  5]   8.00-9.00   sec  45.3 MBytes   380 Mbits/sec                  
[  5]   9.00-10.00  sec  44.8 MBytes   376 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-10.01  sec   430 MBytes   360 Mbits/sec  146             sender
[  5]   0.00-10.00  sec   427 MBytes   358 Mbits/sec                  receiver


And Upload:

iperf3 -c 10.168.1.1
Connecting to host 10.168.1.1, port 5201
[  5] local 10.168.1.175 port 56390 connected to 10.168.1.1 port 5201
[ ID] Interval           Transfer     Bitrate         Retr  Cwnd
[  5]   0.00-1.00   sec  68.5 MBytes   575 Mbits/sec    0   3.02 MBytes       
[  5]   1.00-2.00   sec  70.0 MBytes   587 Mbits/sec  165   2.12 MBytes       
[  5]   2.00-3.00   sec  76.2 MBytes   640 Mbits/sec   89   1.62 MBytes       
[  5]   3.00-4.00   sec  73.8 MBytes   619 Mbits/sec    4   1.21 MBytes       
[  5]   4.00-5.00   sec  75.0 MBytes   629 Mbits/sec    0   1.29 MBytes       
[  5]   5.00-6.00   sec  75.0 MBytes   629 Mbits/sec    0   1.36 MBytes       
[  5]   6.00-7.00   sec  71.2 MBytes   598 Mbits/sec  217   1.02 MBytes       
[  5]   7.00-8.00   sec  71.2 MBytes   598 Mbits/sec    0   1.08 MBytes       
[  5]   8.00-9.00   sec  71.2 MBytes   598 Mbits/sec    0   1.12 MBytes       
[  5]   9.00-10.00  sec  76.2 MBytes   640 Mbits/sec    0   1.15 MBytes       
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-10.00  sec   729 MBytes   611 Mbits/sec  475             sender
[  5]   0.00-10.01  sec   726 MBytes   608 Mbits/sec                  receiver

And Speedtest:

Unfortunatly that didn't solve the issue, but thank you anyway.

1 Like

This is reproducible and appears to be a bug and a regression. I suggest that this needs to be flagged as a bug/regression to the developers. Looking at htop, this appears to be due to CPU resource now maxing out where it did not before under the same test.

2 Likes

How and where can we flag this? I still have this bug. Thank you for you anwser!