R7800 SQM reducing speeds from 400/20 to around 100/20

Looking for some help setting up SQM correctly so that I am not losing so much speed. My internet is 400down/20up with sqm disabled, but drops to around 100down/20up when sqm enabled. I have tried adjusting most settings without any luck. I know to expect some loss of speed, but this seems excessive.


root@OpenWrt:~# cat /etc/config/sqm

config queue 'eth0'
        option verbosity '5'
        option linklayer 'ethernet'
        option qdisc 'cake'
        option script 'piece_of_cake.qos'
        option interface 'eth0.2'
        option debug_logging '1'
        option download '380000'
        option upload '19000'
        option enabled '1'
        option overhead '34'

@moeller0 Any help would be appreciated.

Is there any need to really throttle the download? The upstream links / bandwidth from servers in use are likely slower than your last mile.
You likely spend, unnecessarily, lots of CPU time in calculating throttling for the download streams.

cake causes heavy calculation for ultra-high speeds (like your half-gigabit...)
Test switching to simple.qos with fq_codel, which consumes much less CPU.

I am mostly off-line while on holiday, so any meaningful response will have to wait until I am back....

1 Like

Why do you even answer? ;- ) Keep on the holiday and don't answer me : -)

1 Like

Thanks for the reply.
With Ingress disabled and cake/POC at 200/20.
On simple/fq_codel, both ingress/egress, I am at 300/20
With ingress disabled, and simple/fq_codel I am now at 350/20.

Seems strange to still have reduced speeds with ingress disabled.