R7800 reflash help - Opkg update reboots router

I installed OpenWRT on a Netgear R7800 today, and when I SSH into the router and execute opkg update, sometimes, it might get through a few of the files it needs to download in order to update the data, other times, it downloads more files than it did at other times, but regardless of how far it gets in completing the update, it always causes the router to reboot.

Here are my stats:
Model : Netgear Nighthawk X4S R7800
Architecture : ARMv7 Processor rev 0 (v7l)
Firmware Version: OpenWrt 18.06.5 r7897-9d401013fc / LuCI openwrt-18.06 branch (git-19.309.48729-bc17ef6)
Kernel Version: 4.14.151

Does anyone have any idea what might be causing this problem or how I should troubleshoot or fix this issue?

Thank you,


Sounds quite weird, but I suspect some memory issue.
What is the output of the following commands?
free; head -n -0 /etc/opkg.conf /etc/opkg/*.conf
Use preformatted text (</> button when you paste the console output).
Other than that is the router stable?


Thank you for responding and taking an interest in this problem ... :slight_smile:

Seems stable enough ... When I first bought the router, I had installed DD-WRT, but no matter what I did, I could not get the wireless to link up any faster than 150MB so I flashed the factory firmware and then was able to link up at 1.3GB (quite a difference) ... then I had a need to port forward 3389 for some time for a work thing, but the router was getting inundated with attacks on that port and since I don't trust windows, I removed the PAT - and what really bothers me about these home routers, is you cannot limit your port forward to a specific internet IP address (which would have prevented the entire planet from trying to hack my windows box) .... so thats when I decided I'd give OpenWRT a shot, thinking I could - if anything - find a package that lets me tune my port address translations a little more tightly than the stock firmware ... and thats when I ran into this issue trying to update the repository database ...

Anyways, here is the output you requested:

root@OpenWrt:~# free; head -n -0 /etc/opkg.conf /etc/opkg/*.conf
             total       used       free     shared    buffers     cached
Mem:        478400      66836     411564        444       2800       9068
-/+ buffers/cache:      54968     423432
Swap:            0          0          0
==> /etc/opkg.conf <==
dest root /
dest ram /tmp
lists_dir ext /var/opkg-lists
option overlay_root /overlay
option check_signature

==> /etc/opkg/customfeeds.conf <==
# add your custom package feeds here
# src/gz example_feed_name http://www.example.com/path/to/files

==> /etc/opkg/distfeeds.conf <==
src/gz openwrt_core http://downloads.openwrt.org/releases/18.06.5/targets/ipq806x/generic/packages
src/gz openwrt_kmods http://downloads.openwrt.org/releases/18.06.5/targets/ipq806x/generic/kmods/4.14.151-1-e0e48e988f7369b5689954f7ddd801b1
src/gz openwrt_base http://downloads.openwrt.org/releases/18.06.5/packages/arm_cortex-a15_neon-vfpv4/base
src/gz openwrt_luci http://downloads.openwrt.org/releases/18.06.5/packages/arm_cortex-a15_neon-vfpv4/luci
src/gz openwrt_packages http://downloads.openwrt.org/releases/18.06.5/packages/arm_cortex-a15_neon-vfpv4/packages
src/gz openwrt_routing http://downloads.openwrt.org/releases/18.06.5/packages/arm_cortex-a15_neon-vfpv4/routing
src/gz openwrt_telephony http://downloads.openwrt.org/releases/18.06.5/packages/arm_cortex-a15_neon-vfpv4/telephony

I'm not sure if this is relevant, but this looks odd to me:

root@OpenWrt:~# opkg --version
opkg version dcbc142e51f5f5f2fb9e4e44657e013d3c36a52b (2019-06-14)

Nothing suspicious here.
If you have not done much configuration, I suggest running a firstboot for reset to defaults and immediately trying to run opkg.

The port forwarding works anyway without the need to install extra packages.

if you have space and/or ext-overlay... i'd say strace it... or move your opkg lists_dir ( in opkg.conf ) to the ext-overlay... ( to alleviate the possible memory glitch trendy hints at ).

any fancy kmods / swap / storage-fstab packages or config keep action?

1 Like

No, but I did forget to mention that before installing OpenWRT, I flashed Voxel and TRIED to get opkg working which entailed formatting a thumb drive, then unraring a file into the root of that drive, then I ran an install script and rebooted ... so im not sure if any of that would have made any changes that persisted when I then flashed OpenWRT ...

I'd be down for wiping the entire file system and installing OpenWRT from scratch ... if that's even possible?

1 Like

You think perhaps doing a boot / tftp flash to factory might be the best way to wipe the device? Sounds logical to me ... but just curious what you think?

It's faster to do a firstboot to restore defaults and start from scratch, before going down the path of upgrading.


Make sure that nothing is sending jumbo frames to any of the router ports - see this thread for more info. If this is the issue, the workaround in post 39 of that thread may be useful...

1 Like