R7800 Rebooting but can't pinpoint why

Have a Netgear R7800 that I have tried Kong build, both master and stable Hnyman builds, and now plain vanilla stable build.

No matter what I have been getting random reboots with varying times, as little as 30 minutes or as much as 23 hours, and can also sometimes force a reboot when running a speedtest (dslreports and/or others). I have it connected to a pfSense box through a smart switch so it's setup as a dumb AP per the guide. I have 3 VLANs (20, 30, 40) and am currently using VLAN 1 for admin until I can get this figured out. pfSense sees all the VLANs and there doesn't seem to be any issues with there. I have setup 2 wifi networks per VLAN for 2.4Ghz and 5Ghz using the same SSID. Guest wifi is currently disabled while I troubleshoot this issue. I have added these to my startup as well:
echo 35 > /sys/devices/system/cpu/cpufreq/ondemand/up_threshold
echo 10 > /sys/devices/system/cpu/cpufreq/ondemand/sampling_down_factor

I have tried to enable irqbalance but no change.

Output from /etc/config/network:

/etc/config/network
config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth1.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.1.10'
	option gateway '192.168.1.1'
	option delegate '0'
	list dns '192.168.1.3'
	list dns '192.168.1.4'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'dhcp'
	option delegate '0'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '6t 4 3 2 1'
	option vid '1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0t 5'
	option vid '2'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option ports '6t 4t'
	option vid '20'

config switch_vlan
	option device 'switch0'
	option vlan '4'
	option ports '0t 4t'
	option vid '30'

config switch_vlan
	option device 'switch0'
	option vlan '5'
	option ports '0t 4t'
	option vid '40'

config interface 'PERSONAL'
	option ifname 'eth1.20'
	option proto 'static'
	option delegate '0'
	option type 'bridge'

config interface 'IOT'
	option ifname 'eth0.30'
	option proto 'static'
	option delegate '0'
	option type 'bridge'

config interface 'GUEST'
	option ifname 'eth0.40'
	option proto 'static'
	option delegate '0'
	option type 'bridge'

Output from /etc/config/wireless:

/etc/config/wireless
config wifi-device 'radio0'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
	option htmode 'VHT80'
	option beacon_int '101'
	option legacy_rates '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option mode 'ap'
	option key 
	option ssid 'Mgmt'
	option hidden '1'
	option encryption 'psk2+ccmp'
	option network 'lan'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
	option htmode 'HT20'
	option beacon_int '101'
	option legacy_rates '0'
	option channel '1'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option mode 'ap'
	option key 
	option ssid 'Mgmt'
	option hidden '1'
	option encryption 'psk2+ccmp'
	option network 'lan'

config wifi-iface 'wifinet2'
	option ssid 'Personal'
	option encryption 'psk2+ccmp'
	option device 'radio0'
	option mode 'ap'
	option key 
	option network 'PERSONAL'

config wifi-iface 'wifinet3'
	option ssid 'Personal'
	option encryption 'psk2+ccmp'
	option device 'radio1'
	option mode 'ap'
	option key 
	option network 'PERSONAL'

config wifi-iface 'wifinet4'
	option ssid 'IOT'
	option encryption 'psk2+ccmp'
	option device 'radio0'
	option mode 'ap'
	option hidden '1'
	option key 
	option network 'IOT'

config wifi-iface 'wifinet5'
	option ssid 'IOT'
	option encryption 'psk2+ccmp'
	option device 'radio1'
	option mode 'ap'
	option key 
	option network 'IOT'
	option hidden '1'

config wifi-iface 'wifinet6'
	option ssid 'Guest'
	option encryption 'psk2+ccmp'
	option device 'radio0'
	option mode 'ap'
	option key 
	option network 'GUEST'
	option disabled '1'

config wifi-iface 'wifinet7'
	option ssid 'Guest'
	option encryption 'psk2+ccmp'
	option device 'radio1'
	option mode 'ap'
	option key 
	option network 'GUEST'
	option disabled '1'

There are no crashlogs created when it reboots so I don't know where to go from here.

I'd start by using a new power supply. Random reboots are usually because of that.

2 Likes

Replacement ordered, will arrive tomorrow.

Looking at the current power supply, it has an output of 12V and 1A which would mean obviously 12 watts. However, the Netgear manual for the R7800 says the output should be 12V and 3.5A making it 42 watts. So could very well likely be the issue of underpowered and rebooting when under load.

1 Like

I’m having reboots with mine too. May be completely different to your issue of course!
My psu is the one that came with it originally.
I can sometimes force a reboot just by logging into the gui but mostly it happens seemingly at random. At the moment it seems to reboot maybe 5 or 6 times in a row before it settles. I sometimes have to pull the power too.
Certainly seems more prevalent if it is under heavier load.
I’ve just factory reset it and installed hymans current build (it was originally only one behind) but now seeing the same thing.
Very minimal changes but I have disabled dydns and
I did have logs exporting to my pihole and saw a couple of error messages that didn’t really help (I have a different thread on this).
I think it only started doing this in the last month or so, maybe 2 months.
Not sure if any of this rings true for you?

Have you tried using the current stable release per the OpenWRT page? If you have, it might be a power supply issue.

Mine didn't come with the original but since replacing it I have not had any reboots. Currently at 20 hours, but I also found a 20 watt adapter I had lying around and used that while I waited for the 42 watt to arrive. On the 20 watt it was up 25 hours without issues before I replaced it with the correct one (42). So combined they were up 45 hours without reboot on vanilla stable 19.07.3.

If you have not tried stable 19.07.3 I would suggest starting with that. Did you check the logs to see if you have a crash log created? It would be found in /sys/kernel/debug/crashlog, but if you look at the kernel log right now, does it say No memory allocated for crashlog or does it say something like Crashlog located at 'memory address'? If the former, then it is probably power issue since its rebooting not due to a system failure (potentially), but if the latter and there is a log, you should start there.

Hi,
No crashlog, just checked.
My PSU is 12/3.5 but will see if I can find a new one.
The router has been running for a long time (had DD-WRT originally then the standard OpenWRT before switching to hnyman's build. It has only been recently I've had problems. These things can fail though and I'd certainly not considered the PSU as a possibility.
No memory allocation errors, just a kernel panic which I will post separately.
Thank you for the reply though. I hope your uptime stays!

cheers

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.