R7800 performance

Agreed. I’m running it on three r7800’s and performance is better. :sunglasses:

Hi,
I've flashed https://github.com/ACwifidude/openwrt/tree/kernel5.4-nss-qsdk10.0/bin/targets/ipq806x/generic on my new R7800 (previously only tested the stock firmware for a day) and I am experiencing abysmal wifi performance.

My wan is ~120/12 mbit (pppoe), I am getting full speeds over ethernet, but only 10/12 on wifi (both 2.4/5ghz, different devices - win10 laptops). I was getting full speeds also on wifi on the stock firmware before.

Things I did after I flashed openwrt (factory with tftp, so no old settings carried over):

  1. added some static dhcp leases + forwarded 5 ports,
  2. set wan pppoe login/pwd and dns to 1.1.1.1 i 1.0.0.1 (only on wan interface, not sure if that's the proper place if I want all the clients to use these dns)
  3. then I set identical ssid for 2.4 i 5ghz, with the same password, security "WPA2-PSK/WPA3 SAE Mixed Mode", channel "auto", ("40 mhz" width on 2.4ghz) and checked the "802.11r Fast Transition" checkbox (I've read somewhere it might help with automatic switching between 2.4 & 5 depending on the signal strength)
  4. added additional "guest" ssid on 2.4 ghz with different name and security set to "WPA2-PSK" and checked "Advanced Settings -> Isolate Clients"
    ...and that's it, I didn't touch other settings (e.g. firewall or qos)

I thought, maybe WPA3 is slowing things down? So then I set the security to "WPA2-PSK" for all ssids, then I turned off "802.11r", then I turned off all ssids except the main 2.4ghz (5ghz also turned off), manually set channel 6 on 2.4ghz, 20mhz width... but none of these steps helped anything.

Download speed is still ~10mbps :frowning:
Also: wifi<->lan transfers are just as slow (wifi to a NAS on ethernet) - so WAN connection is out of the equation. Measured 10mbps download / 25mbps upload.

What could be wrong? :thinking: Should I try flashing the latest stable release instead?

The NSS build has similar wifi performance to master.

I’d have a separate SSID for 2.4ghz and 5ghz. 2.4 ghz has tons of interference problems, a narrow bandwidth, and is less than desirable for anything beyond simple IoT connections. If you are looking for optimal performance- I’d eliminate the guest virtual wifi interface.

Virtual wifi interfaces have been causing big performance issues.

Connect to the 5ghz SSID and post a speedtest.net test.

@ACwifidude it indeed goes full speed when only 5ghz is enabled.

Something in my case is force limiting the speed of 2.4ghz, even if it's the only ssid enabled (guest ssid removed, 5ghz disabled) and capping the speed down to ~10 mbps. Very weird.

Like I said it was going full speed on 2.4 on the stock r7800 firmware and also on my previous tp-wr1043nd v2 router on old openwrt/gargoyle v1.10... so the environmental interference could not go that bad all of sudden :thinking: I hope it's "only" a matter of some (unknown to me) config toggle.

Well, I still can try flashing another build (e.g. kong, release) and I will report back.

OEM wifi is NSS accelerated so it’ll get a little more performance. I’d make your ondemand settings more aggressive or run the performance governor to have your main CPU at max performance for testing.

Ex:


echo performance > /sys/devices/system/cpu/cpufreq/policy0/scaling_governor; echo performance > /sys/devices/system/cpu/cpufreq/policy1/scaling_governor

Below are my 2.4ghz settings. Performance Specifics- have it to 20mhz channel (few devices support 40mhz in the 2.4ghz spectrum), have it set to the channel with the least interference (pick - 1,6,11), turned legacy rates off, and running psk2+Forced AES.


root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
        option htmode 'HT20'
        option txpower '20'
        option country 'US'
        option legacy_rates '0'
        option beacon_int '191'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid ''
        option encryption 'psk2+ccmp'

heads up: I've just flashed http://www.desipro.de/openwrt/trunk/ipq806x-nss/kong-ipq806x-generic-netgear_r7800-squashfs-sysupgrade.bin (without preserve config option - clean flash), enabled just 2.4ghz (wpa2-psk, fixed channel 11, 20mhz), configured pppoe and... the connection is back to full speed :see_no_evil:

I'll try the same again with your build @ACwifidude

No sweat. Glad you found something that works. :sunglasses:

Has Kong made any of his NSS source code available? I didn't see it in his /openwrt path.

FWIW, I clean flashed https://github.com/ACwifidude/openwrt/blob/kernel5.4-nss-qsdk10.0/bin/targets/ipq806x/generic/R7800-masterNSS-r14443-sysupgrade.bin, and configured it the same way (2.4 only, wpa2-psk, channel 11, 20 mhz, pppoe) and... the connection is also full speed :see_no_evil:
I am sorry for the confusion. I don't know what was going on back then. I have a number of old devices incl. old logitech squeezebox radios, maybe they were spamming the 2.4g range, trying to connect all at once again? Maybe the router didn't like something back then and locked the bandwidth down to a fail-safe lowest possible speed, trying to resolve issues it noticed? :thinking: (still weird the low-speed "lock" survived multiple router & PCs reboots...)

Good to hear. :sunglasses:

1 Like

hello, have you managed to get the nss sqm script in the luci app?
thanks :slight_smile:

it would be interesting :slight_smile:

Just got the R7800. Read a bit in different threads. Got confused, flashed hnyman build from tftp. Read some more, got little bit less confused. Will flash ACwifidude build later. Hope to help some with testing in a bit. Keep up the excelent work! :smile:

1 Like

I have some issues with the b/g/n network radio crawling speeds at 2-10mbps sometimes at random. A simple toggle radio (enable/disable) fixes it. I remember having changed out the -ct firmware to regular with same results. Does anyone know a fix?

Your 2.4ghz is probably suffering from interference. With interference your device will wait for air time and speed will suffer. Here a good write up on the limitations of 2.4ghz suffering from its own success:

Best practice if performance is your priority is to use a separate SSID for each frequency, minimize interference from 2.4ghz devices, minimize the number of SSIDs you have (if you have multiple virtual interfaces) and keep your quicker devices on 5ghz only.

I can't deny it has somewhat interference. But what is weird is that its always full speed and working rest of the day if I toggle the radio on/off.

I thought same SSID was totally fine nowadays, why is it beneficial to have it separate?

I like them separate so I can force clients to use 2.4 or 5GHz. E.g. I want crappy IoT devices to stay on 2.4 even if they could use or prefer 5. Better range and they don't need all that bandwidth.

1 Like

Agree with @wired - I have a 5ghz SSID and a 2.4ghz SSID.

I have only IoT on the 2.4ghz SSID. Between... Microwaves, baby monitors, 5-6 neighbor 2.4ghz networks(where I live), Bluetooth, etc - 2.4ghz is a mess. 2.4ghz performance greatly varies throughout the day depending on what the constellation of devices are doing.

Here are my settings if you want to tweak and compare:


root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'VHT80'
        option txpower '20'
        option country 'US'
        option legacy_rates '0'
        option beacon_int '101'
        option channel '161'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid ''
        option encryption 'psk2+ccmp'
        option key ''
        option ieee80211r '1'
        option ft_over_ds '1'
        option ft_psk_generate_local '1'
        option wpa_disable_eapol_key_retries '1'
        option ieee80211v '1'
        option ieee80211k '1'
        option bss_transition '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
        option htmode 'HT20'
        option txpower '20'
        option country 'US'
        option legacy_rates '0'
        option beacon_int '191'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid ''
        option encryption 'psk2+ccmp'
        option key ''

Has anyone experienced asymmetric wifi performance on 5GHz? I'm running hnyman's latest build, performance governor. I have a 250/250 connection and in wired speed tests I can reach 260/260, but on wifi I get max downloads at 260 but upload only 160-170. Distance to the router is not an issue, testing next to it. Client is a Mac that connects at 1300Mbps line speed.

Not noticing any change in performance. When you revert to an older version does it change things (which dates did a change occur that is causing the issue, “when did things change”)?