R7800 performance

Hi ACwifidude, if I undestand well reading your suggested links, you build already has everything ready for >500mbps (my need)?

Yep. Feel free to load my build and see what you think. You should just have to put the performance governor in the startup script and have good performance.

The NAT performance is impressive with the hardware offloading. I’m hooked. :sunglasses:

Now ... how do we get max performance and stability out of wifi in AP mode? :slight_smile:

I have tried the latest NSS build from ACWifidude and I cannot get more then 550 wired connection on speedtest on my Centurylink 1GB symmetrical connection.

All setting is default, added the performance governor on start up, added my vlan201 and my Centurylink PPPoE connection.

Any help will be appreciated?

Turn software offloading off in the firewall section (if it isn’t already). Use speedtest.net or similar bandwidth specific test to get a representation of max speed.

Made a new community build with that exact goal. I run two r7800s as APs (I like fast roaming and max performance). If you got tips and tricks to make it better I’m all ears:


Software offloading is off. Speedtest is still coming back the same on wired. Hmm...

I don’t have PPPoE or additional vlans in my setup. Post your config for what changes you’ve added and we could probably troubleshoot to see what the deal is.

Yeah, right now it is pretty simple. Trying not to bork it while working from home. Looks like I can't embed multiple screenshots since I am new.


echo performance > /sys/devices/system/cpu/cpufreq/policy0/scaling_governor
echo performance > /sys/devices/system/cpu/cpufreq/policy1/scaling_governor

Is set up via PPPOE

Most likely it is because I don’t have the NSS PPPoE driver in my build. I’ll rebuild tomorrow with it and it should solve your issue. :sunglasses:

1 Like

ACwifidude, do you have instructions on how to get your build that has NSS support? I’m using latest vanilla build right now, and with fq codel it can’t use the full speed my ISP provides (400mbps). I assume with NSS this speed is obtainable with fq codel?


NSS PPPoE driver is in - give it a whirl and see what you think.

1 Like

Thank you! I got my 1GB speed back now on wired. :slight_smile:

I even did a factory reset to make sure. I tested default ondemand govenor and got line speed as well.

1 Like

Just tested ACwifidude out-of-the-box last release build.
Speed, tested via cli-speedtest, reachs 950 Mbps on a gigabit line... great!
New Wireguard tests: packages and configs work easily. It seems to be a little slower - around 10% - than hnyman build, but it may depend on too many factors (I'm doing tests with a cheap vps in the other part of the world). In both cases, i5 5200u with aes-ni almost doubled the speed (70% more).

1 Like

Anyone else seeing wifi upload throughput being about 100Mbps lower than download (from the perspective of a wifi client connected to the R7800)?
I run my R7800 in AP mode, there's another wired router and e.g. on a 250/250Mbps fiber I get 260/260 wired but on wifi I get about 260/160 down/up. Same if I run an iperf3 test between a wifi client and a wired Linux server, depending on the distance to the AP, I get about 500/400 down/up.
The 100Mbps asymmetry is curious and it seems to be about consistent at various throughput rates. Does it have anything to do with WMM or similar that favors downloads maybe? Though the tests are not doing download/upload at the same time.

Anyone else able to replicate the above?

I ran a new UDP test using iperf3 (wired Linux server, 2018 MacBook Pro wifi client), I can get about 530Mbps down and 800Mbps up, close enough to the router so the link speed is 1300Mbps. Not sure why one direction is that much slower than the other and when using iperf3, and it is download that is slower than upload (from the wifi client perspective).

Might be because usually encrypting takes more CPU cycles than decrypting, and the router's CPU / NSS chip is more resource-constrained when the routers encrypts and uploads data for you (to be downloaded by your wifi client) ???

That could be the case, the explanation does make sense. Didn't realize the device was not capable of full line speed encryption. I suppose I could turn WPA2 off and try it.

It's strange though that when doing an Internet speed test, I see the opposite 260/160 down/up, the upload is slower than the download. Max internet speed is 260/260 (based on wired tests) and that's well below the 500Mbps that I can see the router can handle from the iperf3 tests.

Nope, it's not encryption. I turned off WPA2, just using an unencrypted wifi connection, the results are slightly higher (perhaps within measurement error), but still a 270Mbps difference between up and down in iperf3 UDP tests.

1 Like