R7800 - OpenWrt 22.03.3 - Stream problems over lan

Hi, I have been having difficulty lately in streaming via LAN large files.
Both the TV with the Plex client and the Nas with the Plex server are connected to the router via cable.

With version 18 I don't remember ever having particular problems (I never tested very large files) but since I upgraded I started having problems.
Now the performance via Wi-Fi seems even more stable than via cable.
With cable in fact it seems to run jerky, some going some not.

I haven't done any tests with iperf3 but searching a bit I seem to understand that I am not the only one, so I applied the various suggestions found around the forum, something improved but still not there, I can't stream a file with a bitrate of about 85Mbps

Here is what I applied following the instructions found in the forum:
Enabled irqbalance
Set the startup like this:

echo 1 > /proc/irq/37/smp_affinity
echo 2 > /proc/irq/38/smp_affinity

echo 35 > /sys/devices/system/cpu/cpufreq/ondemand/up_threshold
echo 10 > /sys/devices/system/cpu/cpufreq/ondemand/sampling_down_factor

echo 800000 > /sys/devices/system/cpu/cpufreq/policy0/scaling_min_freq
echo 800000 > /sys/devices/system/cpu/cpufreq/policy1/scaling_min_freq

echo performance > /sys/devices/system/cpu/cpufreq/policy0/scaling_governor
echo performance > /sys/devices/system/cpu/cpufreq/policy1/scaling_governor

echo 1 > /sys/devices/system/cpu/cpufreq/policy0/stats/reset
echo 1 > /sys/devices/system/cpu/cpufreq/policy1/stats/reset

echo 0 > /sys/kernel/debug/ieee80211/phy0/airtime_flags
echo 0 > /sys/kernel/debug/ieee80211/phy1/airtime_flags

Am I doing something wrong and therefore my router has no problem with files of this size, or is this a real problem and not easily solved?
Should I start looking for another router?

Thank you for your attention


The issue might just as well be with the hw used for sending/transcoding and/or receiving/playing back the video.

Then you should probably check the cables, and system log.

Hi Frollic,

I tried copying the file to an hd and connecting it directly to the tv, no problem whatsoever when running.
The file is on a nas and the processor is a Intel(R) Celeron(R) CPU J3355 @ 2.00GHz.
Do you have any idea how I can test to see where the problem is?
The cables are fairly new and undamaged, and in the system logs there do not seem to be any particular errors.
I can do a test with iperf3 if you think it would help.


That's not necessarily the same thing though ...
Try installing Kodi or VLC on the TV, and have it play back the video directly from the file share.

Now, I'm no Plex user, but what it does, is transcoding, that's (AFAIK) the major (only?) selling point.
If your J3355 is trying to transcode the file, instead of just sending it to the Plex app, I could imagine the CPU becoming a bottle neck.

See if there's any way of monitoring the CPU load on your NAS, during play back.

Ok, I got your point.
Kodi is not available for my tv, I had to check for VLC.
Anyway, there's no transcoding, Plex is not always transcoding, depending on settings and subs! I can always check the status of the stream and this file is direct play this means no transcoding.
I'll make a play test, so I can see the cpu usage from nas and R7800
Any suggestion to make any other check in meanwhile?

the R7800 should be idling, if it's plain wifi <> wired, or wired <> wired LAN traffic.

is your TV wired, or using wireless ?

All is via cable, so both TV and NAS with cables.

Idling? The file have to pass from the NAS through the R7800 and then from R7800 to TV, so maybe a little bit of cpu usage will be used, I think.

That's the thing, it's not going through it, but via it, unless the TV and the NAS are on separate subnets, VLANs, etc...

Righ, yes is all under the same lan.
I made three test:

  1. Stream a small file from Plex server via Plex app on TV
  2. Stream the big file from Plex server via Plex app on TV
  3. Stream the same big file from DLNA server (always Plex) via the default app on TV

So the NAS cpu load is:

  1. Plex server -> 3% to 6%
  2. Plex server -> 30% to 45%
  3. Plex server -> 3% to 6% and Plex DLNA about 30%

The problems are only on the bigger file, and with DLNA the playback is even worse

On the R7800 side, no significant CPU increase

Then the TV might be the bottle neck, not the NAS, and the transcoding might actually help here,
instead of doing "direct play".

Still not seeing this as a network/openwrt issue :wink:

Just to be sure, I stream the same big file to a Plex client to my laptop, same conditions as before, so direct play. It goes like a charm, without any interruption and without buffering and I'm no under wire but wi-fi.
So yes, at first look seems to be a Tv "problem" the app or the tv itself

But is strange, because via wireless the stream seems to have more data range, I'll export you two screen from plex side where you can see the bandwith from lan and wifi of the same file.
Like I said when I use the R7800 wired seems to be less reactive