R7800 Low Upload Performance on some devices

I bought an r7800 because i wanted to test openwrt, take advantage of having a powerfull wifi router, with tons of possibilities from a linux device but...

I installed latest openwrt 18.06.1, leaving it almost default and enabling WIFI 5ghz+2.4 and with some devices like smartphone i get very low performance, respect to stock firmware.
I guess i'm doing something wrong.

My ISP speed is 100/50 Mbps which performs usually at 90/45.
(4g lte connection)

on stock: full speed
on openwrt full speed

Oneplus 5t:
on stock: full speed
on openwrt: upload speed is only 20mbps (which is half)

I saw that on macbook connection is set to 1300mbps, on oneplus 5t it is 866mbps.

Now, it's not a real problem to have 20mbps on upload on a smartphone, but i don't understand why...

Another stange fact, but common to both firmwares is that by wire i have to set macbook interface manually to 100mbit/s otherwise i get lower upload speed. (around 20mbsp).
Cable from mac to router is short.. but not a certified cat6 cable.. Could it be this the reason?

How are you measuring the speed? At speedtest.net or something like that?
Is there some QoS or some other bandwidth throttling enabled?

Regarding the cable, if it is not certified there is the possibility that one of the 8 smaller cables inside is damaged, rendering it unable to operate at 1Gbps and has errors. By forcing 100Mbps you only use half of the smaller cables.

1 Like

yes.. just a speedtest.
I know it's not a great bandwidth checker, but switching from ethernet to wifi can be made quickly and i achieve always the same results. Slow upload speeds.
( i think i wasted GB yesterday making lots of tests)

I checked also with a Samsung Tab S3 .... same thing. 866mbps connection , 20,mbps bandwidth..

there's no QOS or any bandwidth throttling..

ok, i'll try different cables.Maybe you're right and there's one of that 8 cables not ok..
Thank you

I did this test

Oneplus 5t with iperf , connected to 5ghz
Macbook pro with cable

On stock i get 470mbs rate
On openwrt i get 350 mbps

So.. it is still faster than my 20mbps, but something is screwing my upload tests via OWRT 5ghz and also gigabit connection to speedtest.com.

Some MTU problem? i don't undestand..

Try to monitor the system resources while you are running the iperf, top or even better htop.

Regarding the speedtest, if it is not some limitation of the 4G network, I'd look if there is something stressing the cpu during the test, since NAT demands some extra cpu cycles and you have not implemented any QoS.

1 Like

i tried with htop and cpu stays low.. so it's not a resource problem.

If it were a 4g problem it would affect also stock firmware, i guess...

I have old (sh**ty) 54g router that get better performance on upload :confounded:


Thank you for your suggestions

You need to look at %idle, if that stays too low (say dipping to <= 5% noticeably often) you are running out of cpu cycles. The way top/htop and friends report CPU usage is not standardized and often the "busy" numbers do not include soft interrupt processing (reported by bog-standards top as sirq), idle however always seems to be the number of cycles still left to do something. Also note that on fancier routers with frequency scaling often it helps as a first measure to set the router to a fixed high frequency to first debug the easy case of a fixed-frequency CPU and only deal with power-saving features after the "easy" configuration works....


On an r7800 it shouldn't be running out of CPU at 20Mbps with no SQM.

I'd say make sure you use quality cat6 cables everywhere as a first step. Particularly due to that stuff about the macbook at 100Mbps being faster

1 Like

i tried running iperf on r7800 and i got:
892mbit/s for the mac gigabit wired
95mbit/s for the mac 100mbit wired
It seems ok!

With oneplus 5t i get 430mbit/s so i would say it is way over 20mbit.

All those test were made into the lan , so NAT was avoided.
I should now test with two devices , 1 on the LAN side and another 1 on the WAN side..

PS: the cpu was not idle.. it had some peaks, but not near 100%. ( maybe 40%-50%)

May I suggest the following setup for iperf testing?

MAC Eth <-> wan r7800 br-lan <-> Wifi Oneplus

Temporarily assign a subnet for the WAN different than the one in LAN. If LAN is then assign static for the r7800 and for the MAC.
Run the iperf server on Mac and connect from Oneplus on IP Let's see what will be the speed there.

1 Like

yes.. that's what i just did right now! :smiley:

i get around 400mbit/s ...


Ok, so can you describe in some detail the topology and test set-up you're using when you are unable to get more than about 20Mbps?

1 Like

Mikrotik 4g router from ISP <------> R7800 wan port
---> LAN macbook
---> WIFI 5ghz Oneplus 5t or Samsung Tab S3

.. and so many others devices , but this is the part relevant to us.

I cannot modify anything in ISP mikrotik router..

Test Using an outside box with iperf3
upload bandwidth is half.. around 20mbps or less.

I did the same test using an old crappy wifi router, and Oneplus 5t and i get 40mbps.
I quit.

It has no sense.. since placing my MAC in the WAN zone gets much higher bandwidth

(i cannot post anymore, so i add in this last post)

Last two test:

1 - Use my son pc with gigabit. (other cable). Same thing. 10mbit upload.

2 - I disabled dhcp server and then plugged the cable from IPS into a lan port ...
Doing in this way i use it like a switch... and guess what: Oneplus 5t at full speed 92/40 and PC at full speed 93/42.

So... it's not the cable, nor an ethernet port.
I can't figure out what's wrong but this is not acceptable.

If you have any suggestion..
Thank you :slight_smile:

Does your R7800 device do PPPoE? Does your ISP device do PPPoE? Do you have an MTU problem between the ISP device and the R7800? What MTU does the ISP device use?

if you do a tcpdump to a file while running a speed test, and listening on the WAN port of R7800 and then copy the file to your PC and open it in wireshark does it show anything interesting, such as tons of retransmits or whatever?

Does the ISP provide you with IPv6, IPv4, Dual Stack? DSLite? CGNat? what?

Can you put the R7800 device into the loop and run a dslreport speed test and post the link to the results page? Details there might be interesting.

1 Like

Ok, i just discovered that Amazon warehouse deals gave me a really old unit and i think it has some problems.

Using iperf3 on an outside box (on digital ocean) i get constant, repeatable better results with an old dlink dir-615! (r7800 on stock/owrt)

Thanks to anyone who helped me.
I appreciate..

So your plan is to return it and get a new unit?

1 Like

For sure i will return this unit.I payed just 50 euros less than stock new, and i got a really old device.
(1,5 years) and i really think it has some issues..

I still don't know if i will pick a new one, or take maybe a linksys acm3200.