R7800 Ethernet Dies After A Few Days

Ethernet just dies after a few days
WiFi and WAN still works though
Where should I start?

Edit: Simply rebooting the router didn't solve the problem

By telling us some details...

What does kernel log say when LAN has died?
Can devices on LAN still ping each other?

You LAN config? Anything special?

Default programs in use? Or tweaked DNS, DHCP etc.?

1 Like

Thanks for the prompt reply, let me take a look tomorrow and get back.

One important thing I forgot to mention is that rebooting the router didn't work. Last time I did a bunch of stuffs which eventually worked out but actually wasn't sure what was it.

AFAIK there isn't anything funky about the LAN config. It does have a guest network but strictly WiFi only. SQM is in use but also for guest network only.

DNS and DHCP are standard stuffs.


Checked today the logs, unfortunately I asked the premise operator to rebooted the router so the logs are after reboot, and apparently there is nothing of concern AFAICT.

Meanwhile, I googled a bit and found the below post saying a downstream switch could cause such a problem... It seems to align somewhat with the timeframe which the setup began to exhibit this "ethernet lost" problem as I replaced an 100baseT router/switch with a gigabit one.

Solved: Re: R7800 wifi is working but not wired connection... - NETGEAR Communities

FWIW, the switch in question is a TP-Link TL-SG1005D, I've replaced it with the old one for time being.

The other possibility I can think of is that I forgot to install SQM after upgrading from rc2 to rc3 at one of the downstream routers.


To follow-up, it seems "downgrading" the switch (a cascaded one, BTW) seems to have solved the problem.

If I'm entrepreneur enough I may try switching the 2 cascaded switches and see how it goes.

But more likely I'm going to leave it as-is or find another switch instead... googling "TL-SG1005D" turns up quite a few results of people complaining about it.


The sg108e is pretty inexpensive and functional for a LAN setup with VLANs.