R7800 crash with L2TP and static IP over WAN

I have built an OpenWrt firmware for R7800, the source code is new from the github repo here:
https://github.com/coolsnowwolf/lede
The kernel version is 4.14.120.
I configure the WAN static IP, and configure a L2TP dialing through WAN(Campus network dialing needed). At first everything went OK, but Every time I turn it on for about four hours, it will crash itself.
Specifically, the first thing is that I can't connect to the Internet. At this time, I can still access other devices in the LAN, such as the remote desktop of my desktop PC. After a while, the LAN devices are also can't be accessed, including Luci's management interface 192.168.1.1. By saving the system's log file, I found that it seems that xl2tp crashes. The specific error location is as follows:

Thu May 30 21:35:00 2019 kern.warn kernel: [13463.879803] Exception stack(0xdd4619d8 to 0xdd461a20)
Thu May 30 21:35:00 2019 kern.warn kernel: [13463.887446] 19c0:                                                       00000000 00000b01
Thu May 30 21:35:00 2019 kern.warn kernel: [13463.892506] 19e0: 00000b00 dd460000 d8798240 da8b5120 d94aa9c0 00000000 00001400 000005ee
Thu May 30 21:35:00 2019 kern.warn kernel: [13463.900669] 1a00: 00000000 00000014 dd76a380 dd461a28 c06d4ea8 c06d567c 00000113 ffffffff
Thu May 30 21:35:00 2019 kern.warn kernel: [13463.908814] [<c030c08c>] (__irq_svc) from [<c06d567c>] (ip_do_fragment+0x5e4/0x66c)
Thu May 30 21:35:00 2019 kern.warn kernel: [13463.916970] [<c06d567c>] (ip_do_fragment) from [<c06d6e7c>] (ip_output+0x50/0xb4)
Thu May 30 21:35:00 2019 kern.warn kernel: [13463.924514] [<c06d6e7c>] (ip_output) from [<bf301a08>] (l2tp_xmit_skb+0x424/0x448 [l2tp_core])
Thu May 30 21:35:00 2019 kern.warn kernel: [13463.932149] [<bf301a08>] (l2tp_xmit_skb [l2tp_core]) from [<bf93c750>] (pppol2tp_xmit+0x168/0x2b4 [l2tp_ppp])
Thu May 30 21:35:00 2019 kern.warn kernel: [13463.940599] [<bf93c750>] (pppol2tp_xmit [l2tp_ppp]) from [<bf8a21f4>] (ppp_unregister_compressor+0x11c/0xd60 [ppp_generic])
Thu May 30 21:35:00 2019 kern.warn kernel: [13463.950583] [<bf8a21f4>] (ppp_unregister_compressor [ppp_generic]) from [<bf8a2c44>] (ppp_unregister_compressor+0xb6c/0xd60 [ppp_generic])
Thu May 30 21:35:00 2019 kern.warn kernel: [13463.961519] [<bf8a2c44>] (ppp_unregister_compressor [ppp_generic]) from [<bf8a468c>] (ppp_release+0x104/0x190 [ppp_generic])
Thu May 30 21:35:00 2019 kern.warn kernel: [13463.974017] [<bf8a468c>] (ppp_release [ppp_generic]) from [<bf8a4860>] (ppp_start_xmit+0x148/0x1a8 [ppp_generic])
Thu May 30 21:35:00 2019 kern.warn kernel: [13463.985395] [<bf8a4860>] (ppp_start_xmit [ppp_generic]) from [<c0690914>] (dev_hard_start_xmit+0xc8/0x154)
Thu May 30 21:35:00 2019 kern.warn kernel: [13463.995543] [<c0690914>] (dev_hard_start_xmit) from [<c06b901c>] (sch_direct_xmit+0xbc/0x1cc)
Thu May 30 21:35:00 2019 kern.warn kernel: [13464.005087] [<c06b901c>] (sch_direct_xmit) from [<c0690f38>] (__dev_queue_xmit+0x488/0x7b0)
Thu May 30 21:35:00 2019 kern.warn kernel: [13464.013685] [<c0690f38>] (__dev_queue_xmit) from [<c06a1830>] (neigh_xmit+0xe4/0x1bc)
Thu May 30 21:35:00 2019 kern.warn kernel: [13464.021857] [<c06a1830>] (neigh_xmit) from [<bf59a414>] (nf_flow_offload_ip_hook+0x4f0/0x524 [nf_flow_table])
Thu May 30 21:35:00 2019 kern.warn kernel: [13464.029857] [<bf59a414>] (nf_flow_offload_ip_hook [nf_flow_table]) from [<c06cabdc>] (nf_hook_slow+0x38/0xd4)
Thu May 30 21:35:00 2019 kern.warn kernel: [13464.039724] [<c06cabdc>] (nf_hook_slow) from [<c068be64>] (__netif_receive_skb_core+0x570/0xbdc)
Thu May 30 21:35:00 2019 kern.warn kernel: [13464.049611] [<c068be64>] (__netif_receive_skb_core) from [<c0691aa4>] (netif_receive_skb_internal+0xc0/0xd4)
Thu May 30 21:35:00 2019 kern.warn kernel: [13464.058466] [<c0691aa4>] (netif_receive_skb_internal) from [<c0785d3c>] (br_handle_frame_finish+0x530/0x55c)
Thu May 30 21:35:00 2019 kern.warn kernel: [13464.068275] [<c0785d3c>] (br_handle_frame_finish) from [<c0785fe4>] (br_handle_frame+0x27c/0x2bc)
Thu May 30 21:35:00 2019 kern.warn kernel: [13464.078084] [<c0785fe4>] (br_handle_frame) from [<c068c010>] (__netif_receive_skb_core+0x71c/0xbdc)
Thu May 30 21:35:00 2019 kern.warn kernel: [13464.086853] [<c068c010>] (__netif_receive_skb_core) from [<c068e2cc>] (process_backlog+0xb0/0x164)
Thu May 30 21:35:00 2019 kern.warn kernel: [13464.095707] [<c068e2cc>] (process_backlog) from [<c0691ed4>] (net_rx_action+0x144/0x31c)
Thu May 30 21:35:00 2019 kern.warn kernel: [13464.104729] [<c0691ed4>] (net_rx_action) from [<c03015c8>] (__do_softirq+0xf0/0x264)
Thu May 30 21:35:00 2019 kern.warn kernel: [13464.112988] [<c03015c8>] (__do_softirq) from [<c031d008>] (irq_exit+0xdc/0x148)
Thu May 30 21:35:00 2019 kern.warn kernel: [13464.120706] [<c031d008>] (irq_exit) from [<c030e4c0>] (handle_IPI+0xb4/0x1ac)
Thu May 30 21:35:00 2019 kern.warn kernel: [13464.127730] [<c030e4c0>] (handle_IPI) from [<c03014b8>] (gic_handle_irq+0x9c/0xb8)
Thu May 30 21:35:00 2019 kern.warn kernel: [13464.135020] [<c03014b8>] (gic_handle_irq) from [<c030c08c>] (__irq_svc+0x6c/0x90)
Thu May 30 21:35:00 2019 kern.warn kernel: [13464.142477] Exception stack(0xdd461f80 to 0xdd461fc8)
Thu May 30 21:35:00 2019 kern.warn kernel: [13464.150056] 1f80: 00000001 00000000 00000000 c0315040 ffffe000 c0b03c74 c0b03c28 00000000
Thu May 30 21:35:00 2019 kern.warn kernel: [13464.155094] 1fa0: 00000000 512f04d0 00000000 00000000 dd461fc8 dd461fd0 c030878c c0308790
Thu May 30 21:35:00 2019 kern.warn kernel: [13464.163231] 1fc0: 60000013 ffffffff
Thu May 30 21:35:00 2019 kern.warn kernel: [13464.171393] [<c030c08c>] (__irq_svc) from [<c0308790>] (arch_cpu_idle+0x38/0x44)
Thu May 30 21:35:00 2019 kern.warn kernel: [13464.174699] [<c0308790>] (arch_cpu_idle) from [<c034fc6c>] (do_idle+0xe8/0x1bc)
Thu May 30 21:35:00 2019 kern.warn kernel: [13464.182336] [<c034fc6c>] (do_idle) from [<c034ffb4>] (cpu_startup_entry+0x1c/0x20)
Thu May 30 21:35:00 2019 kern.warn kernel: [13464.189363] [<c034ffb4>] (cpu_startup_entry) from [<423017cc>] (0x423017cc)
Thu May 30 21:35:00 2019 kern.warn kernel: [13464.197172] ath10k_pci 0000:01:00.0: SWBA overrun on vdev 0, skipped old beacon
Thu May 30 21:35:00 2019 kern.warn kernel: [13464.204042] ath10k_pci 0001:01:00.0: SWBA overrun on vdev 0, skipped old beacon
Thu May 30 21:35:12 2019 daemon.notice xl2tpd[3002]: Maximum retries exceeded for tunnel 58306.  Closing.
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: Terminating pppd: sending TERM signal to pid 3381
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Connection 25488 closed to 10.0.2.3, port 1701 (Timeout)
Thu May 30 21:35:12 2019 daemon.info pppd[3381]: Terminating on signal 15
Thu May 30 21:35:12 2019 daemon.info pppd[3381]: Connect time 223.7 minutes.
Thu May 30 21:35:12 2019 daemon.info pppd[3381]: Sent 952993484 bytes, received 1684379488 bytes.
Thu May 30 21:35:12 2019 daemon.notice netifd: Network device 'l2tp-VPN' link is down
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 0, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 0, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.warn pppd[3381]: Overriding mtu 1500 to 1428
Thu May 30 21:35:12 2019 daemon.warn pppd[3381]: Overriding mru 1500 to mtu value 1428
Thu May 30 21:35:12 2019 daemon.notice pppd[3381]: Connection terminated.
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 0, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info xl2tpd[3002]: Can not find tunnel 58306 (refhim=0)
Thu May 30 21:35:12 2019 daemon.debug xl2tpd[3002]: network_thread: unable to find call or tunnel to handle packet.  call = 55818, tunnel = 58306 Dumping.
Thu May 30 21:35:12 2019 daemon.info pppd[3381]: Exit.
Thu May 30 21:35:13 2019 daemon.notice netifd: Interface 'VPN' is now down
Thu May 30 21:35:13 2019 daemon.notice netifd: Interface 'VPN' is setting up now
Thu May 30 21:35:18 2019 daemon.notice netifd: VPN (7553): Could not resolve server address
Thu May 30 21:35:23 2019 daemon.notice netifd: Interface 'VPN' is now down
Thu May 30 21:35:23 2019 daemon.notice netifd: Interface 'VPN' is setting up now
Thu May 30 21:35:28 2019 daemon.notice netifd: VPN (7645): Could not resolve server address
Thu May 30 21:35:33 2019 daemon.notice netifd: Interface 'VPN' is now down
Thu May 30 21:35:33 2019 daemon.notice netifd: Interface 'VPN' is setting up now

We can see the stack error was thrown from kernel, then xl2tp start to do strange things. Finally the system daemon start to up VPN link again and again, which causes the hole crash directly. I am nearly crazy for it.....:upside_down_face:
So to this problem, is there any solution?

And I also have a second problem. The device I tag to the LAN port often does not appear in the DHCP device overview. Why?

Here is my config in /etc/config/network


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd29:f481:c825::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth1.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option dns '10.0.0.21'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'static'
	option ipaddr '10.110.18.134'
	option netmask '255.255.255.0'
	option gateway '10.110.18.1'
	option dns '10.10.0.21'
	option macaddr 'B0:39:56:66:C4:13'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '5 0t'

config interface 'VPN'
	option proto 'l2tp'
	option server 'lns.zju.edu.cn'
	option username 'myusername'
	option password 'mypassword'
	option ipv6 'auto'
	option mtu '1428'

The second log posted here is troublesome ( dhcp leasefile permission error ) maybe you'll get some support there if your patient...

Otherwise best to switch to official sources.

emmm....You mean that the source code from the repo I used has trouble? I will try the official repo tomorrow, maybe need some time. If this problem still occur, I will inform you.

2 Likes

anyone has advice?

  • You stated that you would try the official repo, have you done so?

I advise you use the official repo; or seek support directly from coolsnowwolf: https://github.com/coolsnowwolf/lede/issues/new

Bad news, I use the official repo, but the problem is the same. Tonight just right now it crash again, the log is here:

Fri May 31 21:11:41 2019 kern.warn kernel: [14352.434931] Exception stack(0xdd461f80 to 0xdd461fc8)
Fri May 31 21:11:41 2019 kern.warn kernel: [14352.440785] 1f80: 00000001 00000000 00000000 c0315200 ffffe000 c0a03c74 c0a03c28 00000000
Fri May 31 21:11:41 2019 kern.warn kernel: [14352.445911] 1fa0: 00000000 512f04d0 00000000 00000000 dd461fc8 dd461fd0 c030876c c0308770
Fri May 31 21:11:41 2019 kern.warn kernel: [14352.454042] 1fc0: 60000013 ffffffff
Fri May 31 21:11:41 2019 kern.warn kernel: [14352.462188] Function entered at [<c030c28c>] from [<c0308770>]
Fri May 31 21:11:41 2019 kern.warn kernel: [14352.465489] Function entered at [<c0308770>] from [<c034fe20>]
Fri May 31 21:11:41 2019 kern.warn kernel: [14352.471392] Function entered at [<c034fe20>] from [<c0350168>]
Fri May 31 21:11:41 2019 kern.warn kernel: [14352.477205] Function entered at [<c0350168>] from [<423017cc>]
Fri May 31 21:11:41 2019 daemon.notice xl2tpd[770]: Maximum retries exceeded for tunnel 2122.  Closing.
Fri May 31 21:11:41 2019 daemon.debug xl2tpd[770]: Terminating pppd: sending TERM signal to pid 28833
Fri May 31 21:11:41 2019 daemon.info xl2tpd[770]: Connection 52978 closed to 10.5.1.9, port 1701 (Timeout)
Fri May 31 21:11:41 2019 daemon.info pppd[28833]: Terminating on signal 15
Fri May 31 21:12:08 2019 kern.err kernel: [14379.936186] INFO: rcu_sched detected expedited stalls on CPUs/tasks: { 1-... } 8743 jiffies s: 457 root: 0x2/.
Fri May 31 21:12:08 2019 kern.err kernel: [14379.936245] blocking rcu_node structures:
Fri May 31 21:12:08 2019 kern.info kernel: [14379.947290] Task dump for CPU 1:
Fri May 31 21:12:08 2019 kern.info kernel: [14379.949193] swapper/1       R  running task        0     0      1 0x00000002
Fri May 31 21:12:08 2019 kern.warn kernel: [14379.952490] Function entered at [<c07c49b4>] from [<00000051>]
Fri May 31 21:12:12 2019 daemon.debug xl2tpd[770]: Unable to deliver closing message for tunnel 2122. Destroying anyway.
Fri May 31 21:12:12 2019 daemon.info xl2tpd[770]: Can not find tunnel 2122 (refhim=0)
Fri May 31 21:12:12 2019 daemon.debug xl2tpd[770]: network_thread: unable to find call or tunnel to handle packet.  call = 7300, tunnel = 2122 Dumping.
Fri May 31 21:12:12 2019 daemon.info xl2tpd[770]: Can not find tunnel 2122 (refhim=0)
Fri May 31 21:12:12 2019 daemon.debug xl2tpd[770]: network_thread: unable to find call or tunnel to handle packet.  call = 7300, tunnel = 2122 Dumping.
Fri May 31 21:12:12 2019 daemon.info xl2tpd[770]: Can not find tunnel 2122 (refhim=0)
Fri May 31 21:12:12 2019 daemon.debug xl2tpd[770]: network_thread: unable to find call or tunnel to handle packet.  call = 7300, tunnel = 2122 Dumping.
Fri May 31 21:12:12 2019 daemon.info xl2tpd[770]: Can not find tunnel 2122 (refhim=0)
Fri May 31 21:12:12 2019 daemon.debug xl2tpd[770]: network_thread: unable to find call or tunnel to handle packet.  call = 7300, tunnel = 2122 Dumping.
Fri May 31 21:12:12 2019 daemon.info xl2tpd[770]: Can not find tunnel 2122 (refhim=0)
Fri May 31 21:12:12 2019 daemon.debug xl2tpd[770]: network_thread: unable to find call or tunnel to handle packet.  call = 7300, tunnel = 2122 Dumping.
Fri May 31 21:12:12 2019 daemon.info hostapd: wlan0: STA ec:c4:0d:bc:a6:f1 IEEE 802.11: deauthenticated due to local deauth request
Fri May 31 21:12:12 2019 daemon.info pppd[28833]: Connect time 2.0 minutes.
Fri May 31 21:12:12 2019 daemon.info pppd[28833]: Sent 22406 bytes, received 110848 bytes.
Fri May 31 21:12:12 2019 daemon.info xl2tpd[770]: Can not find tunnel 2122 (refhim=0)
Fri May 31 21:12:12 2019 daemon.debug xl2tpd[770]: network_thread: unable to find call or tunnel to handle packet.  call = 7300, tunnel = 2122 Dumping.
Fri May 31 21:12:12 2019 daemon.info xl2tpd[770]: Can not find tunnel 2122 (refhim=0)
Fri May 31 21:12:12 2019 daemon.debug xl2tpd[770]: network_thread: unable to find call or tunnel to handle packet.  call = 7300, tunnel = 2122 Dumping.
Fri May 31 21:12:12 2019 daemon.notice netifd: Network device 'l2tp-VPN' link is down
Fri May 31 21:12:12 2019 daemon.info xl2tpd[770]: Can not find tunnel 2122 (refhim=0)
Fri May 31 21:12:12 2019 daemon.debug xl2tpd[770]: network_thread: unable to find call or tunnel to handle packet.  call = 7300, tunnel = 2122 Dumping.
Fri May 31 21:12:12 2019 daemon.info xl2tpd[770]: Can not find tunnel 2122 (refhim=0)
Fri May 31 21:12:12 2019 daemon.debug xl2tpd[770]: network_thread: unable to find call or tunnel to handle packet.  call = 7300, tunnel = 2122 Dumping.
Fri May 31 21:12:12 2019 daemon.info xl2tpd[770]: Can not find tunnel 2122 (refhim=0)
Fri May 31 21:12:12 2019 daemon.debug xl2tpd[770]: network_thread: unable to find call or tunnel to handle packet.  call = 7300, tunnel = 2122 Dumping.
Fri May 31 21:12:12 2019 daemon.info xl2tpd[770]: Can not find tunnel 2122 (refhim=0)
Fri May 31 21:12:12 2019 daemon.debug xl2tpd[770]: network_thread: unable to find call or tunnel to handle packet.  call = 7300, tunnel = 2122 Dumping.
Fri May 31 21:12:12 2019 daemon.info xl2tpd[770]: Can not find tunnel 2122 (refhim=0)
Fri May 31 21:12:12 2019 daemon.debug xl2tpd[770]: network_thread: unable to find call or tunnel to handle packet.  call = 7300, tunnel = 2122 Dumping.

Looks like the same problem, xl2tp kill a tunnel, then report this tunnel not found crazy....Then the hole router down. I think it may be a critical bug in xl2tp or in the kernel..Who can help me ?

I use the official repo and the problem is the same, the only different is that the watchdog of the firmware built from official repo works well, when it crash, the router will auto reboot.....But..it still is an annoying thing.