R7800 Cant go back to stock Firmware

Hello,

i recently updated to openWRT 19.07.2. Now i really would like to go back to the original Firmware of Netgear (v1.0.2.68).
My problem now is, i cant get the firmware installed. I tried via WebGUI and tftp2.
Here is what i tried:
To webGUI:
I go under System -> Backup/Flash Firmware -> Flash new firmware image. The router goes in a never ending circle of reboot
To tft2:
I set the router in to bootloader via pressing the reset button while powering on the router until the power LED tunrs white. In tftp2.exe i set ip, pw and path to original FW and try to upgrade. Unfortunately it failed at 3/4.
At that point, the only thing i can do is flashing back the openWRT 19.07.02 FW.

In some other threads i wrote about a "stripped" Firmware Version to get it done or to downgrade openWRT to version 17. I didnt find thoses FWs.

Please help me out. Cheers

You need to use the push-button tftp recovery method, this should work reliably on your device.

Use another tftp client.
Tftp2 started to fail for me in 2018, breaking the upload in middle.
So I switched to use tftpd64 from Jounin. That has worked with R7800.

2 Likes

Try nmrpflash

@hnyman Thx for your reply.
I already downloaded and installed it, but couldnt set it up properly.
Can you explain it to me ?

@slh that is what i did and discribe at Point 2

You need to just

  • go to the "Tftp Client" tab
  • enter router's IP address and firmware filename (OEM firmware or OpenWrt factory image)
  • push "Put" button to start uploading

1 Like

Just drop the factory Netgear firmware in the tftpd64 directory, start it up and choose your network card in the drop down menu. The router should pull the image over tftp without any other tftp64 configuration.

Have you tested that with R7800? (Or with some other similar Netgear Atheros based router?)
To my knowledge the Netgear router has the TFTP server on u-boot, so you need to have a TFTP client on the PC side.

Some manufacturers (like TP-link) provide the recovery routine otherwise, where you have the TFTP client in router's u-boot, and you need to have TFTP server on the PC side. Your advice sounds more like that. But I have never heard that it would work with R7800, or WNDR3700v1/v2/3800 or other similar Netgear's Atheros based routers.

Or is that some "default client functionality" in tpftd64???

1 Like

Not tested, sorry, I'm used to TP-Link's pulling the image over.

The difference is that he would need to setup the client tab in tftp64 and push the factory image?

@hnyman thx. I will try it later and give feedback

Yes, that is the method with the Netgear Atheros-based routers, like R7800.
The router acts as server, and the PC is client.

1 Like

Thank you very much guys. The way @hnyman has showed me, was the way to go.

So then...

Please see how to mark the topic as solved by hnyman

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.