R7800 build 18.06.4, upload speed cut by 60 mb/s

Good day,

Yesterday for the first time I installed openwrt build on my r7800 via tftpd64. Everything went smoothly, router restarts, I access luci, change wan to static ip, fill the info, enable two wifi radios, set name and password, download luci-app-sqm, but haven't set it up yet and that is about it. Done nothing more, the upload speed seems to take a hit compared to edgerouter that I have nearby, these are the test results.

R7800 - http://www.dslreports.com/speedtest/54028421
Edgerouter - http://www.dslreports.com/speedtest/54028470

What could be the reason behind it capping the upload speed to 1/4, the test is done via personal computer that is connected via cable

Have you tried switching CPU governor to performance?

Adjusting the cpu governor by ssh:
echo 35 > /sys/devices/system/cpu/cpufreq/ondemand/up_threshold
echo 10 > /sys/devices/system/cpu/cpufreq/ondemand/sampling_down_factor

Did not increase the upload speed

edit: If I were to revert these changes, would physical reset button do the trick?

Those are run-time parameters for kernel, not stored anywhere as separate settings.
Simple reboot is enough to clear them.

(note that you need to set them again after each reboot. Or you could compile an own image with kernel patched with those values)

Also check you SQM settings that it really is disabled. First test qithout any SQM QoS tools, then start experimenting. (85/21 sounds really strangely low)

I did reset the router with physical button and set up everything again, this time did not install luci-app-sqm, same low upload speed

Edit:

Connected RT-AC51U with 18.06.4 build
Speedtest http://www.dslreports.com/speedtest/54030930

Hi test out a 19.07 snapshot. https://downloads.openwrt.org/releases/19.07-SNAPSHOT/

Installed 19.07 a moment ago, will test out

19.07 did not solve the problem

Edit: attaching network configs and top -d 1 while running speedtest.




up

The 19.07 snapshot should have LUCI installed. You can use putty to ssh
in to your router at ssh port 22 IP 192.168.1.1

Sorry to here that mate. I don't have that router so I cant be of more
help sorry.

It scares me, because googling revealed that my cable might be faulty. Information so far - speeds are normal at edgerouter-x, RT-AC51U but bad with R7800.

Might need to reflash stock netgear firmware to rule out hardware error. Thanks for help

Related?

Thank you for linking the post, however even with stock firmware 1.0.2.63 the upload speed has yet to peak higher than 50 mb/s, where's on edgerouter it is reaching 85+ few seconds into the test.

The user has solved his problem with realtek driver, however I'am running windows10 packed with most recent drivers.

Can you test on another PC? Or with another cable, or even in wifi 5G (if close to router, should have more than 50mb...)

Yes, I will get some cables and another computer on Saturday

Update: the routers are cursed

Cables - bought extra and tested both old and new, they are not damaged because testing out connection directly to poe injector gives 90/90 speed
Computer - brought over a laptop, wiring it to router - 90/20, wiring it directly to poe 90/90.
Router - bought C7 Archer1750 for 8 euro, installed 18.06.4 - 90/20

What setting could possibly limit the upload speed but not download, maybe I'am messing up the connection setup.

After installing the firmware, I navigate at interfaces, change wan(0.2) from DHCP to static addr, fill the fields, save, enable and configure wifi and that is it.