R7800 Bad WiFi Speeds

I just installed hyman's stable build and have followed instructions on another thread. Title was "Very Slow WiFi for GB connection". There was improvement following that but I still get a C rating for bufferbloat on dslreports. I went from 19megabit to 50 on my iphone and 100 on my laptop. I still have some issues with my 5ghz, I have seen it at 300 on my iphone in the past but I am current getting 130 on my laptop and iphone. My wired desktop gets 490 and I pay for 500. I also get a lot of syntax errors in luci and it gets stuck on "Loading view..." a good amount. I am new to OpenWrt so I might be missing a few things, but any help would be greatly appreciated.

uname -a:
Linux OpenWrt 4.14.218 #0 SMP Wed Feb 3 18:15:29 2021 armv7l GNU/Linux

cat /etc/config/wireless:
config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option txpower '30'
        option htmode 'VHT20'
        option channel '40'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option key ''
        option ssid 'Wifi name but 5G'
        option encryption 'psk2+ccmp'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
        option txpower '30'
        option htmode 'HT20'
        option legacy_rates '0'
        option country 'US'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option key ''
        option ssid 'Wifi name'
        option encryption 'psk2+ccmp'

cat /etc/config/sqm:
config queue 'eth0'
        option interface 'eth0.2'
        option qdisc 'fq_codel'
        option qdisc_advanced '0'
        option enabled '1'
        option download '0'
        option debug_logging '0'
        option verbosity '5'
        option script 'simplest_tbf.qos'
        option upload '32500'
        option linklayer 'ethernet'
        option overhead '22'

Why are you choking your 802.11ac channel? You should be using VHT80 instead of VHT20. Also, set it to channel 36 for clarity, the first channel of that 80 MHz block.

See below for clarification.

Thank you so much! I got my 5ghz speeds up to 300 on my iphone! Any ideas on how to increase the 2.4 speeds? hehe, as you can tell I don't know a whole lot about which settings work together.

You can set HT40 similarly for 802.11bgn but it will fall back to HT20 ('good neighbour') in congested environments. Changing channels might help as well, make sure to scan your surroundings for other active radios.

I think hnyman already switched to the 21.02 codebase so you should be able to use the channel analysis functionality in OpenWrt itself.