R68s a new openwrt arm device. RK3568 2*2.5G+2*1G

seems from benchmark it cant handle more the 1gbit even on 2.5g iface... and its not supported with openwrt?

Not the official openwrt, but they use their own OS version based on openwrt.

@shdf thanks but seems it cant handle even 1gbit properly ;-(

1 Like

Is there any work in progress about adding OpenWrt support to NanoPI R5S?

I already purchased a R5S, and while I wait it to be delivered I've started looking at what would be required to have OpenWrt running on it.

I did a FriendlyWrt build but it is a mess. The .config seems to have a R2S profile with some adaptations. I really will not spend much time trying to understand what FriendlyWrt is doing.

On the other hand, github user @kidding9 seems to have created an armv8.mk patch that seems to be a good starting point (which seems to also be reusing R2S DTS file). When I have some free time, I will try applying this patch to OpenWrt to see what happens.

1 Like

This new review with a new benchmark is more promising. The reviewer was able to achieve 2.35Gbps on the 2.5Gbps ports:

The reviewer noted however that, in order to get the full speed, the following configuration change was needed:

(…) To achieve maximum throughput, delete the pre-configured bridge interface br0, and configure both multigigabit eth1 (LAN1 port) and eth2 (LAN2 port) as standalone unbridged interfaces.(…)

BTW, shouldn’t we split this topic into a new one dedicated to R5S? (this topic is for the R68s….).


I been doing some progress with the rk3568 SoC on OpenWrt and the mainline kernel,I got a r5s yestarday ,I could make it work with some issues with the WAN and LAN1 not working at a full speed , LAN2 is working and I did some tests.


@mj82 i tried to use your r5s image under your releases and dd onto sdcard but it wont boot. I have the 4gb version would that be different?

They ship the r5s with friendlywrt on the emmc, to boot from the sd card you neet to put the device in maskrom, press the mask key and keep pressed, power on, release the mask key after 4 sec.

1 Like

thanks a lot this worked. On reboot i have to keep doing this, is there a way to make this permanent or selectable?

actually nevermind, it tells you on their wiki https://wiki.friendlyelec.com/wiki/index.php/NanoPi_R5S

I backported patches from linux-next to kernel 5.19 and changed the WAN port to LAN1 on the R5S


Yes i see the problem. the wan port depends on the correct configuration for the PHY but we do not have that yet. How did you get the r5s patches to start with?

I modified the DTS from their repo ,they are using the 5.10 rockchip kernel https://github.com/mj22226/linux-stable/blob/nanopi5-v5.10.y_opt/arch/arm64/boot/dts/rockchip/rk3568-nanopi5-rev01.dts

1 Like

Great work on the R5S!

I will be buying one in a bit.

1 Like

can't boot with v.5.19 for R5S 4G https://github.com/mj22226/openwrt/releases/download/rockchip-5.19/openwrt-rockchip-armv8-friendlyelec_nanopi-r5s-ext4-sysupgrade.img.gz. burn img in Windows and in Linux - just solid red light and nothing happens after. please help, what do I do wrong?

unzip it and burn the img file. i suggest balanaetcher for windows img making.

Same here. Solid red on the SYS LED when booting from MicroSD. Card witten with balenaEtcher and dd.

Tried to flash the image to eMMC using FriendlyArm's eFlasher tool. Device failed to boot and the eMMC wasn't detected after trying to reflash it with any of the OEM's images. Had to put the device in MaskROM mode to recover the device using RKDevTool.

Perhaps you didn't press the mask button before booting from the sd card, works for me.

What is the different between openwrt and friendlywrt?

Yeah, button was pressed. Solid Red LED with no activity. Can flash it through the terminal with FriendlyWRT already installed but it renders the device unserviacable after rebooting. This is with the new 4GB model.

@Andy-Voigt FriendlyWRT is FiriendlyArm's fork of OpenWRT. I have yet to dive into the the detail of the changes they've made. One thing I have noticed with their image is that Wireguard doesn't work- even after the kmod package is reinstalled.