R4S Crashing Frequently

I recently set up OpenWrt on my R4S and it has pretty consistently been crashing once or twice a day. When it crashes, the WAN and LAN lights go out and Power and Sys remain lit. It is unreachable by SSH or Luci and logging to a USB stick stops.
The last crash seemed to be 40 seconds after a WAN lease renew. The one before that, the last item in log was a WAN renew, but there wasn't much else happening so I can't tell how long it took to crash.

I have tried downloading a fresh image and reflashing, without importing any settings, and it still does it.
Any help is greatly appreciated.

Here are the usual commands that are requested:
system board

{
        "kernel": "5.15.150",
        "hostname": "Router",
        "system": "ARMv8 Processor rev 4",
        "model": "FriendlyElec NanoPi R4S",
        "board_name": "friendlyarm,nanopi-r4s",
        "rootfs_type": "ext4",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.3",
                "revision": "r23809-234f1a2efa",
                "target": "rockchip/armv8",
                "description": "OpenWrt 23.05.3 r23809-234f1a2efa"
        }
}

network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'redacted'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth1'
        option ipv6 '1'

config device
        option name 'eth1'
        option macaddr 'redacted'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'eth0'
        option macaddr 'redacted'

config interface 'wan'
        option device 'eth0'
        option proto 'dhcp'

config interface 'wan6'
        option device 'eth0'
        option proto 'dhcpv6'

config device
        option type '8021q'
        option ifname 'br-lan'
        option vid '5'
        option name 'br-lan.5'
        option ipv6 '1'

config device
        option type '8021q'
        option ifname 'br-lan'
        option vid '4'
        option name 'br-lan.4'
        option ipv6 '1'

config interface 'work'
        option proto 'static'
        option device 'br-lan.5'
        option ipaddr '192.168.5.1'
        option netmask '255.255.255.0'

config interface 'IoT'
        option proto 'static'
        option device 'br-lan.4'
        option ipaddr '192.168.4.1'
        option netmask '255.255.255.0'

dhcp

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option localservice '1'
        option ednspacket_max '1232'
        list rebind_domain 'dns.msftncsi.com'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'
        option preferred_lifetime '3h'
        option ra_useleasetime '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config host
        option ip '192.168.1.3'
        option name 'redacted'
        list mac 'redacted'
        option leasetime '7d'

config dhcp 'work'
        option interface 'work'
        option start '100'
        option limit '20'
        option leasetime '12h'
        option ra_useleasetime '1'

config dhcp 'IoT'
        option interface 'IoT'
        option start '100'
        option limit '50'
        option leasetime '12h'
        option ra_useleasetime '1'

config host
        option ip '192.168.1.2'
        option leasetime '7d'
        option name 'redacted'
        list mac 'redacted'

config host
        option name 'redacted'
        option ip '192.168.5.2'
        option leasetime '7d'
        list mac 'redacted'

config host
        option name 'redacted'
        option ip '192.168.1.105'
        option leasetime '7d'
        list mac 'redacted'

config host
        option ip '192.168.5.105'
        option leasetime '7d'
        list mac 'redacted'

config host
        option name 'redacted'
        list mac 'redacted'
        option ip '192.168.1.190'
        option leasetime '7d'

config host
        list mac 'redacted'
        option ip '192.168.5.118'
        option leasetime '7d'

firewall

config defaults
        option input 'DROP'
        option output 'ACCEPT'
        option forward 'DROP'
        option synflood_protect '1'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option input 'DROP'
        option output 'ACCEPT'
        option forward 'DROP'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'
        option enabled '0'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config zone
        option name 'work'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'work'

config forwarding
        option src 'work'
        option dest 'wan'

config zone
        option name 'IoT'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'IoT'

config forwarding
        option src 'IoT'
        option dest 'wan'

config forwarding
        option src 'lan'
        option dest 'IoT'
1 Like

Next time(s) it happens, include the logs.

I would recommend removing all the 802.1q stanzas:

Then just use standard dotted notation (eth1.x) in the network interface stanzas:

config interface 'work'
        option proto 'static'
        option device 'eth1.5'
        option ipaddr '192.168.5.1'
        option netmask '255.255.255.0'

Do this for all of your VLANs.

Also, change input and forward to REJECT in the wan firewall zone:

Restart and see if that helps things.

1 Like

That is so cool that you see configs as poetry.

I can see that now.

2 Likes

Lines of logic, neatly laid,
A network's heart, so subtly made.
In UCI, the secrets lie,
Where firewalls rise and packets fly.

Interfaces with whispered names,
Zones defined in rule-bound games.
IP tables, chains so vast,
Filtering traffic, future and past.

DHCP hands out fleeting gain,
Wireless whispers, strength to maintain.
NAT masquerades with artful grace,
Packets transformed, no time to waste.

Comments scarce, like hidden signs,
A trail of thought the code defines.
Through logic's maze, the mind does roam,
Unraveling secrets in this textual home.

7 Likes

Please, don't make me worship you.
I'm in awe of you enough!

the poem is AI generated... lol

3 Likes

I'm going to cry in a corner now.

This is what is sounds like, when dogs cry...

I do have the log from the last time it happened. redactedmac1 was spamming DHCP the whole time so I had to trim most of that out to fit the post. I have to figure out what device that is, but it wasn't doing that on the crash before.

The "stanzas" are just how Luci did it, but I'll try modifying them to what psherman said and see if that helps.

Wed Apr 10 06:31:54 2024 daemon.info dnsmasq[1]: read /etc/hosts - 12 names
Wed Apr 10 06:31:54 2024 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 8 names
Wed Apr 10 06:31:54 2024 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 4 names
Wed Apr 10 06:31:54 2024 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Wed Apr 10 06:31:54 2024 daemon.err collectd[1628]: Exiting normally.
Wed Apr 10 06:31:54 2024 daemon.err collectd[1628]: collectd: Stopping 2 read threads.
Wed Apr 10 06:31:54 2024 daemon.err collectd[1628]: collectd: Stopping 5 write threads.
Wed Apr 10 06:31:54 2024 daemon.err collectd[1628]: rrdtool plugin: Shutting down the queue thread.
Wed Apr 10 06:31:54 2024 daemon.err collectd[4530]: configfile: stat (/etc/collectd/conf.d/*.conf) failed: No such file or directory
Wed Apr 10 06:31:54 2024 daemon.err collectd[4530]: plugin_load: plugin "cpu" successfully loaded.
Wed Apr 10 06:31:54 2024 daemon.err collectd[4530]: plugin_load: plugin "interface" successfully loaded.
Wed Apr 10 06:31:54 2024 daemon.err collectd[4530]: plugin_load: plugin "memory" successfully loaded.
Wed Apr 10 06:31:54 2024 daemon.err collectd[4530]: plugin_load: plugin "rrdtool" successfully loaded.
Wed Apr 10 06:31:54 2024 daemon.err collectd[4530]: rrdtool plugin: RRASingle = true: creating only AVERAGE RRAs
Wed Apr 10 06:31:54 2024 daemon.err collectd[4530]: plugin_load: plugin "thermal" successfully loaded.
Wed Apr 10 06:31:54 2024 daemon.err collectd[4530]: Initialization complete, entering read-loop.
Wed Apr 10 06:31:55 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 06:31:55 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.110 redactedmac1
Wed Apr 10 06:31:57 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 06:31:57 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.110 redactedmac1
Wed Apr 10 06:33:52 2024 authpriv.info dropbear[4757]: Child connection from 192.168.1.190:51904
Wed Apr 10 06:33:53 2024 authpriv.notice dropbear[4757]: Password auth succeeded for 'root' from 192.168.1.190:51904
Wed Apr 10 06:33:56 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 06:33:56 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.110 redactedmac1
Wed Apr 10 06:33:58 2024 daemon.info dnsmasq[1]: read /etc/hosts - 12 names
Wed Apr 10 06:33:58 2024 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 8 names
Wed Apr 10 06:33:58 2024 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 8 names
Wed Apr 10 06:33:58 2024 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Wed Apr 10 06:33:59 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 06:33:59 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.110 redactedmac1
Wed Apr 10 06:34:02 2024 authpriv.info dropbear[4757]: Exit (root) from <192.168.1.190:51904>: Exited normally
Wed Apr 10 06:34:02 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 06:34:02 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.110 redactedmac1
Wed Apr 10 06:37:20 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan.4) 192.168.4.127 redacted2
Wed Apr 10 06:37:20 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan.4) 192.168.4.127 redacted2 HS103
Wed Apr 10 06:37:39 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan.4) 192.168.4.126 redactedmac3
Wed Apr 10 06:37:39 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan.4) 192.168.4.126 redactedmac3 HS103
Wed Apr 10 06:37:45 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 06:37:45 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.110 redactedmac1
Wed Apr 10 06:37:47 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 06:37:47 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.110 redactedmac1
Wed Apr 10 06:37:48 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan.4) 192.168.4.130 redactedmac4
Wed Apr 10 06:37:48 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan.4) 192.168.4.130 redactedmac4 KP115
Wed Apr 10 06:37:50 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 06:37:50 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.110 redactedmac1
Wed Apr 10 06:37:56 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 06:37:56 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.110 redactedmac1
Wed Apr 10 06:37:59 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 06:37:59 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.110 redactedmac1
Wed Apr 10 06:38:02 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 06:38:02 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.110 redactedmac1
Wed Apr 10 06:38:07 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 06:38:07 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.110 redactedmac1
Wed Apr 10 06:38:10 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 06:38:10 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.110 redactedmac1
Wed Apr 10 06:38:13 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 06:38:13 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.110 redactedmac1
Wed Apr 10 06:38:13 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan.4) 192.168.4.120 redactedmac5
Wed Apr 10 06:38:13 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan.4) 192.168.4.120 redactedmac5 Thermostat
Wed Apr 10 06:38:18 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 06:38:18 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.110 redactedmac1
Wed Apr 10 06:38:22 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 06:38:22 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.110 redactedmac1
Wed Apr 10 06:38:25 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 06:38:25 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.110 redactedmac1
Wed Apr 10 06:38:33 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 06:38:33 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.110 redactedmac1
Wed Apr 10 06:38:36 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 06:38:36 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.110 redactedmac1
Wed Apr 10 06:38:39 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 06:38:39 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.110 redactedmac1
Wed Apr 10 06:38:44 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 06:38:44 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.110 redactedmac1
Wed Apr 10 06:38:47 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 06:38:47 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.110 redactedmac1
Wed Apr 10 06:38:50 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 06:38:50 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.110 redactedmac1
Wed Apr 10 06:38:55 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 06:38:55 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.110 redactedmac1
Wed Apr 10 06:38:58 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 06:38:58 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.110 redactedmac1
Wed Apr 10 06:39:01 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 06:39:01 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.110 redactedmac1
Wed Apr 10 06:39:06 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 06:39:06 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.110 redactedmac1
Wed Apr 10 06:39:09 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 06:39:09 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.110 redactedmac1
Wed Apr 10 06:39:12 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 06:39:12 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.110 redactedmac1
Wed Apr 10 06:39:16 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) 192.168.1.187 redactedmac6
Wed Apr 10 06:39:16 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan) 192.168.1.187 redactedmac6
Wed Apr 10 06:39:21 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 06:39:21 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.110 redactedmac1
Wed Apr 10 06:39:24 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 06:39:24 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.110 redactedmac1
Wed Apr 10 06:39:27 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 06:39:27 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.110 redactedmac1
Wed Apr 10 06:39:32 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 06:39:32 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.110 redactedmac1
Wed Apr 10 06:39:35 2024 authpriv.info dropbear[5005]: Child connection from 192.168.1.190:52305
Wed Apr 10 06:39:35 2024 authpriv.notice dropbear[5005]: Password auth succeeded for 'root' from 192.168.1.190:52305
Wed Apr 10 06:44:01 2024 daemon.info dnsmasq[1]: exiting on receipt of SIGTERM
Wed Apr 10 06:44:01 2024 daemon.info dnsmasq[1]: started, version 2.90 cachesize 1000
Wed Apr 10 06:44:01 2024 daemon.info dnsmasq[1]: DNS service limited to local subnets
Wed Apr 10 06:44:01 2024 daemon.info dnsmasq[1]: compile time options: IPv6 GNU-getopt no-DBus UBus no-i18n no-IDN DHCP no-DHCPv6 no-Lua TFTP no-conntrack no-ipset no-nftset no-auth no-cryptohash no-DNSSEC no-ID loop-detect inotify dumpfile
Wed Apr 10 06:44:01 2024 daemon.info dnsmasq[1]: UBus support enabled: connected to system bus
Wed Apr 10 06:44:01 2024 daemon.info dnsmasq-dhcp[1]: DHCP, IP range 192.168.4.100 -- 192.168.4.149, lease time 12h
Wed Apr 10 06:44:01 2024 daemon.info dnsmasq-dhcp[1]: DHCP, IP range 192.168.5.100 -- 192.168.5.119, lease time 12h
Wed Apr 10 06:44:01 2024 daemon.info dnsmasq-dhcp[1]: DHCP, IP range 192.168.1.100 -- 192.168.1.249, lease time 12h
Wed Apr 10 06:44:01 2024 daemon.info dnsmasq[1]: using only locally-known addresses for test
Wed Apr 10 06:44:01 2024 daemon.info dnsmasq[1]: using only locally-known addresses for onion
Wed Apr 10 06:44:01 2024 daemon.info dnsmasq[1]: using only locally-known addresses for localhost
Wed Apr 10 06:44:01 2024 daemon.info dnsmasq[1]: using only locally-known addresses for local
Wed Apr 10 06:44:01 2024 daemon.info dnsmasq[1]: using only locally-known addresses for invalid
Wed Apr 10 06:44:01 2024 daemon.info dnsmasq[1]: using only locally-known addresses for bind
Wed Apr 10 06:44:01 2024 daemon.info dnsmasq[1]: using only locally-known addresses for lan
Wed Apr 10 06:44:01 2024 daemon.info dnsmasq[1]: reading /tmp/resolv.conf.d/resolv.conf.auto
Wed Apr 10 06:44:01 2024 daemon.info dnsmasq[1]: using nameserver redactedserver
Wed Apr 10 06:44:01 2024 daemon.info dnsmasq[1]: using nameserver redactedserver
Wed Apr 10 06:44:01 2024 daemon.info dnsmasq[1]: using only locally-known addresses for test
Wed Apr 10 06:44:01 2024 daemon.info dnsmasq[1]: using only locally-known addresses for onion
Wed Apr 10 06:44:01 2024 daemon.info dnsmasq[1]: using only locally-known addresses for localhost
Wed Apr 10 06:44:01 2024 daemon.info dnsmasq[1]: using only locally-known addresses for local
Wed Apr 10 06:44:01 2024 daemon.info dnsmasq[1]: using only locally-known addresses for invalid
Wed Apr 10 06:44:01 2024 daemon.info dnsmasq[1]: using only locally-known addresses for bind
Wed Apr 10 06:44:01 2024 daemon.info dnsmasq[1]: using only locally-known addresses for lan
Wed Apr 10 06:44:01 2024 daemon.info dnsmasq[1]: read /etc/hosts - 12 names
Wed Apr 10 06:44:01 2024 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 8 names
Wed Apr 10 06:44:01 2024 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 8 names
Wed Apr 10 06:44:01 2024 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Wed Apr 10 06:45:35 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan.5) 192.168.5.106 redactedmac7
Wed Apr 10 06:45:35 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan.5) 192.168.5.106 redactedmac7 iPhone
Wed Apr 10 06:45:35 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan.5) 192.168.5.106 redactedmac7
Wed Apr 10 06:45:35 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan.5) 192.168.5.106 redactedmac7 iPhone
Wed Apr 10 06:57:23 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan.5) 192.168.5.109 redactedmac8
Wed Apr 10 06:57:23 2024 daemon.warn dnsmasq-dhcp[1]: Ignoring domain corpads.local for DHCP host name WorkLaptop
Wed Apr 10 06:57:23 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan.5) 192.168.5.109 redactedmac8 WorkLaptop
Wed Apr 10 06:57:24 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 06:57:24 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.137 redactedmac1
Wed Apr 10 06:57:27 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan.5) 192.168.5.109 redactedmac8
Wed Apr 10 06:57:27 2024 daemon.warn dnsmasq-dhcp[1]: Ignoring domain corpads.local for DHCP host name WorkLaptop
Wed Apr 10 06:57:27 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan.5) 192.168.5.109 redactedmac8 WorkLaptop
Wed Apr 10 07:29:01 2024 daemon.notice netifd: wan (2943): udhcpc: sending renew to server redactedserver
Wed Apr 10 07:29:01 2024 daemon.notice netifd: wan (2943): udhcpc: lease of redactedip obtained from redactedserver, lease time 7200
Wed Apr 10 07:29:02 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 07:29:02 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.137 redactedmac1
Wed Apr 10 07:50:04 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) 192.168.1.204 redactedmac9
Wed Apr 10 07:50:04 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan) 192.168.1.204 redactedmac9 iPhone-3
Wed Apr 10 07:50:05 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 07:50:05 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.137 redactedmac1
Wed Apr 10 08:21:54 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan.5) 192.168.5.119 redactedmac10
Wed Apr 10 08:21:54 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan.5) 192.168.5.119 redactedmac10
Wed Apr 10 08:21:55 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 08:21:55 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.137 redactedmac1
Wed Apr 10 08:29:00 2024 daemon.notice netifd: wan (2943): udhcpc: sending renew to server redactedserver
Wed Apr 10 08:29:00 2024 daemon.notice netifd: wan (2943): udhcpc: lease of redactedip obtained from redactedserver, lease time 7200
Wed Apr 10 08:29:03 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 08:29:03 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.137 redactedmac1
Wed Apr 10 09:29:01 2024 daemon.notice netifd: wan (2943): udhcpc: sending renew to server redactedserver
Wed Apr 10 09:29:01 2024 daemon.notice netifd: wan (2943): udhcpc: lease of redactedip obtained from redactedserver, lease time 7200
Wed Apr 10 09:29:05 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 09:29:05 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.137 redactedmac1
Wed Apr 10 10:29:01 2024 daemon.notice netifd: wan (2943): udhcpc: sending renew to server redactedserver
Wed Apr 10 10:29:01 2024 daemon.notice netifd: wan (2943): udhcpc: lease of redactedip obtained from redactedserver, lease time 7200
Wed Apr 10 10:29:03 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 10:29:03 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.137 redactedmac1
Wed Apr 10 10:29:08 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 10:29:08 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.137 redactedmac1
Wed Apr 10 10:29:11 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 10:29:11 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.137 redactedmac1
Wed Apr 10 10:29:14 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 10:29:14 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.137 redactedmac1
Wed Apr 10 10:29:20 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 10:29:20 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.137 redactedmac1
Wed Apr 10 10:29:26 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 10:29:26 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.137 redactedmac1
Wed Apr 10 10:29:26 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 10:29:26 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.137 redactedmac1
Wed Apr 10 10:29:34 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 10:29:34 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.137 redactedmac1
Wed Apr 10 10:29:37 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 10:29:37 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.137 redactedmac1
Wed Apr 10 10:29:40 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan.4) redactedmac1
Wed Apr 10 10:29:40 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan.4) 192.168.4.137 redactedmac1

Try @psherman's 'stanzas'.
He's not wrong about the configs.

Are you using a power supply with at least 2A and from a good brand?

And have you tried a different MicroSD card?

Just trying to rule out these hardware possibilities....

I am using a 60w Dell USB-C laptop power supply. The CanaKit Pi 4 5v/3.5A supply failed to boot. So did a 5V/4A one from amazon. Laptop charger works fine, as does USB 3.2 output from my desktop.
I have not tried a different microSD yet, although it is a brand new Sandisk max endurance 32gb card.

It is not the SD card, yet. If the card failed it would fail, in a cascade, spectacularly.

That suggests a hardware problem.
But there may be a configuration problem, so absorb the feedback.

If you want to test the hardware, boot in another Linux distro and stress test it for >30 minutes.

I was a bit worried about that. We'll see how it does with the changes. If it crashes again I'll try a stress test.

Follow up question - I changed the firewall to drop rather than reject, because isn't that theoretically more "invisible" for possible external risks? Or did I do that wrong?

I have a debate about drop vs. reject.

I have no problems dropping everything, including ping but @psherman knows VLANs.

So, as I wrote before: absorb and implement. Just save before every change.

Yes. In practice, probably not. Unless you have a specific reason to switch it to drop then it's absolutely fine to leave it as reject. You're no more secure with either setting.

So it crashed again today, but differently than usual. Clients were able to retain their IP, and the system stayed "running" and repeating kernel warnings until I rebooted it this morning. I cut the log short to fit but it spammed the same kernel warning until I rebooted at 7am today.

Wed Apr 10 21:34:52 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) 192.168.1.146 mac1
Wed Apr 10 21:34:52 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan) 192.168.1.146 mac1 Pixel-8
Wed Apr 10 21:36:27 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(eth1.4) 192.168.4.120 mac2
Wed Apr 10 21:36:27 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(eth1.4) 192.168.4.120 mac2 Thermostat
Wed Apr 10 21:40:15 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(eth1.5) 192.168.5.109 mac3
Wed Apr 10 21:40:15 2024 daemon.warn dnsmasq-dhcp[1]: Ignoring domain corpads.local for DHCP host name WorkLaptop
Wed Apr 10 21:40:15 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(eth1.5) 192.168.5.109 mac3 WorkLaptop
Wed Apr 10 21:46:44 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) 192.168.1.146 mac1
Wed Apr 10 21:46:44 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan) 192.168.1.146 mac1 Pixel-8
Wed Apr 10 21:52:11 2024 daemon.notice netifd: wan (2922): udhcpc: sending renew to server redactedserver
Wed Apr 10 21:52:11 2024 daemon.notice netifd: wan (2922): udhcpc: lease of redactedip obtained from redactedserver, lease time 7200
Wed Apr 10 21:57:11 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(eth1.4) 192.168.4.120 mac2
Wed Apr 10 21:57:11 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(eth1.4) 192.168.4.120 mac2 Thermostat
Wed Apr 10 22:29:23 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(eth1.4) 192.168.4.133 mac4
Wed Apr 10 22:29:23 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(eth1.4) 192.168.4.133 mac4 RokuExpress
Wed Apr 10 22:32:48 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(eth1.4) 192.168.4.133 mac4
Wed Apr 10 22:32:48 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(eth1.4) 192.168.4.133 mac4 RokuExpress
Wed Apr 10 22:36:14 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) 192.168.1.204 mac5
Wed Apr 10 22:36:14 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan) 192.168.1.204 mac5 iPhone-3
Wed Apr 10 22:38:05 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(eth1.4) 192.168.4.120 mac2
Wed Apr 10 22:38:05 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(eth1.4) 192.168.4.120 mac2 Thermostat
Wed Apr 10 22:52:10 2024 daemon.notice netifd: wan (2922): udhcpc: sending renew to server redactedserver
Wed Apr 10 22:52:10 2024 daemon.notice netifd: wan (2922): udhcpc: lease of redactedip obtained from redactedserver, lease time 7200
Wed Apr 10 23:02:29 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(eth1.5) mac6
Wed Apr 10 23:02:29 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(eth1.5) 192.168.5.105 mac6
Wed Apr 10 23:02:29 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(eth1.5) 192.168.5.105 mac6
Wed Apr 10 23:02:29 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(eth1.5) 192.168.5.105 mac6 MerakiRouter
Wed Apr 10 23:16:07 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan) 192.168.1.105 mac7
Wed Apr 10 23:16:07 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan) 192.168.1.105 mac7
Wed Apr 10 23:16:07 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) 192.168.1.105 mac7
Wed Apr 10 23:16:07 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan) 192.168.1.105 mac7 Printer
Wed Apr 10 23:41:52 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(eth1.4) 192.168.4.146 mac8
Wed Apr 10 23:41:52 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(eth1.4) 192.168.4.146 mac8 redactedSN
Wed Apr 10 23:52:10 2024 daemon.notice netifd: wan (2922): udhcpc: sending renew to server redactedserver
Wed Apr 10 23:52:10 2024 daemon.notice netifd: wan (2922): udhcpc: lease of redactedip obtained from redactedserver, lease time 7200
Wed Apr 10 23:58:40 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(eth1.4) 192.168.4.120 mac2
Wed Apr 10 23:58:40 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(eth1.4) 192.168.4.120 mac2 Thermostat
Thu Apr 11 00:23:14 2024 authpriv.info dropbear[17895]: Child connection from 192.168.1.190:56318
Thu Apr 11 00:23:14 2024 authpriv.notice dropbear[17895]: Password auth succeeded for 'root' from 192.168.1.190:56318
Thu Apr 11 00:23:21 2024 authpriv.info dropbear[17895]: Exit (root) from <192.168.1.190:56318>: Exited normally
Thu Apr 11 00:37:56 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) 192.168.1.187 mac9
Thu Apr 11 00:37:56 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan) 192.168.1.187 mac9
Thu Apr 11 00:52:10 2024 daemon.notice netifd: wan (2922): udhcpc: sending renew to server redactedserver
Thu Apr 11 00:52:10 2024 daemon.notice netifd: wan (2922): udhcpc: lease of redactedip obtained from redactedserver, lease time 7200
Thu Apr 11 01:04:19 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) 192.168.1.146 mac1
Thu Apr 11 01:04:19 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan) 192.168.1.146 mac1 Pixel-8
Thu Apr 11 01:52:11 2024 daemon.notice netifd: wan (2922): udhcpc: sending renew to server redactedserver
Thu Apr 11 01:52:11 2024 daemon.notice netifd: wan (2922): udhcpc: lease of redactedip obtained from redactedserver, lease time 7200
Thu Apr 11 01:52:47 2024 daemon.info dnsmasq[1]: read /etc/hosts - 12 names
Thu Apr 11 01:52:47 2024 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 8 names
Thu Apr 11 01:52:47 2024 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 4 names
Thu Apr 11 01:52:47 2024 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Thu Apr 11 02:39:30 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(eth1.4) 192.168.4.120 mac2
Thu Apr 11 02:39:30 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(eth1.4) 192.168.4.120 mac2 Thermostat
Thu Apr 11 02:52:11 2024 daemon.notice netifd: wan (2922): udhcpc: sending renew to server redactedserver
Thu Apr 11 02:52:11 2024 daemon.notice netifd: wan (2922): udhcpc: lease of redactedip obtained from redactedserver, lease time 7200
Thu Apr 11 03:23:21 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(eth1.4) 192.168.4.127 mac10
Thu Apr 11 03:23:21 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(eth1.4) 192.168.4.127 mac10 HS103
Thu Apr 11 03:23:40 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(eth1.4) 192.168.4.126 mac11
Thu Apr 11 03:23:40 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(eth1.4) 192.168.4.126 mac11 HS103
Thu Apr 11 03:23:49 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(eth1.4) 192.168.4.130 mac12
Thu Apr 11 03:23:49 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(eth1.4) 192.168.4.130 mac12 KP115
Thu Apr 11 03:24:18 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(eth1.4) 192.168.4.137 mac13
Thu Apr 11 03:24:18 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(eth1.4) 192.168.4.137 mac13 KP115
Thu Apr 11 03:25:14 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(eth1.5) 192.168.5.119 mac14
Thu Apr 11 03:25:14 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(eth1.5) 192.168.5.119 mac14
Thu Apr 11 03:28:28 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(eth1.5) 192.168.5.106 mac15
Thu Apr 11 03:28:28 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(eth1.5) 192.168.5.106 mac15 iPhone
Thu Apr 11 03:52:11 2024 daemon.notice netifd: wan (2922): udhcpc: sending renew to server redactedserver
Thu Apr 11 03:52:11 2024 daemon.notice netifd: wan (2922): udhcpc: lease of redactedip obtained from redactedserver, lease time 7200
Thu Apr 11 04:32:49 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(eth1.4) 192.168.4.133 mac4
Thu Apr 11 04:32:49 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(eth1.4) 192.168.4.133 mac4 RokuExpress
Thu Apr 11 04:36:36 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) 192.168.1.204 mac5
Thu Apr 11 04:36:36 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan) 192.168.1.204 mac5 iPhone-3
Thu Apr 11 04:52:11 2024 daemon.notice netifd: wan (2922): udhcpc: sending renew to server redactedserver
Thu Apr 11 04:52:11 2024 daemon.notice netifd: wan (2922): udhcpc: lease of redactedip obtained from redactedserver, lease time 7200
Thu Apr 11 05:13:03 2024 kern.alert kernel: [33667.297896] Unable to handle kernel access to user memory outside uaccess routines at virtual address 0000000000400058
Thu Apr 11 05:13:03 2024 kern.alert kernel: [33667.298873] Mem abort info:
Thu Apr 11 05:13:03 2024 kern.alert kernel: [33667.299124]   ESR = 0x0000000096000004
Thu Apr 11 05:13:03 2024 kern.alert kernel: [33667.299460]   EC = 0x25: DABT (current EL), IL = 32 bits
Thu Apr 11 05:13:03 2024 kern.alert kernel: [33667.299935]   SET = 0, FnV = 0
Thu Apr 11 05:13:03 2024 kern.alert kernel: [33667.300210]   EA = 0, S1PTW = 0
Thu Apr 11 05:13:03 2024 kern.alert kernel: [33667.300492]   FSC = 0x04: level 0 translation fault
Thu Apr 11 05:13:03 2024 kern.alert kernel: [33667.300927] Data abort info:
Thu Apr 11 05:13:03 2024 kern.alert kernel: [33667.301185]   ISV = 0, ISS = 0x00000004
Thu Apr 11 05:13:03 2024 kern.alert kernel: [33667.301588]   CM = 0, WnR = 0
Thu Apr 11 05:13:03 2024 kern.alert kernel: [33667.301858] user pgtable: 4k pages, 48-bit VAs, pgdp=0000000002e15000
Thu Apr 11 05:13:03 2024 kern.alert kernel: [33667.302470] [0000000000400058] pgd=0800000002bb5003, p4d=0800000002bb5003, pud=08000000053bf003, pmd=0800000002ae9003, pte=00200000f1f02fc3
Thu Apr 11 05:13:03 2024 kern.emerg kernel: [33667.303617] Internal error: Oops: 0000000096000004 [#1] PREEMPT SMP
Thu Apr 11 05:13:03 2024 kern.warn kernel: [33667.304178] Modules linked in: pppoe ppp_async nft_fib_inet nf_flow_table_ipv6 nf_flow_table_ipv4 nf_flow_table_inet pppox ppp_generic nft_reject_ipv6 nft_reject_ipv4 nft_reject_inet nft_reject nft_redir nft_quota nft_objref nft_numgen nft_nat nft_masq nft_log nft_limit nft_hash nft_flow_offload nft_fib_ipv6 nft_fib_ipv4 nft_fib nft_ct nft_counter nft_chain_nat nf_tables nf_nat nf_flow_table nf_conntrack lzo iptable_mangle iptable_filter ipt_REJECT ipt_ECN ip_tables xt_time xt_tcpudp xt_tcpmss xt_statistic xt_multiport xt_mark xt_mac xt_limit xt_length xt_hl xt_ecn xt_dscp xt_comment xt_TCPMSS xt_LOG xt_HL xt_DSCP xt_CLASSIFY x_tables slhc sch_cake r8169 nfnetlink nf_reject_ipv6 nf_reject_ipv4 nf_log_syslog nf_defrag_ipv6 nf_defrag_ipv4 lzo_rle lzo_decompress lzo_compress crc_ccitt sch_tbf sch_ingress sch_htb sch_hfsc em_u32 cls_u32 cls_route cls_matchall cls_fw cls_flow cls_basic act_skbedit act_mirred act_gact ifb crypto_acompress gpio_button_hotplug exfat
Thu Apr 11 05:13:03 2024 kern.warn kernel: [33667.311881] CPU: 1 PID: 2522 Comm: watchcat.sh Not tainted 5.15.150 #0
Thu Apr 11 05:13:03 2024 kern.warn kernel: [33667.312490] Hardware name: FriendlyElec NanoPi R4S (DT)
Thu Apr 11 05:13:03 2024 kern.warn kernel: [33667.312972] pstate: 20400005 (nzCv daif +PAN -UAO -TCO -DIT -SSBS BTYPE=--)
Thu Apr 11 05:13:03 2024 kern.warn kernel: [33667.313618] pc : 0xffff8000081c0e2c
Thu Apr 11 05:13:03 2024 kern.warn kernel: [33667.313950] lr : 0xffff8000081c0db4
Thu Apr 11 05:13:03 2024 kern.warn kernel: [33667.314278] sp : ffff80000c563930
Thu Apr 11 05:13:03 2024 kern.warn kernel: [33667.314590] x29: ffff80000c563930 x28: 0000000000000000 x27: ffff00000207b460
Thu Apr 11 05:13:03 2024 kern.warn kernel: [33667.315266] x26: ffff800008c49000 x25: ffff000005dac980 x24: 0000000000000cc0
Thu Apr 11 05:13:03 2024 kern.warn kernel: [33667.315941] x23: 0000000000000000 x22: 0000000000400000 x21: ffff000000407400
Thu Apr 11 05:13:03 2024 kern.warn kernel: [33667.316613] x20: ffff800008039168 x19: f4899418c23ada66 x18: 0000000000000000
Thu Apr 11 05:13:03 2024 kern.warn kernel: [33667.317287] x17: 0000000000000000 x16: 0000000000000000 x15: 0000000000000000
Thu Apr 11 05:13:03 2024 kern.warn kernel: [33667.317959] x14: 0000000000000002 x13: 00000000000ecb05 x12: 0000000000000000
Thu Apr 11 05:13:03 2024 kern.warn kernel: [33667.318631] x11: ffff0000005a8000 x10: ffffffffffffffff x9 : 0000000000000000
Thu Apr 11 05:13:03 2024 kern.warn kernel: [33667.319304] x8 : ffff000005299f40 x7 : ffff00000121cf00 x6 : 0000000000100000
Thu Apr 11 05:13:03 2024 kern.warn kernel: [33667.319976] x5 : ffff00000121d1d8 x4 : 0000000000000000 x3 : 0000000000000058
Thu Apr 11 05:13:03 2024 kern.warn kernel: [33667.320649] x2 : 0000000000000000 x1 : 000000000504df01 x0 : 5800400000000000
Thu Apr 11 05:13:03 2024 kern.warn kernel: [33667.321322] Call trace:
Thu Apr 11 05:13:03 2024 kern.warn kernel: [33667.321556]  0xffff8000081c0e2c
Thu Apr 11 05:13:03 2024 kern.warn kernel: [33667.321856]  0xffff800008039168
Thu Apr 11 05:13:03 2024 kern.warn kernel: [33667.322155]  0xffff80000803a68c
Thu Apr 11 05:13:03 2024 kern.warn kernel: [33667.322455]  0xffff80000803b2b0
Thu Apr 11 05:13:03 2024 kern.warn kernel: [33667.322754]  0xffff80000803b6d0
Thu Apr 11 05:13:03 2024 kern.warn kernel: [33667.323053]  0xffff80000803b870
Thu Apr 11 05:13:03 2024 kern.warn kernel: [33667.323353]  0xffff8000080238b0
Thu Apr 11 05:13:03 2024 kern.warn kernel: [33667.323652]  0xffff8000080239a0
Thu Apr 11 05:13:03 2024 kern.warn kernel: [33667.323951]  0xffff8000088b7fd8
Thu Apr 11 05:13:03 2024 kern.warn kernel: [33667.324250]  0xffff8000088b8de8
Thu Apr 11 05:13:03 2024 kern.warn kernel: [33667.324549]  0xffff8000080115f4
Thu Apr 11 05:13:03 2024 kern.emerg kernel: [33667.324857] Code: f9405eb3 8b0302c0 b9401322 dac00c00 (f8636ac3)
Thu Apr 11 05:13:03 2024 kern.warn kernel: [33667.325421] ---[ end trace b59c614518f71d80 ]---
Thu Apr 11 05:13:04 2024 kern.alert kernel: [33668.732224] Unable to handle kernel access to user memory outside uaccess routines at virtual address 0000000000400058
Thu Apr 11 05:13:04 2024 kern.alert kernel: [33668.733238] Mem abort info:
Thu Apr 11 05:13:04 2024 kern.alert kernel: [33668.733504]   ESR = 0x0000000096000004
Thu Apr 11 05:13:04 2024 kern.alert kernel: [33668.733854]   EC = 0x25: DABT (current EL), IL = 32 bits
Thu Apr 11 05:13:04 2024 kern.alert kernel: [33668.734347]   SET = 0, FnV = 0
Thu Apr 11 05:13:04 2024 kern.alert kernel: [33668.734637]   EA = 0, S1PTW = 0
Thu Apr 11 05:13:04 2024 kern.alert kernel: [33668.734933]   FSC = 0x04: level 0 translation fault
Thu Apr 11 05:13:04 2024 kern.alert kernel: [33668.735386] Data abort info:
Thu Apr 11 05:13:04 2024 kern.alert kernel: [33668.735656]   ISV = 0, ISS = 0x00000004
Thu Apr 11 05:13:04 2024 kern.alert kernel: [33668.736012]   CM = 0, WnR = 0
Thu Apr 11 05:13:04 2024 kern.alert kernel: [33668.736294] user pgtable: 4k pages, 48-bit VAs, pgdp=0000000002723000
Thu Apr 11 05:13:04 2024 kern.alert kernel: [33668.736888] [0000000000400058] pgd=0000000000000000, p4d=0000000000000000
Thu Apr 11 05:13:04 2024 kern.emerg kernel: [33668.737525] Internal error: Oops: 0000000096000004 [#2] PREEMPT SMP
Thu Apr 11 05:13:04 2024 kern.warn kernel: [33668.738103] Modules linked in: pppoe ppp_async nft_fib_inet nf_flow_table_ipv6 nf_flow_table_ipv4 nf_flow_table_inet pppox ppp_generic nft_reject_ipv6 nft_reject_ipv4 nft_reject_inet nft_reject nft_redir nft_quota nft_objref nft_numgen nft_nat nft_masq nft_log nft_limit nft_hash nft_flow_offload nft_fib_ipv6 nft_fib_ipv4 nft_fib nft_ct nft_counter nft_chain_nat nf_tables nf_nat nf_flow_table nf_conntrack lzo iptable_mangle iptable_filter ipt_REJECT ipt_ECN ip_tables xt_time xt_tcpudp xt_tcpmss xt_statistic xt_multiport xt_mark xt_mac xt_limit xt_length xt_hl xt_ecn xt_dscp xt_comment xt_TCPMSS xt_LOG xt_HL xt_DSCP xt_CLASSIFY x_tables slhc sch_cake r8169 nfnetlink nf_reject_ipv6 nf_reject_ipv4 nf_log_syslog nf_defrag_ipv6 nf_defrag_ipv4 lzo_rle lzo_decompress lzo_compress crc_ccitt sch_tbf sch_ingress sch_htb sch_hfsc em_u32 cls_u32 cls_route cls_matchall cls_fw cls_flow cls_basic act_skbedit act_mirred act_gact ifb crypto_acompress gpio_button_hotplug exfat
Thu Apr 11 05:13:04 2024 kern.warn kernel: [33668.746293] CPU: 1 PID: 1132 Comm: odhcpd Tainted: G      D           5.15.150 #0
Thu Apr 11 05:13:04 2024 kern.warn kernel: [33668.746988] Hardware name: FriendlyElec NanoPi R4S (DT)
Thu Apr 11 05:13:04 2024 kern.warn kernel: [33668.747472] pstate: 20400005 (nzCv daif +PAN -UAO -TCO -DIT -SSBS BTYPE=--)
Thu Apr 11 05:13:04 2024 kern.warn kernel: [33668.748119] pc : 0xffff8000081c0e2c
Thu Apr 11 05:13:04 2024 kern.warn kernel: [33668.748450] lr : 0xffff8000081c0db4
Thu Apr 11 05:13:04 2024 kern.warn kernel: [33668.748779] sp : ffff80000abbba80
Thu Apr 11 05:13:04 2024 kern.warn kernel: [33668.749090] x29: ffff80000abbba80 x28: ffff000002539880 x27: ffff000005e24000
Thu Apr 11 05:13:04 2024 kern.warn kernel: [33668.749766] x26: ffff800008c49000 x25: ffff000002539880 x24: 0000000000000cc0
Thu Apr 11 05:13:04 2024 kern.warn kernel: [33668.750439] x23: 0000000000000000 x22: 0000000000400000 x21: ffff000000407400
Thu Apr 11 05:13:04 2024 kern.warn kernel: [33668.751112] x20: ffff800008039168 x19: f4899418c23ada66 x18: 0000000000000000
Thu Apr 11 05:13:04 2024 kern.warn kernel: [33668.751785] x17: 0000000000000000 x16: 0000000000000000 x15: 0000000000000000
Thu Apr 11 05:13:04 2024 kern.warn kernel: [33668.752456] x14: 0000000000000000 x13: 0000000000000000 x12: 0000000000000000
Thu Apr 11 05:13:04 2024 kern.warn kernel: [33668.753127] x11: 0000000000000000 x10: 0000000000000000 x9 : 0000000000000000
Thu Apr 11 05:13:04 2024 kern.warn kernel: [33668.753798] x8 : 0000000000000000 x7 : 0000000000000000 x6 : 0000000000000000
Thu Apr 11 05:13:04 2024 kern.warn kernel: [33668.754468] x5 : 0000ffffbc765000 x4 : ffff000002539880 x3 : 0000000000000058
Thu Apr 11 05:13:04 2024 kern.warn kernel: [33668.755140] x2 : 0000000000000000 x1 : 000000000504df01 x0 : 5800400000000000
Thu Apr 11 05:13:04 2024 kern.warn kernel: [33668.755814] Call trace:
Thu Apr 11 05:13:04 2024 kern.warn kernel: [33668.756049]  0xffff8000081c0e2c
Thu Apr 11 05:13:04 2024 kern.warn kernel: [33668.756349]  0xffff800008039168
Thu Apr 11 05:13:04 2024 kern.warn kernel: [33668.756649]  0xffff80000818a754
Thu Apr 11 05:13:04 2024 kern.warn kernel: [33668.756948]  0xffff80000818ab5c
Thu Apr 11 05:13:04 2024 kern.warn kernel: [33668.757248]  0xffff80000818adc0
Thu Apr 11 05:13:04 2024 kern.warn kernel: [33668.757546]  0xffff80000818ae80
Thu Apr 11 05:13:04 2024 kern.warn kernel: [33668.757846]  0xffff8000080238b0
Thu Apr 11 05:13:04 2024 kern.warn kernel: [33668.758144]  0xffff8000080239a0
Thu Apr 11 05:13:04 2024 kern.warn kernel: [33668.758442]  0xffff8000088b7fd8
Thu Apr 11 05:13:04 2024 kern.warn kernel: [33668.758742]  0xffff8000088b8de8
Thu Apr 11 05:13:04 2024 kern.warn kernel: [33668.759040]  0xffff8000080115f4
Thu Apr 11 05:13:04 2024 kern.emerg kernel: [33668.759348] Code: f9405eb3 8b0302c0 b9401322 dac00c00 (f8636ac3)
Thu Apr 11 05:13:04 2024 kern.warn kernel: [33668.759913] ---[ end trace b59c614518f71d81 ]---
Thu Apr 11 05:13:18 2024 kern.alert kernel: [33683.021038] Unable to handle kernel access to user memory outside uaccess routines at virtual address 0000000000400058
Thu Apr 11 05:13:18 2024 kern.alert kernel: [33683.022081] Mem abort info:
Thu Apr 11 05:13:18 2024 kern.alert kernel: [33683.022337]   ESR = 0x0000000096000004
Thu Apr 11 05:13:18 2024 kern.alert kernel: [33683.022673]   EC = 0x25: DABT (current EL), IL = 32 bits
Thu Apr 11 05:13:18 2024 kern.alert kernel: [33683.023147]   SET = 0, FnV = 0
Thu Apr 11 05:13:18 2024 kern.alert kernel: [33683.023422]   EA = 0, S1PTW = 0
Thu Apr 11 05:13:18 2024 kern.alert kernel: [33683.023703]   FSC = 0x04: level 0 translation fault
Thu Apr 11 05:13:18 2024 kern.alert kernel: [33683.024137] Data abort info:
Thu Apr 11 05:13:18 2024 kern.alert kernel: [33683.024395]   ISV = 0, ISS = 0x00000004
Thu Apr 11 05:13:18 2024 kern.alert kernel: [33683.024737]   CM = 0, WnR = 0
Thu Apr 11 05:13:18 2024 kern.alert kernel: [33683.025005] user pgtable: 4k pages, 48-bit VAs, pgdp=00000000057bf000
Thu Apr 11 05:13:18 2024 kern.alert kernel: [33683.025578] [0000000000400058] pgd=0800000002e60003, p4d=0800000002e60003, pud=0800000005e63003, pmd=0800000005587003, pte=00200000f1f02fc3

On the R4S page in the device table, it says "Supported Current Release - [23.05.0]"

Does that mean I should only be using that specific release and not the latest stable 23.05.3?

No, it just means the wiki hasn't been updated yet.