Quirks/Oddities you will encounter with Asus RT-AX53U

Ideally you would not run iperf on your networking hardware, it needs to sit in between your client and another device running iperf.


Some testing numbers...

Both RT-AX53U routers (ASUSWRT and OpenWrt) are set as dumb access points.

ThinkPad L520 (LAN) <=> RT-AX53U <=> iPhone XS (WLAN)

iPhone XS wireless capability is...
=> 5 GHz 802.11ac; 2x2 @ 80 MHz = 866 Mbps
=> 2.4 GHz 802.11n; 2x2 @ 20 MHz = 144 Mbps

OpenSpeedTest running on ThinkPad laptop connected to RT-AX53U LAN port at 1 Gbps.
(ThinkPad is running on latest release of Windows 10 Professional).

FIRMWARE: OpenWrt 22.03.2

I ran the test 10 times and averaged the download and upload speeds.

1 metre from router

2.4Ghz = DL: 110.6 Mbps = UP: 107.1 Mbps = Ping: 4
5.0Ghz = DL: 674.1 Mbps = UP: 617.3 Mbps = Ping: 4
2.4Ghz = DL: 84.3 Mbps = UP: 116.0 Mbps = Ping: 5
5.0Ghz = DL: 622.3 Mbps = UP: 610.2 Mbps = Ping: 5

This is North-South orientation...8m from router (2 wooden walls in between)

2.4Ghz = DL: 89.2 Mbps = UP: 97.0 Mbps = Ping: 5
5.0Ghz = DL: 363.0 Mbps = UP: 400.8 Mbps = Ping: 5
2.4Ghz = DL: 73.1 Mbps = UP: 89.9 Mbps = Ping: 5
5.0Ghz = DL: 334.8 Mbps = UP: 388.5 Mbps = Ping: 6

This is East-West orientation...8m from router (3 wooden walls in between)

2.4Ghz = DL: 92.7 Mbps = UP: 89.3 Mbps = Ping: 5
5.0Ghz = DL: 138.8 Mbps = UP: 170.6 Mbps = Ping: 6
2.4Ghz = DL: 67.8 Mbps = UP: 79.9 Mbps = Ping: 5
5.0Ghz = DL: 132.8 Mbps = UP: 141.1 Mbps = Ping: 5

12m from router (4 wooden walls in between)

2.4Ghz = DL: 25.2 Mbps = UP: 11.7 Mbps = Ping: 6
5.0Ghz = NO SIGNAL!
2.4Ghz = DL: 33.8 Mbps = UP: 19.3 Mbps = Ping: 6
5.0Ghz = NO SIGNAL!

I hope this gives people a rough idea on performance with Wifi 5 client.

It was pretty straightforward. Took me less than 10 minutes to do.

What I did was plug the router (LAN 1) into the switch of my network and set a laptop to accept DHCP. Then open up a web browser and typed in router.asus.com ; then follow the guide.

I set it to operate as access point with static IP address, then entered the SSID and Wifi password. After that, I added username and password to the router.

I enabled SSH via Port 22 on the LAN side. => Administration => System => Scroll down to Service section => For Enable SSH , I select LAN only => For SSH Port , I left it as port 22

I install an SSH client (like Putty) on my laptop to login to the router. Type in the LAN IP address of the router and port 22. Login and password credentials are the same as you login into the router via web browser.

Follow the rest of the instructions on the OpenWrt wiki page for RT-AX53U. (You don't need to follow the installation of LUCI part, as the factory image comes with LUCI GUI already.)

Don't rush it or be impatient. Give it time when you write the OpenWrt image to the router. Then run reboot command. If it gets stuck, just power off, wait a few seconds. Then power it back on. After that, OpenWrt should be on there and the default IP address (login via web browser) is ...That's it. Set it up as a dumb access point and you're done.

1 Like

I did some iperf3 tests to look at wireless performance...

The setup is...I've already flashed one AX53U to OpenWrt, while leaving the other as stock (updated to the latest ASUSWRT release). I then configured the OpenWrt one as a wireless client and connected to LAN port (to desktop PC). The ASUSWRT one is configured as a dumb access point.

I ran iperf3 with 4 streams for 60 seconds...

Client (OpenWrt) and AP (ASUSWRT)

2.4Ghz AX
=> 248 to 269 Mbit/s
=> 310 to 335 Mbit/s (Reverse Mode)        

5Ghz AX
=> 382 to 442 Mbit/s
=> 501 to 583 Mbit/s (Reverse Mode)

I then flashed the 2nd one to OpenWrt..Then tested again...

Client (OpenWrt) and AP (OpenWrt)

2.4Ghz AX
=> 319 to 348 Mbit/s
=> 366 to 368 Mbit/s (Reverse Mode)

5Ghz AX
=> 377 to 411 Mbit/s
=> 496 to 553 Mbit/s (Reverse Mode)

It looks like the ASUSWRT is slightly faster on 5GHz band, while slower on 2.4GHz.

Out of curiosity, I tested my old AP setup (TP-Link Archer C5) against the new one (RT-AX53U). All using OpenWrt.

Client = RT-AX53U (AX1800)
AP = Archer C5 (AC1200)

1 Stream => 100 Mbit/s
28 Streams => 116 Mbit/s
1 Stream => 253 Mbit/s
28 Streams => 287 Mbit/s


Client = RT-AX53U (AX1800)
AP = RT-AX53U (AX1800)

1 Stream => 198 Mbit/s
28 Streams => 289 Mbit/s
1 Stream => 279 Mbit/s
28 Streams => 430 Mbit/s

I used 28 streams because that is the limit of the Archer C5. The AX53U can handle up to 32 streams. (Each stream is about 14 to 18 Mbit/s).

Another interesting "quirk" I've noticed with the stock ASUSWRT firmware while testing; regarding wireless performance...

Sometimes it suddenly drops speed or stops for a second, but then regains speed moments later. (It looks like some feature in the stock firmware is causing this).

I'm not the only one experiencing this behaviour, this review article indicates the same...
=> https://www.mbreviews.com/asus-rt-ax53u-wifi-6-router-review/
(They have a chart showing their tests for an hour, and there are sudden dips in wireless performance.)

This behaviour does not happen with OpenWrt firmware. The wireless performance remains consistent. No drops in speed when I ran iperf3 for over an hour.

Finally...with the stock firmware, NAT Acceleration is enabled by default. With OpenWrt, be sure to enable Software flow offloading and Hardware flow offloading. (All tests had these enabled by default).

...Think I'll test wired performance next. (NAT, Software/Hardware flow offloading on and off, etc)

Have to correct myself here...It's actually up to 30 streams.

I did lots of testing with iperf3 and used "top" (viewed via SSH) to see CPU usage.

I found an interesting "quirk" of this router in relation to enabling Hardware flow offloading under OpenWrt.

When enabled, this router cannot handle more than 7 simultaneous streams when you use Wifi 2.4GHz band, 5Ghz band, and LAN (cable) all at the same time.

For example:

Wifi 2.4GHz band => 2 streams
Wifi 5Ghz band => 2 streams
LAN (wired) => 3 streams

...Any more will cause the router to drop additional connections.

This does not happen when you just have Software flow offloading enabled or disabled. Under this scenario (simultaneous streams), you can have the following (maximum)...

Wifi 2.4GHz band => 10 streams
Wifi 5Ghz band => 10 streams
LAN (wired) => 10 streams

I noticed this behaviour because I previously tested the LAN side (wired and wireless) individually. So it had no trouble doing 30 parallel streams with Hardware flow offloading enabled...It is when you throw all three (wired and 2.4Ghz/5Ghz wireless LAN connections) into the mix, does this router max out at 7 simultaneous streams.

This could explain why the stock ASUSWRT mysteriously drops to lower speeds, then suddenly jumps back during testing. (NAT acceleration is enabled by default).

So what's the recommendation?

If you're going to use this as a wireless router or dumb access point with OpenWrt, then have:
Software Flow Offloading = ON
Hardware Flow Offloading = OFF

If you're using it this as a pure wired router (1Gb/s connection)
Software Flow Offloading = ON
Hardware Flow Offloading = ON
...The max wired speed is about 910 Mbps down and 850 Mbps up.

With SQM (cake) enabled and Software and Hardware flow offloading disabled; the router maxes out at 200 to 250 Mbps in wired speeds...Which is similar to Edgerouter X. (As they use the same CPU).

Overall conclusion?

If you use this purely as a budget wireless router, its suitable for up to 100 to 200 Mbps Internet plans.

For best performance, use this as a cheap Wifi 6 dumb access point and a low-powered x86-based system for wired routing role. (Suitable for up to 300 to 400 Mbps Internet plans.)

If you want 1Gbit/s wired/wireless performance, this wireless router will not meet your needs. Look at other options.

1 Like

In Australia, there's another model called RT-AX54HP (It's called something else in other regions). In terms of specifications, it is very similar to the RT-AX53U, except it does not have the USB connector and has 4 LAN connections instead of 3 LAN. (Looking through the ASUS GPL source code for that model, it seems to be based on the same Mediatek hardware as RT-AX53U)...Maybe a future addition to the OpenWrt table of hardware? :wink:

hey @stmok

i am getting openwrt working on ax54 (ax54hp , ax1800 S/HP)

ax53u firmwere on ax54hp ( kind of)

1 Like

Pls retest with master (so called snapshot version), where this patch landed months ago:

I'm curious whether this patch improves the situation.
Also of note: master has all LEDs working by now thanks to the work of @znevna :slight_smile:

Master comes without LuCI preinstalled, follow instructions 1 and 2 if you require LuCI:

Also of note: master has all LEDs working by now thanks to the work of @znevna :slight_smile:

the wifi 5g/2g led dont work

They should as of two days ago https://github.com/openwrt/openwrt/commit/521efb62ebb55dcc67dc618757aa2e3ccbdf3774

I've tried the following snapshot...

Version: SNAPSHOT (r21968-acd8e94d20)
Date: 2023-02-02 21:01:23

=> LEDs for network ports (LAN and WAN), as well as 2.4Ghz and 5Ghz Wifi are now working!

Upon further testing of SNAPSHOT release...

I've noticed the stock settings for the WIFI 2.4GHz LED is constantly flashing (continuously at regular intervals); even when it's supposed to be idle.

To correct the issue (in LUCI), you need to change the behaviour of that particular LED...

"System" (top menu) => "LED Configuration"
See "WIFI 2.4GHz" and click on "EDIT" button.
Set "Trigger" to "Network device activity" (kernel: netdev)
Set "Device" to Wireless 2.4 Ghz => "phy0-ap0"
Set "Trigger Mode" to enable "Link On", "Transmit", and "Receive"
Click "Save"
Click "Save & Apply"

And now it behaves as it should.

This isn't an issue with "WIFI 5GHz" LED. The network port LEDs (LAN and WAN) behave normally.

Haven't fully tested activity USB LED yet. Just did a quick plug and unplug to see if the LED will come on when plugged into router.

2.4Ghz and 5Ghz Wifi are now working on ax54 too

LEDs for network ports (LAN and WAN) work on ax54 but the way they work is bit funky.

Are you using the official release (22.03.3) OR snapshot release (r21968-acd8e94d20)?

i builded my own firmware for ax54


1 Like

WiFi is never idle, beacons are always transmitted.
Behaviour of the LEDs is pretty normal with the default settings (what I've set in config is used even if you don't set anything, and I've defined them with the defaults).


I did some testing...Yes it does!

The following two tests have...

Software Flow Offloading = ON
Hardware Flow Offloading = ON

OpenWrt 22.03.2 Release
=> Router cannot handle more than 7 simultaneous streams when you use Wifi 2.4GHz band, 5Ghz band, and LAN (cable) all at the same time.


Snapshot Release (r21968-acd8e94d20)
=> Router can now handle...

Wifi 2.4GHz band => 30 streams MAX
Wifi 5Ghz band => 30 streams MAX
LAN (wired) => 30 streams MAX

...all at the same time! No drop out!

"TOP" indicates router's CPU is at 22% idle under this testing scenario.


Oh, OK then.

Looks like the LED issue has largely been solved for this router.

Thanks for the post about this, and for getting this into a great supported device!

I also got this last year in AU ;).

As you noted, the stock UI is incredibly slow, I have no idea what they are doing, I bet it's the HTTPS or something having weird issues.

I tried to flash straight to the snapshot build, but that didn't work for some reason (it just rebooted right back into the stock AsusUI).

Instead, what I ended up doing was using the 22.03.3 build, then performed a sysupgrade to snapshot r22040-eeba2a67ca via luci.

Once the upgrade was complete, it also wiped to factory settings, so I had to install luci via SSH.

Everything seems to work great for my use case, I haven't tested the LED lights/USB (as I have no use for them). Snappy as, happy as always with OpenWRT.

Kia ora joshx1 and stmok,

I'm pretty flipping new to using OpenWRT... very new in fact.

I'm wanting to flash OpenWRT on my new ASUS RT-AX54HP, and am wondering where I can get hold of the snapshot r21968-acd8e94d20 mentioned above -- or maybe the snapshot r22040-eeba2a67ca? More than happy for you to assume I've not looked in the correct place :grimacing:

Many thanks,

OpenWRT is pretty straight forward now adays, much less confusing than the stock standard mess of a UI Asus has anyway :).

  1. Go to https://firmware-selector.openwrt.org/?version=SNAPSHOT&target=ramips%2Fmt7621&id=asus_rt-ax54 and search for RT-AX54HP , download the second image (Factory)

  2. Then you want to follow along with these instructions https://openwrt.org/toh/asus/rt-ax53u

The main difference if you're new to tech/openwrt/linux is that you'll need to use a terminal for this. If you use Windows, you can use Putty, which is a free tool.