Question for Filesystem and 5Ghz on tplink archer c6 v3.2

Hi there! New to the forum but long time user of OpenWRT.
So i've just bought a tplink archer c6 v3.2 and it has arrived yesterday. The first thing that i've done was install the openwrt upgrade package, and it's working like a charm.
I have encountered 2 problems during the usage:

  1. why the router see an 8Mb filesystem if the internal flash of this device is 16Mb? Is there a way to expand the filesystem?

  2. Can I create an AP in 2,4Ghz and 5Ghz with the same SSID so that the devices can use them also in concurrency?

  1. Concurrent use of bands is only possible with WiFi 7. This device and OpenWrt, for that matter, don’t support it.
1 Like
  1. The OEM partitioning gives you 16'121'856 (so just 640 KB 'lost' to bootloader and the various device specific data partitions). However, the default release images for OpenWrt on mt7621 weigh around 6.8 MB, which means you're left with roundabout 8 MB free space at your disposal.
  2. yes.
    This router ships with two radios (MT7603EN+MT7613BEN, the later not being a good choice, but it's present nevertheless), you can configure both of them with the same access credentials for your clients to roam freely between them (qunvureze seems to refer to MLO, which is something different (and indeed a wifi7 feature), allowing a client to merge- and use both bands at the same time - which doesn't appear to be the question at hand).
1 Like

Ok for the point 1 I’ve learned something new

For the point 2 I settled up on the 2 radios the same SSID but all devices just use the 2.4ghz radio. They don’t want to use the 5ghz unless I disable the 2.4 radio

TY to everyone :v::v:

FWIW, your dual-band capable devices will select the band that provides the best performance based on a number of variables and logic... so devices don't always connect to 5G just because it's there. But obviously they should be able to connect at least some of the time.

Let's see the config:

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
1 Like

Hi psherman, here is the device informations

{
	"kernel": "5.15.134",
	"hostname": "Qul0Wrt",
	"system": "MediaTek MT7621 ver:1 eco:3",
	"model": "TP-Link Archer C6 v3",
	"board_name": "tplink,archer-c6-v3",
	"rootfs_type": "squashfs",
	"release": {
		"distribution": "OpenWrt",
		"version": "23.05.0",
		"revision": "r23497-6637af95aa",
		"target": "ramips/mt7621",
		"description": "OpenWrt 23.05.0 r23497-6637af95aa"
	}
}

and here is the network config

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd92:df77:9c62::/48'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ip6assign '60'
	list ipaddr '192.168.42.1/24'
	list dns '1.1.1.1'
	list dns '8.8.8.8'

config interface 'wan'
	option device 'wan.835'
	option proto 'pppoe'
	option username 'XXXXXXX'
	option password 'XXXXXXX'
	option ipv6 '0'
	option force_link '1'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'

config device
	option type '8021q'
	option ifname 'wan'
	option vid '835'
	option name 'wan.835'

config device
	option type 'bridge'
	option name 'br-IoT'
	list ports 'lan4'
	option mtu '1500'
	option macaddr 'XXXXXXXXX'

config interface 'IoT'
	option proto 'none'
	option device 'lan4'

and here is the wireless config

config wifi-device 'radio0'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option channel 'auto'
	option band '2g'
	option htmode 'HT40'
	option cell_density '0'

config wifi-device 'radio1'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
	option channel 'auto'
	option band '5g'
	option htmode 'VHT160'
	option cell_density '0'
	option disabled '1'

config wifi-iface 'wifinet0'
	option device 'radio0'
	option mode 'ap'
	option ssid 'XXXX'
	option encryption 'psk2'
	option key 'XXXXXXXX'
	option network 'lan'
	option disabled '1'

config wifi-iface 'wifinet1'
	option device 'radio1'
	option mode 'ap'
	option ssid 'XXXXX'
	option encryption 'psk2'
	option key 'XXXXXX'
	option network 'lan'
	option disabled '1'

config wifi-iface 'wifinet2'
	option device 'radio0'
	option mode 'ap'
	option ssid 'XXXXX'
	option encryption 'psk2'
	option key 'XXXXXXXX'
	option network 'lan'
	option ieee80211r '1'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'

config wifi-iface 'wifinet4'
	option device 'radio1'
	option mode 'ap'
	option ssid 'SSID: XXXXX'
	option encryption 'psk2'
	option key 'XXXXXXXXX'
	option ieee80211r '1'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'
	option disabled '1'

I see that you are running v23.05.0 and use VHT160 for the 5-GHz wifi. What may happen is that the performance on that frequency is bad enough that devices switch to 2.4-GHz instead.

My assumption is based on this thread (which ofc compares ac to ax but might have merit): [Solved] 802.11ax worse than 802.11ac with mt76 driver? - #443 by Anteus

You could try to change the frequency away from VHT160 and check if anything changes. Or you could upgrade to a snapshot, since the issues seem to have been fixed since August. If I read the latest posts in v23.05.2 release thread correctly there'll be a v23.05.3 release shortly, which would enable you to stick with VHT160 after upgrading, too.

1 Like

I agree with @Nihilokrat 's statements.

Other things to do:

  1. Make sure you set your country code.
  2. In addition to reducing the channel width, make sure you are setting the channel manually and avoiding DFS channels. In many places, 160MHz channel width will cause DFS overlap except in the highest channel range. You should avoid DFS and use either 40 or 80MHz channels. (DFS causes the radio to delay coming up and will go down whenever it detects a radar hit)
  3. remove all of the 802.11r related stuff entirely. You can add that in again if you need it to improve roaming (that of course requires multiple APs, but they should be tuned for optimal traditional roaming first).
  4. Make sure you've actually enabled the radio and SSID on the 5G band (currently it appears they are disabled).
2 Likes

@psherman @Nihilokrat ok i've modified some settings

the 5ghz radio works at 80mhz and the led on the router is now on
i've also deactivated the 802,11r. Is that more useful with multiple AP's? I don't need more than this AP at home

Now i'm checking all my devices with the 5ghz radio, for now no one has connected to this radio

It is only useful if you have multiple APs.

The clients need to make their own decision about which band to use. Hopefully they will move over to the 5G band when the conditions are right.

1 Like

Ok! i'm seeing some devices (principally apple) that are switching to the 5ghz wireless automatically!

Thank you so much guys, i was thinking about an hardware issue of the router because is brand new...

I'm checking the solution, but I think that I may need some more advices to configure it in the future!

Have a nice day guys, cheers from italy!

1 Like

@Nihilokrat 23.05.2 installed, i'm going to try some wifi performance tonight (i have 2,5G fiber at home).

Do you have more hints on how to have more performance with this board? I don't need amazing wifi speed but i want to reach almost gigabit in LAN and also to have stability.

I'm going to create some VLAN's, and another 2,4G ap for the IoT, then i'm going to install an adblocker and if you have hints on more services that i can use!

Well, there is this thread that might help with increasing the performance: 2 Gbps WAN/LAN NAT Routing on ramips MT7621 devices

Since my usecase is set on Wireguard for all clients, those high-level performance settings/tweaks don't fall into my work with this device.

The "special" stuff I am running is basically a self written policy-based-routing for streaming, a timeclock feature for the wifi and that's it.

1 Like

Oh thanks i'm going to read this post!

I've tried some cli speedtests and in wifi this router would not go over 300mbit (up and down), but in LuCI in shows that it's connected with the devices in 866mbit

That number is for the connection speed from the devices to the router. It can be significantly higher than the maximum throughput your router is capable of when sending data via WAN to the next point of routing.

1 Like

So it can be a real thing that this router is not well optimized with openwrt? Because the router is advertised for 1gbit ftth/fttb.

This evening i'm going to do some testing connected with the cable.
Don't get me wrong, 350mbps in in wifi is enough for my needs, but I was wondering how much can openwrt impact on the real performance of this boards vs the stock firmware

I've checked this topic, my device is on the list of "device that can't benefit this" so i think that this guide can't help me

OEM firmware can use hardware flow offloading, which OpenWrt can't. To be honest, I never go by maximum throughput, etc. I only check CPU power and compare it to the CPUs inside Archer C7 and Archer C6v3/Ax23v1 to decide on the usability in my case. The bandwidth when using Wireguard (e.g. ~140 Mbps with C6v3) is considerable low enough to not care about GB throughput at all.

1 Like

Ok clear, i'm not going to use wireguard for now. Thank you for all the advices!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.