Quectel RM520N-GL T-Mobile connection problems

Hello all,
This isn't an OpenWRT issues I don't think, but I'm trying to do this on OpenWRT and hoping maybe someone here has the expertise to help me figure out my problem.

Let me preface this by saying, I really don't know what I'm doing here :stuck_out_tongue: I'm attempting to get something to work, and don't really understand all the ins and outs of it. I have some networking knowledge and quite a bit about IT in general, but very little low level knowledge about how these cellular modems work and are configured. I don't know if what I'm trying to do is even possible. I cannot find any posts on the internet with someone doing specifically this, but there are things that seem similar enough that I think it should work?

So anyway, what I've got.
Banana Pi R4
OpenWRT version r26504
Quectel RM520N-GL 5G Cellular modem
T-Mobile sim card

Now the T-Mobile sim card is just a standard sim card they gave me at the store. We recently started a new T-Mobile account and they had a special where we got a 3rd line for free with the 2 new lines. So, I figured, hey maybe I can just take that 3rd line and throw it in a my router as a backup WAN at home. The plan for the SIM card is their current NEXT plan that has 50 GB of 5G hotspot data available. I didn't know if doing this would use hotspot data or not, but I figured as a backup if it just acted as and used hotspot data that would be fine. If I take this same sim card and put it in a 5g hotspot device I have it connects and works fine using some of the 50 GB of hotspot data. And if I put the sim in a phone it also works fine and does not use the hotspot data for data transferred on the phone. I can use PDANet on the phone as well to hotspot without using hotspot data because it does something to look like the data is coming from the phone itself I guess.

I have installed a LOT of packages trying to get this thing to work. Pretty much all the QMI and all the MBIM stuff. The furthest I have gotten has been using the QMI packages. I added an interface to using QM Cellular protocol. Configured it to use fast.t-mobile.com (also tried epc.tmobile.com and internet as I've seen those referenced elsewhere) as the APN and IPV6 Only. I had tried IPV4 only but it wouldn't ever get an IP address. With IPV6 only it does get an IP address, and each time I restart the interface I receive exactly 2 packets and that is it. There are lots of TX packets going out. I'm assuming this is probably it attempting to connect, or maybe the MultiWAN Manager trying to send out pings to test if it's up or not.

After receiving those 2 packets, I get nothing else out of the interface.

I'm guessing this is part of the problem:

:~# uqmi -d /dev/cdc-wdm0 --get-current-settings
"Out of call"

but I'm no really sure where to go from there. I can't figure out where I can even see messages to maybe see why it's failing to connect. I don't see anything relevant to the connection itself in dmesg.

This output also looks concerning to me, with both the "unknown" network and 0 data service capabilities. But maybe that is normal before a connection is established?

:~# qmicli -d /dev/cdc-wdm0 --nas-get-serving-system
[/dev/cdc-wdm0] Successfully got serving system:
	Registration state: 'registered'
	CS: 'detached'
	PS: 'attached'
	Selected network: 'unknown'
	Radio interfaces: '1'
		[0]: '5gnr'
	Roaming status: 'off'
	Data service capabilities: '0'
	Current PLMN:
		MCC: '310'
		MNC: '260'
		Description: 'T-Mobile'
	Roaming indicators: '1'
		[0]: 'off' (5gnr)
	Detailed status:
		Status: 'available'
		Capability: 'ps'
		HDR Status: 'none'
		HDR Hybrid: 'no'
		Forbidden: 'no'
	Full operator code info:
		MCC: '310'
		MNC: '260'
		MNC with PCS digit: 'yes'

I'm not sure what other commands I might could run to show relevant information. So, maybe if someone might have an idea of what is wrong or knows what they are doing with this thing, tell me what to run?

Or is this just not even possible with an over the counter sim card?

Any advice / help would be much appreciated!

Get openwrt stable release, install luco qmi component and you will be set in no time.

Hmm by stable release do you mean not the snapshot that I'm on? I don't know that there is a stable release for the Banana Pi R4 yet =/ if I got to firmware-selector.openwrt.org and serach for bpi-r4 it only shows up under the SNAPSHOT option, not any of the versioned releases.

But are you saying what I have for sure should work (the sim card and plan type and all)? Would something get removed in a new SNAPSHOT version that enabled this to work in the previous stable version or something?

At least install luci and do the normal things.

Luci is installed sorry I should have mentioned when I added the interface it was through the Luci web ui... and the "normal things" no idea what you mean there. Everything is configured except for this modem connection.

@ steven6282 Are you able to manage the 5G connection (band selection/aggregation and any sort of stuff) through OpenWrt?
Because I want to build my own 5G router, maybe using Mini PC, mini-ITX or similars due to an easier expandibility, but seems to be there are limitations.
I didn't though to Raspberry, Banana etc. If there is more support, then I could add these to the list of candidates.
How much did you paid the module? I have been told is very expensive.

SNAPSHOT is always a bit risky to use, as there might be temp issues, because it is mor or les a development version. In your case, for very recently supported hardware, this is even a bit more risky. Anyway, you have no choice.

So, I was able to confirm the modem and sim card themselves do work. I had gotten the 5G card with a kit that included a raspberry pi hat. I figured in case I wanted to play around with it on one of my Pi's, but my primary goal is / was to set it up on the banana pi router. So I took I took the time to set it up on a raspberry pi and it was working in less than 5 minutes =/

The only difference that I can find is the guide that I followed for it had me configure the 5g card in ECM instead of QMI ("usbnet",1). But yeah, given that, it worked no problems and I was definitely getting 5G UC speeds (250 Mbps down with pretty weak antennas not properly position. I was planning on installing an external antenna and pointing it at the nearest tower properly if this all worked.)

So, now I got to figure out what I'm doing wrong on OpenWRT for it not to work there =/

So yeah, something I had done was causing problems. No idea what. I reset the system back to default settings. Then just did some basic stuff to configure my network. Went and added a qmi celluar interface and that was it, started working no problems. Getting 600 Mbps+ download speeds this time haha.

Unfortunately, it does seem to count this data as hotspot data. Was kind of hoping it would look at it as just cellular data. But 50 gb should be enough for a temporary backup if the main line is down I suppose.

Could you share the purchase link or at least tell me how much you paid for all?
600 Mbps+ completely indoor with weak antennas is a very good result (NSA or SA mode?). You should put antennas (and very good quality ones) on the roof and see how much you can achieve.
A seller told me that it is hard to get good speed with OpenWrt because it lacks Hw-nat and recommended x-wrt. I don't know if this statement is true, but have you checked with this firmware?
Have you checked that OpenWrt has aggregated all the suitable bands?
The 5G module you're using is not the latest and faster ones, but it can still provide 3.4Gbps download speed, as long as all the parameters are satisfied (distance, ISP bands, proper settings etc).

Honestly I don't know much about cellluar stuff :stuck_out_tongue: I can't even tell you if it's NSA or SA mode =P The cellular card I was using came from amazon https://www.amazon.com/dp/B0C2V5TL3Z?psc=1 $280 atm, but when I purchased it a couple of weeks ago it was only $230, not sure why the price difference.

$230 is not bad although I'm not sure if that extensive module itself is an overkill, at least in my country where maximum achievable speed is 1Gbps.
Let us know how much speed you can achieve outdoor on the roof (in the highest position you can place it) and with good quality antennas.

Have you try use others firmware such as R00ter, immortalwrt, x-wrt & etc?

1 Like

I also suggested the same just as quick way to see what firmware performs better. However now seems that he fixed the issues and he is getting 600Mbps+ in download with OpenWrt and this is very good. I'm curious to see how much he can reach outdoor with good antennas!

1 Like