Quectel EC25 not on in CF-E5

I am using Comfast CF-E5, the vendor firmware is a fork of OpenWrt. I have updated the firmware to OpenWrt 19.07.2. The LTE module is not detected in dmesg and lsusb. Need help in enabling the Quectel EC25.

yes, i don't kown why by default openwrt have nothing installed on this device for lte side.
long time not playing with that device, so that's the only think i can say.

Thanks @bricco1981. I am just curious, if you know any setting to detect the LTE module. I followed https://openwrt.org/docs/guide-user/network/wan/wwan/ltedongle to install all the required packages. As, the device is not detected (not sure powered on) via usb. I don't see the device with /dev/cdc-wdm0. Let me know, if you have came across any such issue.

check this discussion Help installing EC25 Drivers

@AndrewZ, I followed the link shared by you. And my current GPIO's are

root@COMFAST:~# cat /sys/kernel/debug/gpio
gpiochip0: GPIOs 0-31, parent: platform/18040000.gpio, 18040000.gpio:
 gpio-0   (                    |cf-e5:blue:wlan     ) out lo
 gpio-2   (                    |cf-e5:blue:rssi0    ) out hi
 gpio-3   (                    |cf-e5:blue:rssi1    ) out hi
 gpio-4   (                    |cf-e5:blue:wan      ) out hi
 gpio-11  (                    |sysfs               ) out hi
 gpio-14  (                    |sysfs               ) out hi
 gpio-15  (                    |cf-e5:blue:rssi2    ) out hi
 gpio-16  (                    |cf-e5:blue:lan      ) out hi
 gpio-17  (                    |reset               ) in  hi
root@COMFAST:~# cat /sys/kernel/debug/usb/devices

T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480  MxCh= 1
B:  Alloc=  0/800 us ( 0%), #Int=  0, #Iso=  0
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=1d6b ProdID=0002 Rev= 4.14
S:  Manufacturer=Linux 4.14.171 ehci_hcd
S:  Product=EHCI Host Controller
S:  SerialNumber=1b000000.usb
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=  0mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   4 Ivl=256ms

Also, noticed there is proper /etc/board.d/03_gpio_switches

root@COMFAST:~# cat /etc/board.d/03_gpio_switches
#!/bin/sh
#
# Copyright (C) 2018 OpenWrt.org
#

. /lib/functions/uci-defaults.sh

board_config_update

board=$(board_name)

case "$board" in
comfast,cf-e5)
        ucidef_add_gpio_switch "lte_power" "LTE Power" "14" "1"
        ucidef_add_gpio_switch "lte_wakeup" "LTE Wakeup" "11" "1"
        ucidef_add_gpio_switch "lte_poweroff" "LTE Poweroff" "1" "1"
        ucidef_add_gpio_switch "lte_reset" "LTE Reset" "12" "1"
        ;;
# **** Truncated for Post
esac

board_config_flush

exit 0

There is /etc/board.json available too

root@COMFAST:~# cat /etc/board.json
{
        "model": {
                "id": "comfast,cf-e5",
                "name": "COMFAST CF-E5/E7"
        },
        "led": {
                "lan": {
                        "name": "LAN",
                        "sysfs": "cf-e5:blue:lan",
                        "trigger": "switch0",
                        "type": "switch",
                        "mode": "",
                        "port_mask": "0x02",
                        "speed_mask": ""
                },
                "wan": {
                        "name": "WAN",
                        "sysfs": "cf-e5:blue:wan",
                        "type": "netdev",
                        "device": "eth1",
                        "mode": "link tx rx"
                },
                "rssilow": {
                        "name": "",
                        "sysfs": "cf-e5:blue:rssi0",
                        "type": "rssi",
                        "iface": "wlan0",
                        "minq": "1",
                        "maxq": "100",
                        "offset": "0",
                        "factor": "1"
                },
                "rssimedium": {
                        "name": "",
                        "sysfs": "cf-e5:blue:rssi1",
                        "type": "rssi",
                        "iface": "wlan0",
                        "minq": "33",
                        "maxq": "100",
                        "offset": "0",
                        "factor": "1"
                },
                "rssihigh": {
                        "name": "",
                        "sysfs": "cf-e5:blue:rssi2",
                        "type": "rssi",
                        "iface": "wlan0",
                        "minq": "66",
                        "maxq": "100",
                        "offset": "0",
                        "factor": "1"
                }
        },
        "rssimon": {
                "wlan0": {
                        "refresh": 200000,
                        "threshold": 1
                }
        },
        "network": {
                "lan": {
                        "ifname": "eth0",
                        "protocol": "static"
                },
                "wan": {
                        "ifname": "eth1",
                        "protocol": "dhcp"
                }
        },
        "gpioswitch": {
                "lte_power": {
                        "name": "LTE Power",
                        "pin": 14,
                        "default": 1
                },
                "lte_wakeup": {
                        "name": "LTE Wakeup",
                        "pin": 11,
                        "default": 1
                },
                "lte_poweroff": {
                        "name": "LTE Poweroff",
                        "pin": 1,
                        "default": 1
                },
                "lte_reset": {
                        "name": "LTE Reset",
                        "pin": 12,
                        "default": 1
                }
        }
}

And, below is the vendor customized OpenWrt output

root@COMFAST:/sys/devices/platform/qca953x_wmac/gpio/gpiochip46# cat /sys/kernel/debug/gpio
GPIOs 0-23, ath79:
 gpio-0   (comfast:blue:wlan   ) out lo
 gpio-1   (comfast:blue:4g_powe) out hi
 gpio-2   (comfast:blue:signal1) out lo
 gpio-3   (comfast:blue:signal2) out lo
 gpio-4   (comfast:blue:wan    ) out hi
 gpio-11  (comfast:blue:4g_waku) out hi
 gpio-12  (comfast:blue:4g_rst ) out hi
 gpio-14  (comfast:blue:4g_powe) out hi
 gpio-15  (comfast:blue:signal3) out hi
 gpio-16  (comfast:blue:lan    ) out hi
 gpio-17  (Reset button        ) in  hi

GPIOs 46-63, platform/qca953x_wmac, ath9k-phy0:
 gpio-47  (ath9k-phy0          ) in  lo
root@COMFAST:/etc/rc.d# cat /sys/kernel/debug/usb/devices

T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480  MxCh= 1
B:  Alloc=  0/800 us ( 0%), #Int=  0, #Iso=  0
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=1d6b ProdID=0002 Rev= 3.10
S:  Manufacturer=Linux 3.10.44 ehci_hcd
S:  Product=EHCI Host Controller
S:  SerialNumber=ehci-platform
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=  0mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   4 Ivl=256ms

T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  2 Spd=480  MxCh= 0
D:  Ver= 2.00 Cls=ef(misc ) Sub=02 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=2c7c ProdID=0125 Rev= 3.18
S:  Manufacturer=Android
S:  Product=Android
C:* #Ifs= 5 Cfg#= 1 Atr=a0 MxPwr=500mA
I:* If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
E:  Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:* If#= 1 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=00 Prot=00 Driver=(none)
E:  Ad=83(I) Atr=03(Int.) MxPS=  10 Ivl=32ms
E:  Ad=82(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:* If#= 2 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=00 Prot=00 Driver=(none)
E:  Ad=85(I) Atr=03(Int.) MxPS=  10 Ivl=32ms
E:  Ad=84(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=03(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:* If#= 3 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=00 Prot=00 Driver=(none)
E:  Ad=87(I) Atr=03(Int.) MxPS=  10 Ivl=32ms
E:  Ad=86(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=04(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:* If#= 4 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=qmi_wwan
E:  Ad=89(I) Atr=03(Int.) MxPS=   8 Ivl=32ms
E:  Ad=88(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=05(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms

it looks like your modem is already detected

and is running in QMI mode

The last two outputs are from original firmware detecting the EC25. I did enable GPIO pins 11, 14. Still, the device is not detected/power on.

 cat /sys/kernel/debug/gpio
gpiochip0: GPIOs 0-31, parent: platform/18040000.gpio, 18040000.gpio:
 gpio-0   (                    |cf-e5:blue:wlan     ) out lo
 gpio-2   (                    |cf-e5:blue:rssi0    ) out hi
 gpio-3   (                    |cf-e5:blue:rssi1    ) out hi
 gpio-4   (                    |cf-e5:blue:wan      ) out hi
 gpio-11  (                    |sysfs               ) out hi
 gpio-14  (                    |sysfs               ) out hi
 gpio-15  (                    |cf-e5:blue:rssi2    ) out hi
 gpio-16  (                    |cf-e5:blue:lan      ) out hi
 gpio-17  (                    |reset               ) in  hi

Not sure what exactly mean enable here, but try to manually trigger gpio14 state.

@AndrewZ Where can we find the documentation for GPIO manual trigger

i take it out from the box, and i have installed 19.07.2, and from dmesg i see:

 37.886402] usb 1-1: new high-speed USB device number 2 using ehci-platform
[   38.112510] qmi_wwan 1-1:1.4: cdc-wdm0: USB WDM device
[   38.147881] qmi_wwan 1-1:1.4 wwan0: register 'qmi_wwan' at usb-1b000000.usb-1, WWAN/QMI device, xxxxxxxxx

i have nothink installed for the lte modem, i don't need it now.

@bricco1981 May, I know what command you have used to upgrade. I will retry and share the dmesg. I flashed few times from GUI. Let me try CLI this time. As, the EC25 detected on your device hoping I will also use 19.07.2

are you on stok firmware or openwrt?
from web interface in any case.
if you want try from command

  1. put openwrt-19.07.2-ath79-generic-comfast_cf-e5-squashfs-sysupgrade.bin
    in tmp directory
    2 ssh to the router
    3 cd /tmp
    4 sysupgrade -n openwrt-19.07.2-ath79-generic-comfast_cf-e5-squashfs-sysupgrade.bin

please in any case don't keep setting

1 Like

In the docs: https://openwrt.org/docs/techref/hardware/port.gpio

@bricco1981 I did as per the above command. I couldn't reach 192.168.1.1. Keeping existing setting let me in via 192.168.10.1. I am using POE mode connected my cable in WAN Interface.

don't keep setting, now hold the reset button until it reboot
try again 192.168.1.1
if that not work, please try to change the ethernet cable input, from one port to another
also make sure the problem is not you browser

Able to ping, as I moved POE to LAN interface of CF-E5. Flashing with sysupgrade -n detects the Quectel EC25. For CF-E5, it is recommended to upgrade to OpenWrt via CLI.

Thank you @bricco1981 and @AndrewZ for your valuable time and helping community.

the solution is to hold the reset button after flash operwrt, and change the poe input.
via command line or luci make no difference, but you shoud not keep setting.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.