Qualcommax NSS Build

Your options are the same as mine, minus the engine stuff...

However, I think I know the issue. I forgot that although disabling CONFIG_OPENSSL_ENGINE prevents it from getting compiled, the option for it remains in the final /etc/ssl/openssl.cnf config. I explicitly disabled it in my custom files/etc/ssl/openssl.cnf build folder.

image

That option should really be checked for in the Makefile of openssl, and patched when it packages openssl.cnf, rather than assuming CONFIG_OPENSSL_ENGINE is always enabled.

Anyways, you can enable CONFIG_OPENSSL_ENGINE without having to enable OPENSSL_ENGINE_BUILTIN_DEVCRYPTO. That later is what causes problems with NSS.

1 Like