Qualcomm Fast Path For LEDE


#527

A question.
I need to use USB storage, filesystem format as ext4, vfat..., vftpd server and samba server.
Is needed include this modules at make menuconfig??
kmod-usb-storage and filesystem are at module kernel. Or how I install this?

Regards .


#528

This are a series of patches that are applied prior to building the lede image. You download the patch, apply it with $ patch -p1 < 12XYZ.patch, then you edit your config file via menuconfig and select kmod-fast-path and kmod-shortcut-fe not the one with "cm". That's it, you build your image and fastpath should be baked right in.


#529

Ok, I'm appling gwlim's patch.
But I want to incluide kmod-usb-storage for yo use hard disk connected to USB.
The module kmod-usb-storage is not included in the patch.
Do I need to include this module in menuconfig? Or do I'm installing this module with opkg after ?


#530

I have already understood what you are saying. I apply the gwlim's script before editing the config via menuconfig.
If I understood correctly then I should execute script, make menuconfig and delete the patch folder before to do make V = s.
Prior... hahaha
Thanks.


#531

@dissent1 Can you fix the patches for Kernel 4.14?


#532

First wait until 4.14 support is finished and merged


#533

multiwan3 problem is that the traffic is not load balanced ?
I have it on 1043nd v3 and failover is working but no load balanced, didn't try without fastpath


#534

You may encounter the same problem here.


#535

I followed the instruction to build gwlim a few months but something messed up in my tree that I need to re-do this all over again.

However, when I follow the instruction I can no longer run the ./patch_LEDE.sh successfully. I even tried to checkout branch v17.0.1.3 which is prior to the last update date in Sept and still didnt work and complain about missing wireguard file. The latest version seems to have problem with kernel version.

Can anyone shed some light into this???


#536

Hi.
The same thing happens to me as you.
I am following the gwlim's instructions to build the lede image.
I have problems with the patches when I run ./patch_LEDE.sh :
012-update-kernel-version.patch
066-wireguard-update.patch.
I have removed these two patches from the "patch" folder.

If I do this when I run patch_LEDE.sh it does it without problems.

I add fast_classifier in the make menuconfig, save and exit.

When I run make V = s I get an error when the patch "./target/linux/generic/patches-4.4/895-patch-kernel-support-SFE.patch" is applied. This file is patched in turn by another Gwlim's patch called "895-SFE-support-kernel.patch".

This error was reported by build000 on October 16 in this forum.

My conclusion is that the Gwlim's patch called "895-SFE-support-kernel.patch". is wrong.


#537

Is the pull request for this feature ever going to be merged into the official LEDE builds? It's been ages since that was posted, but there hasn't been an official response on the pull request as of yet.


#538

Given irc banter, probably not. The preferred methodology would appear to be existing kernel.org upstream code; have not gone to try and find the code myself.


#539

Getting error while trying to run the patch_LEDE.sh:

Hunk #1 FAILED at 3.
1 out of 1 hunk FAILED -- saving rejects to file include/kernel-version.mk.rej

Checking the file contents:

luciano@home:~/lede$ cat include/kernel-version.mk.rej
--- include/kernel-version.mk
+++ include/kernel-version.mk
@@ -3,10 +3,10 @@
LINUX_RELEASE?=1

LINUX_VERSION-3.18 = .43
-LINUX_VERSION-4.4 = .87
+LINUX_VERSION-4.4 = .87

LINUX_KERNEL_HASH-3.18.43 = 1236e8123a6ce537d5029232560966feed054ae31776fe8481dd7d18cdd5492c
-LINUX_KERNEL_HASH-4.4.87 = 1ab05222c3c55e062c3f7418976137ee529f92174261ccb0cd5a7d3370ff6f5b
+LINUX_KERNEL_HASH-4.4.87 = 1ab05222c3c55e062c3f7418976137ee529f92174261ccb0cd5a7d3370ff6f5b

ifdef KERNEL_PATCHVER
LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))

I ran the patch following the instructions on the website - lede 17.01 git clone, and patch clone..

I'm trying to build this custom firmware on my test router WR740N v4 first, before I go 'production' with the other two routers (WDR4300 v1, MR3420 v1).

How can I get past the patching error?


#540

Hi.
You need to remove two files before you run script.
./lede/patch/012-update-kernel-version.patch
./lede/patch/066-wireguard-update.patch

When you make image with make V=s, you will obteined a error compiling sfe library.

I'm doing to solve this error. I'll post this.


#541

Good Day Phiijohn,

I really hope to get your instruction about how to apply this Patch to the old Openwrt-14.07 version, the barrier breaker ,is it possible?

BB runs very fast and eats up much less memory and, one feature of Fast-Path is that it consumes less CPU resources, so if two can be compatible, seems good.

Under BB-target-linux-generic, it shows config-3.10 and patches-3.10, which is different from the current lede master , stable, or even openwrt-trunk, so is the Openwrt-CC , which has patches 3.18.

Is possible the discent patch can be applied to BB and CC? and how is the procedure?

Thank you so much and would really appreciate your direction.


#542

@philjohn hi Mr.Phil John, i wonder if this patch by discent can be applied to openwrt-14.07 barrier breaker? is that possible? what would need to be done before run the script patch? Thank you.


#543

@k3nny have you made it out on barrier breaker basis? How to do the patch properly, I really would like to learn from you guys.


#544

@jgvega @lucianor

I figured it out.

Instead of fixing patch for newer kernel. I have rolled back to kernel version 4.4.87 to match gwlim's patch by doing this:

git checkout ab305e147ed7f950e8b34d0de23797c8dbb6a27f

Then all i have to do is to remove wireguard, which I am not sure why it is no longer in the packages:
./lede/patch/066-wireguard-update.patch

Then the thing will be compiled and works. I have successfully build it and running the firmware just now.


#545

I've seen your mail but didn't have quite time to answer. svn.dd-wrt.com already contains needed changes for k3.10 that you may take, you just need to find it. It had been applied there something like 3-4 months ago.


#546

@dissent1 yes I did a mail , that was me lol . Really thank you and I know you have huge works to do. Ok I will check your link on ddwrt. Initially I wanted to send you by gmail as well but for the past two months the China great cyber firewall really gets stronger and I am not able to use Gmail even by deployment of shadowsocks proxy on my router.