Qualcomm Atheros QCA9886 802.11

Wifi ssid (5.7ghz) created for this radio does not work. I have correct country code and have tried changing channels.

I have tried restarting the radio and also have tried adding a new ssid for this. Also tried restarting the router.

It used to work in the past.

2.4ghz ap works perfectly.

any help with this issue? here are the specs of my install.

Hostname	OpenWrt_AP
Model	TP-Link Archer C60 v2
Architecture	Qualcomm Atheros QCA956X ver 1 rev 0
Target Platform	ath79/generic
Firmware Version	OpenWrt 23.05.3 r23809-234f1a2efa / LuCI openwrt-23.05 branch git-24.086.45142-09d5a38
Kernel Version	5.15.150
type or paste code here

doesn't really tell us anything.

  • it may mean that DFS discovery hasn't completed yet (so wait 11 minutes after any wireless config change/ reboot, before declaring defeat)
  • try a non-DFS channel, as in ch36
  • can you 'see' (e.g. scan for, using a smartphone app or other computer) the BSSID?
    there's a difference between the AP being 'up' and visible <> accepting connections from your clients

If you used auc, firmware-selector or similar convenience tools that modify the installed package set, don't - test with a vanilla -official- image, to rule out that you accidentally missed important packages (as in kernel modules). If in doubt, sysupgrade to the current 23.05.3 image again.

  • what does dmesg say about your radio, what error messages or warnings
  • can you actively scan the ether (iwinfo radio0 scan or iwinfo radio1 scan)

You may try ath10k-ct (preinstalled by default) vs ath10k (and their corresponding firmware packages).

1 Like

thanks, changing the channel seem to have fixed it.I was trying to avoid congestion in the neighborhood.
I changed the channel setting to auto now.
Hope the signal stays strong.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.